summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Woods <wwoods@gentoo.org>2002-10-25 17:16:58 +0000
committerWill Woods <wwoods@gentoo.org>2002-10-25 17:16:58 +0000
commitcf9dfcbb33bf68ae10c29cb5d0aa3bcaa070f9c1 (patch)
tree2a24d8b232d389360009eee3664e46381a229f14
parentNew eclass to update old config.guess and config.sub (diff)
downloadgentoo-2-cf9dfcbb33bf68ae10c29cb5d0aa3bcaa070f9c1.tar.gz
gentoo-2-cf9dfcbb33bf68ae10c29cb5d0aa3bcaa070f9c1.tar.bz2
gentoo-2-cf9dfcbb33bf68ae10c29cb5d0aa3bcaa070f9c1.zip
Added gnuconfig_update to solve compilation problems on alpha
-rw-r--r--sys-apps/bash/bash-2.05a-r3.ebuild6
-rw-r--r--sys-devel/m4/m4-1.4p.ebuild9
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r5.ebuild5
-rw-r--r--sys-libs/readline/readline-4.2a.ebuild10
4 files changed, 25 insertions, 5 deletions
diff --git a/sys-apps/bash/bash-2.05a-r3.ebuild b/sys-apps/bash/bash-2.05a-r3.ebuild
index 12ea577cd9ec..8f571c42eeca 100644
--- a/sys-apps/bash/bash-2.05a-r3.ebuild
+++ b/sys-apps/bash/bash-2.05a-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05a-r3.ebuild,v 1.4 2002/10/04 06:22:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05a-r3.ebuild,v 1.5 2002/10/25 17:16:48 wwoods Exp $
-inherit flag-o-matic
+inherit flag-o-matic gnuconfig
S=${WORKDIR}/${P}
DESCRIPTION="The standard GNU Bourne again shell"
@@ -24,6 +24,8 @@ src_unpack() {
#enable non-interactive login shells; this patch allows your prompt
#to be preserved when you start X and closes bug #1579.
cat ${FILESDIR}/config-top.h.diff | patch -p0 -l || die
+ # bash's config.sub doesn't recognize alphaev67. update it.
+ use alpha && gnuconfig_update
}
src_compile() {
diff --git a/sys-devel/m4/m4-1.4p.ebuild b/sys-devel/m4/m4-1.4p.ebuild
index 11a1e64e9aa1..acb1e723351f 100644
--- a/sys-devel/m4/m4-1.4p.ebuild
+++ b/sys-devel/m4/m4-1.4p.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4p.ebuild,v 1.9 2002/10/05 05:39:26 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4p.ebuild,v 1.10 2002/10/25 17:16:58 wwoods Exp $
+
+inherit gnuconfig
IUSE="nls"
@@ -19,6 +21,11 @@ DEPEND="virtual/glibc
RDEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A}
+ use alpha && gnuconfig_update
+}
+
src_compile() {
local myconf
if [ -z "`use nls`" ]
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
index 927bf91df79f..047d99669318 100644
--- a/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
+++ b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Chad Huneycutt <chad.huneycutt@acm.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild,v 1.10 2002/10/05 05:39:27 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild,v 1.11 2002/10/25 17:16:58 wwoods Exp $
+
+inherit gnuconfig
IUSE="berkdb"
@@ -23,6 +25,7 @@ src_unpack() {
unpack ${A}
cd ${WORKDIR}
patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+ use alpha && gnuconfig_update
}
src_compile() {
diff --git a/sys-libs/readline/readline-4.2a.ebuild b/sys-libs/readline/readline-4.2a.ebuild
index bd443ef715e0..df0e902bf341 100644
--- a/sys-libs/readline/readline-4.2a.ebuild
+++ b/sys-libs/readline/readline-4.2a.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.2a.ebuild,v 1.11 2002/10/16 09:50:09 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.2a.ebuild,v 1.12 2002/10/25 17:16:58 wwoods Exp $
+
+inherit gnuconfig
S=${WORKDIR}/${P}
DESCRIPTION="Another cute console display library"
@@ -16,6 +18,12 @@ DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r2
>=sys-apps/bash-2.05a-r3"
+src_unpack() {
+ unpack ${A}
+ # config.sub doesn't recognize alphaev67+, update it
+ use alpha && gnuconfig_update
+}
+
src_compile() {
./configure --host=${CHOST} --with-curses \