summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-04-21 01:59:35 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-04-21 01:59:35 +0000
commitcf6b8319aa417394febb6f961521079e55b26e77 (patch)
tree5e8740863bacaf76a77c329eee743ba04c11c1a9
parentFix RDEPEND for bug #217278 (diff)
downloadgentoo-2-cf6b8319aa417394febb6f961521079e55b26e77.tar.gz
gentoo-2-cf6b8319aa417394febb6f961521079e55b26e77.tar.bz2
gentoo-2-cf6b8319aa417394febb6f961521079e55b26e77.zip
Add GCC 4.3 patch. Bug #214138.
(Portage version: 2.2_pre5)
-rw-r--r--x11-apps/ttmkfdir/ChangeLog6
-rw-r--r--x11-apps/ttmkfdir/files/ttmkfdir-3.0.9-gcc43.patch9
-rw-r--r--x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild3
3 files changed, 16 insertions, 2 deletions
diff --git a/x11-apps/ttmkfdir/ChangeLog b/x11-apps/ttmkfdir/ChangeLog
index 94c74c1b6e1a..9f5d7f6fadea 100644
--- a/x11-apps/ttmkfdir/ChangeLog
+++ b/x11-apps/ttmkfdir/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-apps/ttmkfdir
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ChangeLog,v 1.6 2008/03/26 03:58:11 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ChangeLog,v 1.7 2008/04/21 01:59:35 dirtyepic Exp $
+
+ 21 Apr 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/ttmkfdir-3.0.9-gcc43.patch, ttmkfdir-3.0.9-r3.ebuild:
+ Add GCC 4.3 patch. Bug #214138.
26 Mar 2008; <ricmm@gentoo.org> ttmkfdir-3.0.9-r3.ebuild:
Drop to ~mips due to unstable deps
diff --git a/x11-apps/ttmkfdir/files/ttmkfdir-3.0.9-gcc43.patch b/x11-apps/ttmkfdir/files/ttmkfdir-3.0.9-gcc43.patch
new file mode 100644
index 000000000000..dbdd655ca6e4
--- /dev/null
+++ b/x11-apps/ttmkfdir/files/ttmkfdir-3.0.9-gcc43.patch
@@ -0,0 +1,9 @@
+diff -Naurp ttmkfdir-3.0.9-orig/directory.cpp ttmkfdir-3.0.9/directory.cpp
+--- ttmkfdir-3.0.9-orig/directory.cpp 2008-04-20 19:48:00.000000000 -0600
++++ ttmkfdir-3.0.9/directory.cpp 2008-04-20 19:48:39.000000000 -0600
+@@ -1,4 +1,5 @@
+ #include <cctype>
++#include <cstring>
+ #include <dirent.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
diff --git a/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild b/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild
index 0184bb329731..4b1f99da78e9 100644
--- a/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild
+++ b/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild,v 1.6 2008/03/26 03:58:11 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild,v 1.7 2008/04/21 01:59:35 dirtyepic Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -28,6 +28,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-encoding.patch
# fix pack to work with new freetype include scheme (#44119)
epatch "${FILESDIR}"/${P}-freetype_new_includes.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch # 214138
# Install into regular filesystem, not /usr/X11R6 hierarchy
sed -i "s:/usr/X11R6:/usr:" README ttmkfdir.cpp