summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-19 08:43:58 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-19 08:43:58 +0000
commitcc6b9605894b6d820edbad99596f2b8ffbb28089 (patch)
tree2daa7dfa925fe0a8ffb8dcd095de26a6ac458535
parentVersion bump. (diff)
downloadgentoo-2-cc6b9605894b6d820edbad99596f2b8ffbb28089.tar.gz
gentoo-2-cc6b9605894b6d820edbad99596f2b8ffbb28089.tar.bz2
gentoo-2-cc6b9605894b6d820edbad99596f2b8ffbb28089.zip
Version bump for bug #416363, thanks to Christoph Brill (egore). Now properly installs udev rules.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
-rw-r--r--dev-libs/libwacom/ChangeLog10
-rw-r--r--dev-libs/libwacom/files/libwacom-0.5-eraser-bamboo.patch35
-rw-r--r--dev-libs/libwacom/files/libwacom-0.5-eraser.patch34
-rw-r--r--dev-libs/libwacom/libwacom-0.5.ebuild48
4 files changed, 126 insertions, 1 deletions
diff --git a/dev-libs/libwacom/ChangeLog b/dev-libs/libwacom/ChangeLog
index b21dcda54a09..e1a81e247bc5 100644
--- a/dev-libs/libwacom/ChangeLog
+++ b/dev-libs/libwacom/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libwacom
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwacom/ChangeLog,v 1.2 2012/05/04 18:35:48 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwacom/ChangeLog,v 1.3 2012/05/19 08:43:58 tetromino Exp $
+
+*libwacom-0.5 (19 May 2012)
+
+ 19 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libwacom-0.5.ebuild, +files/libwacom-0.5-eraser.patch,
+ +files/libwacom-0.5-eraser-bamboo.patch:
+ Version bump for bug #416363, thanks to Christoph Brill (egore). Now properly
+ installs udev rules.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> libwacom-0.4.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-libs/libwacom/files/libwacom-0.5-eraser-bamboo.patch b/dev-libs/libwacom/files/libwacom-0.5-eraser-bamboo.patch
new file mode 100644
index 000000000000..25f722e57878
--- /dev/null
+++ b/dev-libs/libwacom/files/libwacom-0.5-eraser-bamboo.patch
@@ -0,0 +1,35 @@
+From f2845accd942e44238edf030f6bd918f9d88838e Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Thu, 3 May 2012 09:24:32 +1000
+Subject: [PATCH] data: add generic eraser to Bamboo Pen & Touch
+
+Crashes gnome-control-center without it.
+
+(gnome-control-center:18115): wacom-cc-panel-WARNING **: Could not set the
+current stylus ID 0x0 for tablet 'Wacom Bamboo Pen & Touch', no general pen
+found
+wacom-cc-panel:ERROR:gsd-wacom-device.c:1491:gsd_wacom_device_set_current_stylus:
+assertion failed: (device->priv->styli)
+
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+Reviewed-by: Ping Cheng <pinglinux@gmail.com>
+---
+ data/bamboo-pen-and-touch.tablet | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/data/bamboo-pen-and-touch.tablet b/data/bamboo-pen-and-touch.tablet
+index 125db37..3fff338 100644
+--- a/data/bamboo-pen-and-touch.tablet
++++ b/data/bamboo-pen-and-touch.tablet
+@@ -13,7 +13,7 @@ Width=6
+ Height=4
+
+ # The other stylusses don't match it, it has two buttons and an eraser.
+-Styli=0xfffff
++Styli=0xfffff;0xffffe;
+
+ [Features]
+ Stylus=true
+--
+1.7.8.6
+
diff --git a/dev-libs/libwacom/files/libwacom-0.5-eraser.patch b/dev-libs/libwacom/files/libwacom-0.5-eraser.patch
new file mode 100644
index 000000000000..2e0791eb089d
--- /dev/null
+++ b/dev-libs/libwacom/files/libwacom-0.5-eraser.patch
@@ -0,0 +1,34 @@
+From 17eb272e0cc6dd8404d210770ab9c2c0c9624a09 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 2 May 2012 16:57:04 +0100
+Subject: [PATCH] lib: Fix generic stylus missing an eraser
+
+HasEraser=yes, but we didn't add an eraser for the stylus,
+leading to bugs in the display UI for consumer products.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=675299
+---
+ libwacom/libwacom-database.c | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/libwacom/libwacom-database.c b/libwacom/libwacom-database.c
+index 0c60d6d..9fc9e35 100644
+--- a/libwacom/libwacom-database.c
++++ b/libwacom/libwacom-database.c
+@@ -369,9 +369,10 @@ libwacom_parse_tablet_keyfile(const char *path)
+ g_strfreev (styli_list);
+ device->supported_styli = (int *) g_array_free (array, FALSE);
+ } else {
+- device->supported_styli = g_new (int, 1);
+- *device->supported_styli = 0xfffff;
+- device->num_styli = 1;
++ device->supported_styli = g_new (int, 2);
++ device->supported_styli[0] = WACOM_STYLUS_FALLBACK_ID;
++ device->supported_styli[1] = WACOM_ERASER_FALLBACK_ID;
++ device->num_styli = 2;
+ }
+
+ /* Features */
+--
+1.7.8.6
+
diff --git a/dev-libs/libwacom/libwacom-0.5.ebuild b/dev-libs/libwacom/libwacom-0.5.ebuild
new file mode 100644
index 000000000000..60866c057151
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwacom/libwacom-0.5.ebuild,v 1.1 2012/05/19 08:43:58 tetromino Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/glib:2
+ sys-fs/udev[gudev]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # in next release
+ epatch "${FILESDIR}/${P}-eraser.patch"
+ epatch "${FILESDIR}/${P}-eraser-bamboo.patch"
+
+ if ! use doc; then
+ sed -e 's:^\(SUBDIRS = .* \)doc:\1:' -i Makefile.in || die "sed failed"
+ fi
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodir /lib/udev/rules.d
+ # generate-udev-rules must be run from inside tools directory
+ pushd tools > /dev/null
+ ./generate-udev-rules > "${ED}/lib/udev/rules.d/65-libwacom.rules" ||
+ die "generating udev rules failed"
+ popd > /dev/null
+ use doc && dohtml -r doc/html/*
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+}