summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-02-21 19:44:50 +0000
committerSamuli Suominen <drac@gentoo.org>2007-02-21 19:44:50 +0000
commitcb5a427afe6778be2637d6e8d17213cb3757301a (patch)
tree55c8e192a546e767561977c8d76619a647a6a11c
parentTransition to Manifest2. (diff)
downloadgentoo-2-cb5a427afe6778be2637d6e8d17213cb3757301a.tar.gz
gentoo-2-cb5a427afe6778be2637d6e8d17213cb3757301a.tar.bz2
gentoo-2-cb5a427afe6778be2637d6e8d17213cb3757301a.zip
Fix bugs 167768 166992 161592.
(Portage version: 2.1.2-r10)
-rw-r--r--x11-themes/tango-icon-theme/ChangeLog10
-rw-r--r--x11-themes/tango-icon-theme/files/digest-tango-icon-theme-0.8.03
-rw-r--r--x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild45
3 files changed, 56 insertions, 2 deletions
diff --git a/x11-themes/tango-icon-theme/ChangeLog b/x11-themes/tango-icon-theme/ChangeLog
index e186bb5b4c1e..c388224f9db5 100644
--- a/x11-themes/tango-icon-theme/ChangeLog
+++ b/x11-themes/tango-icon-theme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/tango-icon-theme
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/ChangeLog,v 1.22 2006/09/30 19:32:32 dang Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/ChangeLog,v 1.23 2007/02/21 19:44:50 drac Exp $
+
+*tango-icon-theme-0.8.0 (21 Feb 2007)
+
+ 21 Feb 2007; Samuli Suominen <drac@gentoo.org>
+ +tango-icon-theme-0.8.0.ebuild:
+ Fix bugs 167768 166992 161592.
30 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
tango-icon-theme-0.7.2.ebuild:
diff --git a/x11-themes/tango-icon-theme/files/digest-tango-icon-theme-0.8.0 b/x11-themes/tango-icon-theme/files/digest-tango-icon-theme-0.8.0
new file mode 100644
index 000000000000..6a6d5bf275c7
--- /dev/null
+++ b/x11-themes/tango-icon-theme/files/digest-tango-icon-theme-0.8.0
@@ -0,0 +1,3 @@
+MD5 feb1870e84b99ea41db9b51a448c59f8 tango-icon-theme-0.8.0.tar.gz 1770650
+RMD160 02a7c384f4640b978c7cb1413f3ca5888113676f tango-icon-theme-0.8.0.tar.gz 1770650
+SHA256 6745cb47b9b0d54bfec7cc0a77c0789cf41935b04f9c8f7c4a78e165cf92e419 tango-icon-theme-0.8.0.tar.gz 1770650
diff --git a/x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild
new file mode 100644
index 000000000000..cdb960784a21
--- /dev/null
+++ b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/tango-icon-theme-0.8.0.ebuild,v 1.1 2007/02/21 19:44:50 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="SVG icon theme from the Tango project"
+HOMEPAGE="http://tango-project.org/"
+SRC_URI="http://tango-project.org/releases/${P}.tar.gz"
+
+LICENSE="CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="png"
+
+RESTRICT="binchecks strip"
+
+RDEPEND=">=x11-misc/icon-naming-utils-0.8.2
+ media-gfx/imagemagick
+ >=gnome-base/librsvg-2.12.3"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.33
+ sys-devel/gettext"
+
+pkg_setup() {
+ if use png && ! built_with_use media-gfx/imagemagick png; then
+ die "Build media-gfx/imagemagick with USE=png."
+ fi
+}
+
+src_compile() {
+ if use png; then
+ econf --enable-png-creation
+ else
+ econf
+ fi
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}