summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-02 23:41:54 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-02 23:41:54 +0000
commitc9aaede5732e41e3fd21683798253d986837eca6 (patch)
tree922dc1b30c7fe25ac56d4c1d020d1309ffc98329
parentMigrate to python-r1. (diff)
downloadgentoo-2-c9aaede5732e41e3fd21683798253d986837eca6.tar.gz
gentoo-2-c9aaede5732e41e3fd21683798253d986837eca6.tar.bz2
gentoo-2-c9aaede5732e41e3fd21683798253d986837eca6.zip
Migrate to python-any-r1 (strictly build-time dependency on Python).
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-3.2.ebuild29
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild29
3 files changed, 35 insertions, 29 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 224329a3ef11..8406b534ccc2 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.105 2013/01/17 13:44:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.106 2013/02/02 23:41:54 mgorny Exp $
+
+ 02 Feb 2013; Michał Górny <mgorny@gentoo.org> llvm-3.2.ebuild,
+ llvm-9999.ebuild:
+ Migrate to python-any-r1 (strictly build-time dependency on Python).
17 Jan 2013; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.2.ebuild,
metadata.xml:
diff --git a/sys-devel/llvm/llvm-3.2.ebuild b/sys-devel/llvm/llvm-3.2.ebuild
index 8140d14cc211..e25a0d71de8a 100644
--- a/sys-devel/llvm/llvm-3.2.ebuild
+++ b/sys-devel/llvm/llvm-3.2.ebuild
@@ -1,10 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.2.ebuild,v 1.4 2013/01/17 13:44:07 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.2.ebuild,v 1.5 2013/02/02 23:41:54 mgorny Exp $
EAPI=5
-PYTHON_DEPEND="2"
-inherit eutils flag-o-matic multilib toolchain-funcs python pax-utils
+
+# pypy gives me around 1700 unresolved tests due to open file limit
+# being exceeded. probably GC does not close them fast enough.
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils flag-o-matic multilib python-any-r1 toolchain-funcs pax-utils
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
@@ -27,7 +31,8 @@ DEPEND="dev-lang/perl
libffi? ( virtual/pkgconfig
virtual/libffi )
ocaml? ( dev-lang/ocaml )
- udis86? ( dev-libs/udis86[pic(+)] )"
+ udis86? ( dev-libs/udis86[pic(+)] )
+ ${PYTHON_DEPS}"
RDEPEND="dev-lang/perl
libffi? ( virtual/libffi )
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
@@ -36,8 +41,7 @@ S=${WORKDIR}/${P}.src
pkg_setup() {
# Required for test and build
- python_set_active_version 2
- python_pkg_setup
+ python-any-r1_pkg_setup
# need to check if the active compiler is ok
@@ -64,12 +68,12 @@ pkg_setup() {
if [[ ${CHOST} == x86_64-* && ${broken_gcc_amd64} == *" ${version} "* ]];
then
- elog "Your version of gcc is known to miscompile llvm in amd64"
- elog "architectures. Check"
- elog "http://www.llvm.org/docs/GettingStarted.html for possible"
- elog "solutions."
+ elog "Your version of gcc is known to miscompile llvm in amd64"
+ elog "architectures. Check"
+ elog "http://www.llvm.org/docs/GettingStarted.html for possible"
+ elog "solutions."
die "Your currently active version of gcc is known to miscompile llvm"
- fi
+ fi
}
src_prepare() {
@@ -96,9 +100,6 @@ src_prepare() {
sed -e "/NO_INSTALL = 1/s/^/#/" -i utils/FileCheck/Makefile \
|| die "FileCheck Makefile sed failed"
- # Specify python version
- python_convert_shebangs -r 2 test/Scripts
-
epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.0-PPC_macro.patch
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 786cba412cf5..7c109cad0dc5 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,10 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.38 2013/01/07 20:22:12 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.39 2013/02/02 23:41:54 mgorny Exp $
EAPI=5
-PYTHON_DEPEND="2"
-inherit subversion eutils flag-o-matic multilib toolchain-funcs python pax-utils
+
+# pypy gives me around 1700 unresolved tests due to open file limit
+# being exceeded. probably GC does not close them fast enough.
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit subversion eutils flag-o-matic multilib python-any-r1 toolchain-funcs pax-utils
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
@@ -27,15 +31,15 @@ DEPEND="dev-lang/perl
libffi? ( virtual/pkgconfig
virtual/libffi )
ocaml? ( dev-lang/ocaml )
- udis86? ( dev-libs/udis86[pic(+)] )"
+ udis86? ( dev-libs/udis86[pic(+)] )
+ ${PYTHON_DEPS}"
RDEPEND="dev-lang/perl
libffi? ( virtual/libffi )
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
pkg_setup() {
# Required for test and build
- python_set_active_version 2
- python_pkg_setup
+ python-any-r1_pkg_setup
# need to check if the active compiler is ok
@@ -62,12 +66,12 @@ pkg_setup() {
if [[ ${CHOST} == x86_64-* && ${broken_gcc_amd64} == *" ${version} "* ]];
then
- elog "Your version of gcc is known to miscompile llvm in amd64"
- elog "architectures. Check"
- elog "http://www.llvm.org/docs/GettingStarted.html for possible"
- elog "solutions."
+ elog "Your version of gcc is known to miscompile llvm in amd64"
+ elog "architectures. Check"
+ elog "http://www.llvm.org/docs/GettingStarted.html for possible"
+ elog "solutions."
die "Your currently active version of gcc is known to miscompile llvm"
- fi
+ fi
}
src_prepare() {
@@ -94,9 +98,6 @@ src_prepare() {
sed -e "/NO_INSTALL = 1/s/^/#/" -i utils/FileCheck/Makefile \
|| die "FileCheck Makefile sed failed"
- # Specify python version
- python_convert_shebangs -r 2 test/Scripts
-
epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.0-PPC_macro.patch