summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-23 15:36:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-23 15:36:30 +0000
commitc957c348318a16cc3950c02b8f391f1c17c44c93 (patch)
tree4af3fe393436f82d6def2e320261334762882d22
parentFix segmentation fault with false options e.g. "fuser --help" wrt #297423 and... (diff)
downloadgentoo-2-c957c348318a16cc3950c02b8f391f1c17c44c93.tar.gz
gentoo-2-c957c348318a16cc3950c02b8f391f1c17c44c93.tar.bz2
gentoo-2-c957c348318a16cc3950c02b8f391f1c17c44c93.zip
Fix building with USE="-nls" wrt #237046 by Christophe LEFEBVRE.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
-rw-r--r--x11-misc/grun/ChangeLog10
-rw-r--r--x11-misc/grun/files/grun-0.9.3-no_nls.patch12
-rw-r--r--x11-misc/grun/grun-0.9.3-r1.ebuild60
3 files changed, 80 insertions, 2 deletions
diff --git a/x11-misc/grun/ChangeLog b/x11-misc/grun/ChangeLog
index 2533e50a5922..6f604fb391ea 100644
--- a/x11-misc/grun/ChangeLog
+++ b/x11-misc/grun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/grun
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/ChangeLog,v 1.29 2009/02/02 23:56:08 nelchael Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/ChangeLog,v 1.30 2009/12/23 15:36:29 ssuominen Exp $
+
+*grun-0.9.3-r1 (23 Dec 2009)
+
+ 23 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> +grun-0.9.3-r1.ebuild,
+ +files/grun-0.9.3-no_nls.patch:
+ Fix building with USE="-nls" wrt #237046 by Christophe LEFEBVRE.
02 Feb 2009; Krzysiek Pawlik <nelchael@gentoo.org> ChangeLog:
Fix ChangeLog entries.
diff --git a/x11-misc/grun/files/grun-0.9.3-no_nls.patch b/x11-misc/grun/files/grun-0.9.3-no_nls.patch
new file mode 100644
index 000000000000..52acf68a4c05
--- /dev/null
+++ b/x11-misc/grun/files/grun-0.9.3-no_nls.patch
@@ -0,0 +1,12 @@
+diff -ur grun-0.9.3.orig/grun.c grun-0.9.3/grun.c
+--- grun-0.9.3.orig/grun.c 2008-01-14 08:28:10.000000000 +0200
++++ grun-0.9.3/grun.c 2009-12-23 17:34:34.000000000 +0200
+@@ -30,8 +30,6 @@
+
+ #if defined (HAVE_GETTEXT) || defined (HAVE_CATGETS)
+ #include <libintl.h>
+-#else
+-#include "intl/libintl.h"
+ #endif
+
+ #define PATH_CHAR ":"
diff --git a/x11-misc/grun/grun-0.9.3-r1.ebuild b/x11-misc/grun/grun-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..981296c7e3a6
--- /dev/null
+++ b/x11-misc/grun/grun-0.9.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/grun-0.9.3-r1.ebuild,v 1.1 2009/12/23 15:36:29 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="a GTK+ application launcher with nice features such as a history"
+HOMEPAGE="http://code.google.com/p/grun/"
+SRC_URI="http://grun.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no_nls.patch
+}
+
+src_configure() {
+ [[ -z ${TERM} ]] && TERM=xterm
+
+ econf \
+ $(use_enable nls) \
+ --disable-gtktest \
+ --enable-testfile \
+ --enable-associations \
+ --with-default-xterm=${TERM}
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "It is recommended to bind grun to a keychain. Fluxbox users can"
+ elog "do this by appending e.g. the following line to ~/.fluxbox/keys:"
+ elog
+ elog "Mod4 r :ExecCommand grun"
+ elog
+ elog "Then reconfigure Fluxbox (using the menu) and hit <WinKey>-<r>"
+ elog
+ elog "The default system-wide definition file for associating file"
+ elog "extensions with applications is /usr/share/grun/gassoc, the"
+ elog "default system-wide definition file for recognized console"
+ elog "applications is /usr/share/grun/consfile. They can be overridden"
+ elog "on a per user basis by ~/.gassoc and ~/.consfile respectively."
+ elog
+ elog "To change the default terminal application grun uses, adjust the"
+ elog "TERM environment variable accordingly and remerge grun, e.g."
+ elog
+ elog "TERM=Eterm emerge grun"
+}