summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-30 07:33:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-30 07:33:24 +0000
commitc7a89ce0af4ba2ad1218f8602b70547dc33edf66 (patch)
treeb1da5bbbe372cfcaa7305ef7c9493da5efe02696
parentInitial import, ebuild by me (diff)
downloadgentoo-2-c7a89ce0af4ba2ad1218f8602b70547dc33edf66.tar.gz
gentoo-2-c7a89ce0af4ba2ad1218f8602b70547dc33edf66.tar.bz2
gentoo-2-c7a89ce0af4ba2ad1218f8602b70547dc33edf66.zip
Version bump
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
-rw-r--r--sci-mathematics/gretl/ChangeLog9
-rw-r--r--sci-mathematics/gretl/gretl-1.9.11.ebuild (renamed from sci-mathematics/gretl/gretl-1.9.8.ebuild)35
-rw-r--r--sci-mathematics/gretl/gretl-1.9.7.ebuild114
3 files changed, 20 insertions, 138 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index a3ff9f94c5c9..c0e0675ecfa6 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.39 2012/06/10 18:46:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.40 2012/11/30 07:33:23 bicatali Exp $
+
+*gretl-1.9.11 (30 Nov 2012)
+
+ 30 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> +gretl-1.9.11.ebuild,
+ -gretl-1.9.7.ebuild, -gretl-1.9.8.ebuild:
+ Version bump
*gretl-1.9.9 (10 Jun 2012)
@@ -212,4 +218,3 @@
07 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+gretl-1.6.5.ebuild:
Initial import. Close bug #39966. Thanks everyone in the bug who helped.
-
diff --git a/sci-mathematics/gretl/gretl-1.9.8.ebuild b/sci-mathematics/gretl/gretl-1.9.11.ebuild
index 884bb29a2650..6d3925baf2bf 100644
--- a/sci-mathematics/gretl/gretl-1.9.8.ebuild
+++ b/sci-mathematics/gretl/gretl-1.9.11.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.8.ebuild,v 1.3 2012/06/10 18:46:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.11.ebuild,v 1.1 2012/11/30 07:33:23 bicatali Exp $
EAPI=4
USE_EINSTALL=true
-inherit eutils gnome2 elisp-common toolchain-funcs
+inherit eutils elisp-common toolchain-funcs
DESCRIPTION="Regression, econometrics and time-series library"
HOMEPAGE="http://gretl.sourceforge.net/"
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="accessibility emacs gnome gtk nls odbc openmp readline sse2 R static-libs"
RDEPEND="
@@ -31,13 +31,8 @@ RDEPEND="
gtk? (
media-libs/gd[png]
sci-visualization/gnuplot[gd]
- x11-libs/gtk+:2
- x11-libs/gtksourceview:2.0 )
- gnome? (
- media-libs/gd[png]
- sci-visualization/gnuplot[gd]
- gnome-base/libgnomeui
- gnome-base/gconf:2 )
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0 )
odbc? ( dev-db/unixODBC )
R? ( dev-lang/R )
readline? ( sys-libs/readline )"
@@ -61,36 +56,32 @@ src_configure() {
--enable-shared \
--with-mpfr \
$(use_enable gtk gui) \
+ $(use_enable gtk gtk3) \
+ $(use_enable gtk xdg) \
+ $(use_enable gtk xdg-utils) \
$(use_enable nls) \
$(use_enable openmp) \
$(use_enable sse2) \
$(use_enable static-libs static) \
$(use_with accessibility audio) \
- $(use_with gnome) \
$(use_with odbc) \
$(use_with readline) \
$(use_with R libR) \
${myconf} \
- LAPACK_LIBS="$(pkg-config --libs lapack)"
+ LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
}
src_compile() {
emake
if use emacs; then
- elisp-compile utils/emacs/gretl.el || die "elisp-compile failed"
+ cd utils/emacs && emake
+ elisp-compile gretl.el || die "elisp-compile failed"
fi
}
src_install() {
- if use gnome; then
- gnome2_src_install gnome_prefix="${ED}"/usr svprefix="${ED}usr"
- else
- einstall svprefix="${ED}usr"
- fi
- if use gtk && ! use gnome; then
- doicon gnome/gretl.png
- make_desktop_entry gretl_x11 gretl
- fi
+ # to fix
+ emake -j1 DESTDIR="${D}" install
if use emacs; then
elisp-install ${PN} utils/emacs/gretl.{el,elc} \
|| die "elisp-install failed"
diff --git a/sci-mathematics/gretl/gretl-1.9.7.ebuild b/sci-mathematics/gretl/gretl-1.9.7.ebuild
deleted file mode 100644
index 37c06d9ec20f..000000000000
--- a/sci-mathematics/gretl/gretl-1.9.7.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.7.ebuild,v 1.4 2012/06/10 18:46:32 jlec Exp $
-
-EAPI=4
-
-USE_EINSTALL=true
-
-inherit eutils gnome2 elisp-common toolchain-funcs
-
-DESCRIPTION="Regression, econometrics and time-series library"
-HOMEPAGE="http://gretl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="accessibility emacs gnome gtk nls odbc openmp readline sse2 R static-libs"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/gmp
- dev-libs/libxml2:2
- dev-libs/mpfr
- sci-libs/fftw:3.0
- sci-visualization/gnuplot
- virtual/lapack
- virtual/latex-base
- readline? ( sys-libs/readline )
- accessibility? ( app-accessibility/flite )
- gtk? (
- media-libs/gd[png]
- sci-visualization/gnuplot[gd]
- x11-libs/gtk+:2
- x11-libs/gtksourceview:2.0 )
- gnome? (
- sci-visualization/gnuplot[gd]
- media-libs/gd[png]
- gnome-base/libgnomeui
- gnome-base/gconf:2 )
- R? ( dev-lang/R )
- odbc? ( dev-db/unixODBC )
- emacs? ( virtual/emacs )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
- if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp
- then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
- die "Need an OpenMP capable compiler"
- fi
-}
-
-src_configure() {
- econf \
- --disable-rpath \
- --enable-shared \
- --with-mpfr \
- $(use_enable gtk gui) \
- $(use_enable nls) \
- $(use_enable openmp) \
- $(use_enable sse2) \
- $(use_enable static-libs static) \
- $(use_with accessibility audio) \
- $(use_with gnome) \
- $(use_with odbc) \
- $(use_with readline) \
- $(use_with R libR) \
- ${myconf} \
- LAPACK_LIBS="$(pkg-config --libs lapack)"
-}
-
-src_compile() {
- emake
- if use emacs; then
- elisp-compile utils/emacs/gretl.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- if use gnome; then
- gnome2_src_install gnome_prefix="${ED}"/usr svprefix="${ED}usr"
- else
- einstall svprefix="${ED}usr"
- fi
- if use gtk && ! use gnome; then
- doicon gnome/gretl.png
- make_desktop_entry gretl_x11 gretl
- fi
- if use emacs; then
- elisp-install ${PN} utils/emacs/gretl.{el,elc} \
- || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
- || die "elisp-site-file-install failed"
- fi
- dodoc README README.audio ChangeLog CompatLog
-}
-
-pkg_postinst() {
- if use emacs; then
- elisp-site-regen
- elog "To begin using gretl-mode for all \".inp\" files that you edit,"
- elog "add the following line to your \"~/.emacs\" file:"
- elog " (add-to-list 'auto-mode-alist '(\"\\\\.inp\\\\'\" . gretl-mode))"
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}