summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <cbrannon@gentoo.org>2011-04-11 19:09:42 +0000
committerChristopher Brannon <cbrannon@gentoo.org>2011-04-11 19:09:42 +0000
commitc6665a52ae0d4fc2a5b4671e784eb926a6e17cee (patch)
treece9af9be020d271fa21fdf277f99352a37bd1f04
parentVersion bump. (diff)
downloadgentoo-2-c6665a52ae0d4fc2a5b4671e784eb926a6e17cee.tar.gz
gentoo-2-c6665a52ae0d4fc2a5b4671e784eb926a6e17cee.tar.bz2
gentoo-2-c6665a52ae0d4fc2a5b4671e784eb926a6e17cee.zip
Add latest version to the tree, remove the older unstable version.
3.4.7 is here. 3.4.6 was never stabilized. It had flaws, like the use of memcpy on overlapping regions. No need to keep it in the tree. (Portage version: 2.1.9.45/cvs/Linux i686)
-rw-r--r--app-accessibility/edbrowse/ChangeLog15
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.4.7.ebuild (renamed from app-accessibility/edbrowse/edbrowse-3.4.6.ebuild)7
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch54
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch13
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.4.7-fix-makefile.patch13
5 files changed, 30 insertions, 72 deletions
diff --git a/app-accessibility/edbrowse/ChangeLog b/app-accessibility/edbrowse/ChangeLog
index bd12b70e7d56..a19406408667 100644
--- a/app-accessibility/edbrowse/ChangeLog
+++ b/app-accessibility/edbrowse/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for app-accessibility/edbrowse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/ChangeLog,v 1.3 2011/03/28 20:05:10 cbrannon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/ChangeLog,v 1.4 2011/04/11 19:09:41 cbrannon Exp $
+
+*edbrowse-3.4.7 (11 Apr 2011)
+
+ 11 Apr 2011; Christopher Brannon <cbrannon@gentoo.org>
+ -edbrowse-3.4.6.ebuild, -files/edbrowse-3.4.6-fix-makefile.patch,
+ -files/edbrowse-3.4.6-fix-off-by-one.patch, +edbrowse-3.4.7.ebuild,
+ +files/edbrowse-3.4.7-fix-makefile.patch:
+ Add latest version to the tree, remove the older unstable version.
+
+ 3.4.7 is here.
+ 3.4.6 was never stabilized.
+ It had flaws, like the use of memcpy on overlapping regions.
+ No need to keep it in the tree.
28 Mar 2011; Christopher Brannon <cbrannon@gentoo.org>
edbrowse-3.4.6.ebuild, files/edbrowse-3.4.6-fix-makefile.patch,
diff --git a/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild b/app-accessibility/edbrowse/edbrowse-3.4.7.ebuild
index 0aa9a56725aa..c108d51ae5fc 100644
--- a/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild
+++ b/app-accessibility/edbrowse/edbrowse-3.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild,v 1.3 2011/03/28 20:05:10 cbrannon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/edbrowse-3.4.7.ebuild,v 1.1 2011/04/11 19:09:41 cbrannon Exp $
EAPI="4"
inherit eutils
@@ -24,7 +24,6 @@ RDEPEND="${COMMON_DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-fix-makefile.patch
- epatch "${FILESDIR}"/${P}-fix-off-by-one.patch
}
src_compile() {
@@ -34,11 +33,11 @@ src_compile() {
JSLIB=-lmozjs
fi
- emake prefix=/usr JSLIB="${JSLIB}"
+ emake prefix=/usr JSLIB="${JSLIB}" STRIP=''
if use odbc; then
# Top-level makefile doesn't have this target.
cd src
- emake prefix=/usr edbrowseodbc
+ emake prefix=/usr STRIP='' edbrowseodbc
cd ..
fi
}
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch
deleted file mode 100644
index e44710210645..000000000000
--- a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -Naur edbrowse-3.4.6/src/makefile edbrowse-3.4.6-new/src/makefile
---- edbrowse-3.4.6/src/makefile 2011-01-20 10:38:24.000000000 +0000
-+++ edbrowse-3.4.6-new/src/makefile 2011-03-28 14:02:25.000000000 +0000
-@@ -23,12 +23,15 @@
- STRIP=-s
- endif
-
--CFLAGS = -I/usr/local/js/src -I/usr/local/js/src/Linux_All_DBG.OBJ -DXP_UNIX -DX86_LINUX $(DEBUGFLAGS)
-+JSFLAGS = -I/usr/include/js -DXP_UNIX
-+
-+%.o: %.c
-+ $(CC) $(CFLAGS) $(JSFLAGS) -c -o $@ $<
-
- # If the smjs library is already installed by your linux distribution,
- # e.g. Debian, use the following flags.
- #
--#CFLAGS = -I/usr/include/js -DXP_UNIX -DX86_LINUX $(DEBUGFLAGS)
-+#CFLAGS = -I/usr/include/smjs -DXP_UNIX -DX86_LINUX $(DEBUGFLAGS)
-
- # Normal load flags
- LFLAGS = $(STRIP)
-@@ -45,7 +48,8 @@
- # Or you can use the target jslink below.
- # Some folks need to add -lcrypto to this list.
-
--LIBS = -lpcre -lm -lssl -ljs -lcurl -lreadline
-+JSLIB = -ljs
-+LIBS = -lpcre -lm -lssl $(JSLIB) -lcurl -lreadline
-
- # Make the dynamically linked executable program by default.
- # Edbrowse executable.
-@@ -59,11 +63,11 @@
- $(EBOBJS) : eb.h eb.p messages.h tcp.h
-
- edbrowse: $(EBOBJS) tcp.o dbstubs.o
-- cc $(LFLAGS) -o edbrowse $(EBOBJS) tcp.o dbstubs.o $(LIBS)
-+ $(CC) $(LDFLAGS) -o edbrowse $(EBOBJS) tcp.o dbstubs.o $(LIBS)
-
- # You probably need to be root to do this.
- install:
-- install -Dm755 edbrowse $(bindir)/edbrowse
-+ install -Dm755 edbrowse $(DESTDIR)$(bindir)/edbrowse
-
- # If you had to build the javascript library yourself,
- # link it into /usr/lib.
-@@ -87,7 +91,7 @@
-
- # odbc access
- edbrowseodbc: $(EBOBJS) tcp.o dbops.o dbodbc.o
-- cc $(LFLAGS) -o edbrowseodbc $(EBOBJS) tcp.o dbops.o dbodbc.o $(LIBS) -lodbc
-+ $(CC) $(LDFLAGS) -o edbrowseodbc $(EBOBJS) tcp.o dbops.o dbodbc.o $(LIBS) -lodbc
-
- # Build function prototypes.
- # mkproto is my program, not a general unix utility.
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch
deleted file mode 100644
index 324d43d231ba..000000000000
--- a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/buffers.c b/src/buffers.c
-index fe0d50a..4a37d58 100644
---- a/src/buffers.c
-+++ b/src/buffers.c
-@@ -2590,7 +2590,7 @@ substituteText(const char *line)
- replaceLine[replaceLineLen] = '\n';
- if(!linecount) {
- /* normal substitute */
-- char newnum[LNWIDTH];
-+ char newnum[LNWIDTH+1];
- textLines[textLinesCount] = allocMem(replaceLineLen + 1);
- memcpy(textLines[textLinesCount], replaceLine,
- replaceLineLen + 1);
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.4.7-fix-makefile.patch b/app-accessibility/edbrowse/files/edbrowse-3.4.7-fix-makefile.patch
new file mode 100644
index 000000000000..142c6ab33b85
--- /dev/null
+++ b/app-accessibility/edbrowse/files/edbrowse-3.4.7-fix-makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/src/makefile b/src/makefile
+index 900c425..af1250e 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -59,7 +59,7 @@ edbrowse: $(EBOBJS) tcp.o dbstubs.o
+
+ # You probably need to be root to do this.
+ install:
+- install -Dm755 edbrowse $(bindir)/edbrowse
++ install -Dm755 edbrowse $(DESTDIR)$(bindir)/edbrowse
+
+ # If you had to build the javascript library yourself,
+ # link it into /usr/lib.