summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-07-06 18:58:42 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-07-06 18:58:42 +0000
commitc313b227dcb442e446eeed1d4e769e53e5a09a3f (patch)
tree4c4f43599d6f2469e72a76e36f0ab60773503cdc
parentremove old (diff)
downloadgentoo-2-c313b227dcb442e446eeed1d4e769e53e5a09a3f.tar.gz
gentoo-2-c313b227dcb442e446eeed1d4e769e53e5a09a3f.tar.bz2
gentoo-2-c313b227dcb442e446eeed1d4e769e53e5a09a3f.zip
Version bump flask to 0.7.2.
(Portage version: 2.1.10.4/cvs/Linux x86_64)
-rw-r--r--dev-python/flask/ChangeLog7
-rw-r--r--dev-python/flask/flask-0.7.2.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 9ece23873f21..00867a237c18 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.7 2011/02/12 17:45:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.8 2011/07/06 18:58:42 djc Exp $
+
+*flask-0.7.2 (06 Jul 2011)
+
+ 06 Jul 2011; Dirkjan Ochtman <djc@gentoo.org> +flask-0.7.2.ebuild:
+ Version bump to 0.7.2.
12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
flask-0.6.1.ebuild:
diff --git a/dev-python/flask/flask-0.7.2.ebuild b/dev-python/flask/flask-0.7.2.ebuild
new file mode 100644
index 000000000000..bd46f25b79db
--- /dev/null
+++ b/dev-python/flask/flask-0.7.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.7.2.ebuild,v 1.1 2011/07/06 18:58:42 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="http://pypi.python.org/pypi/Flask"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/blinker
+ >=dev-python/jinja-2.4
+ dev-python/setuptools
+ >=dev-python/werkzeug-0.6.1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" tests/flask_tests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/_build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}