summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-08 20:47:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-08 20:47:05 +0000
commitc215724349358ee7f889ef79acc82c4a81f8ce44 (patch)
tree14f0e394d07aec1db9399da6a60db824e6b44e00
parentmask >=sci-libs/acml-3.6 since it depends on gcc-4* (diff)
downloadgentoo-2-c215724349358ee7f889ef79acc82c4a81f8ce44.tar.gz
gentoo-2-c215724349358ee7f889ef79acc82c4a81f8ce44.tar.bz2
gentoo-2-c215724349358ee7f889ef79acc82c4a81f8ce44.zip
Version bump. Fixed openmp profiles for acml-3.6.0-r1 and acml-3.6.1-r1. Added a bunch of tests, now supports new virtual style. Remove any cblas reference since API is not compatible.
(Portage version: 2.1.3.9)
-rw-r--r--sci-libs/acml/ChangeLog13
-rw-r--r--sci-libs/acml/acml-3.6.0-r1.ebuild152
-rw-r--r--sci-libs/acml/acml-3.6.1-r1.ebuild173
-rw-r--r--sci-libs/acml/acml-4.0.0.ebuild168
-rw-r--r--sci-libs/acml/files/blas.pc.in11
-rw-r--r--sci-libs/acml/files/digest-acml-3.6.0-r112
-rw-r--r--sci-libs/acml/files/digest-acml-3.6.1-r19
-rw-r--r--sci-libs/acml/files/digest-acml-4.0.09
-rw-r--r--sci-libs/acml/files/lapack.pc.in11
9 files changed, 557 insertions, 1 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index a614beec1048..2dfc5e241892 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sci-libs/acml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.21 2007/07/02 15:25:55 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.22 2007/10/08 20:47:04 bicatali Exp $
+
+*acml-4.0.0 (08 Oct 2007)
+*acml-3.6.1-r1 (08 Oct 2007)
+*acml-3.6.0-r1 (08 Oct 2007)
+
+ 08 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org> +files/blas.pc.in,
+ +files/lapack.pc.in, +acml-3.6.0-r1.ebuild, +acml-3.6.1-r1.ebuild,
+ +acml-4.0.0.ebuild:
+ Version bump. Fixed openmp profiles for acml-3.6.0-r1 and acml-3.6.1-r1.
+ Added a bunch of tests, now supports new virtual style. Remove any cblas
+ reference since API is not compatible.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> acml-3.0.0.ebuild,
acml-3.1.0-r1.ebuild, acml-3.6.0.ebuild, acml-3.6.1.ebuild:
diff --git a/sci-libs/acml/acml-3.6.0-r1.ebuild b/sci-libs/acml/acml-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..699a21ed10eb
--- /dev/null
+++ b/sci-libs/acml/acml-3.6.0-r1.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.0-r1.ebuild,v 1.1 2007/10/08 20:47:04 bicatali Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="AMD Core Math Library (ACML) for x86 and amd64 CPUs"
+HOMEPAGE="http://developer.amd.com/acml.jsp"
+
+MY_PV=${PV//\./\-}
+
+IUSE="openmp ifc doc examples"
+KEYWORDS="~amd64 ~x86"
+
+SRC_URI="amd64? ( ifc? ( acml-${MY_PV}-ifort-64bit.tgz )
+ !ifc? ( openmp? ( acml-${MY_PV}-ifort-64bit.tgz )
+ !openmp? ( acml-${MY_PV}-gnu-64bit.tgz ) )
+ openmp? ( acml-${MY_PV}-ifort-64bit.tgz ) )
+ x86? ( ifc? ( acml-${MY_PV}-ifort-32bit.tgz )
+ !ifc? ( openmp? ( acml-${MY_PV}-ifort-32bit.tgz )
+ !openmp? ( acml-${MY_PV}-gnu-32bit.tgz ) )
+ openmp? ( acml-${MY_PV}-ifort-32bit.tgz ) )"
+
+RESTRICT="strip fetch"
+LICENSE="ACML"
+SLOT="0"
+
+DEPEND="app-admin/eselect-blas
+ app-admin/eselect-lapack"
+
+RDEPEND="${DEPEND}
+ doc? ( app-doc/blas-docs app-doc/lapack-docs )"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download the ACML from:"
+ einfo "${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}."
+ einfo "The previous versions could be found at"
+ einfo "http://developer.amd.com/acmlarchive.jsp"
+ einfo "SRC=${A} $SRC_URI"
+}
+
+pkg_setup() {
+ elog "From version 3.5.0 on, ACML no longer supports"
+ elog "hardware without SSE/SSE2 instructions. "
+ elog "For older 32-bit hardware that does not support SSE/SSE2,"
+ elog "you must continue to use an older version (ACML 3.1.0 and ealier)."
+ epause
+ FORTRAN=ifc
+ FORT=ifort
+ ! use ifc && ! use openmp && FORTRAN=g77 && FORT=gnu
+ fortran_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ (DISTDIR="${S}" unpack contents-acml-*.tgz)
+ use openmp || rm -rf ${FORT}*_mp*
+ FORTDIRS="$(ls -d ${FORT}*)"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_test() {
+ for fort in ${FORTDIRS}; do
+ einfo "Testing acml for $(basename ${fort})"
+ cd "${S}"/${fort}/examples
+ for d in . acml_mv; do
+ cd "${S}"/${fort}/examples/${d}
+ emake \
+ ACMLDIR="${S}"/${fort} \
+ F77=${FORTRANC} \
+ CC="$(tc-getCC)" \
+ CPLUSPLUS="$(tc-getCXX)" \
+ || die "emake test in ${fort}/examples/${d} failed"
+ emake clean
+ done
+ done
+}
+
+src_install() {
+ # respect acml default install dir (and FHS)
+ local instdir=/opt/${PN}${PV}
+ dodir ${instdir}
+
+ for fort in ${FORTDIRS}; do
+ # install acml
+ use examples || rm -rf "${S}"/${fort}/examples
+ cp -pPR "${S}/${fort}" "${D}"${instdir} || die "copy ${fort} failed"
+
+ # install profiles
+ ESELECT_PROF=acml-${FORTRANC}
+ local acmldir=${instdir}/${fort}
+ local libname=${acmldir}/lib/libacml
+ local extlibs
+ local extflags
+ if [[ ${fort} =~ _mp ]]; then
+ ESELECT_PROF=${ESELECT_PROF}-openmp
+ extlibs=-lpthread
+ libname=${libname}_mp
+ extflags="${extflags} -openmp"
+ fi
+ for l in blas lapack; do
+ # pkgconfig files
+ sed -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PV@:${PV}:" \
+ -e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@EXTLIBS@:${extlibs}:g" \
+ -e "s:@EXTFLAGS@:${extflags}:g" \
+ "${FILESDIR}"/${l}.pc.in > ${l}.pc \
+ || die "sed ${l}.pc failed"
+ insinto ${acmldir}/lib
+ doins ${l}.pc || die "doins ${l}.pc failed"
+
+ # eselect files
+ cat > eselect.${l} << EOF
+${libname}.so /usr/@LIBDIR@/lib${l}.so.0
+${libname}.so /usr/@LIBDIR@/lib${l}.so
+${libname}.a /usr/@LIBDIR@/lib${l}.a
+${acmldir}/lib/${l}.pc /usr/@LIBDIR@/pkgconfig/${l}.pc
+EOF
+ eselect ${l} add $(get_libdir) eselect.${l} ${ESELECT_PROF}
+ done
+ echo "LDPATH=${instdir}/${fort}/lib" > 35acml
+ echo "INCLUDE=${instdir}/${fort}/include" >> 35acml
+ done
+
+ doenvd 35acml || die "doenvd failed"
+
+ use doc || rm -rf "${S}"/Doc/acml.pdf "${S}"/Doc/html
+ cp -pPR "${S}"/Doc "${D}"${instdir} || die "copy doc failed"
+}
+
+pkg_postinst() {
+ for p in blas lapack; do
+ local current_p=$(eselect ${p} show | cut -d' ' -f2)
+ # uncomment when eselect bug #189942 is fixed, together with DEPEND
+ #if [[ -z ${current_p} || ${current_p} == ${ESELECT_PROF} ]]; then
+ if [[ -z ${current_p} ]]; then
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_p}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+ done
+}
diff --git a/sci-libs/acml/acml-3.6.1-r1.ebuild b/sci-libs/acml/acml-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..7ae06fc40a19
--- /dev/null
+++ b/sci-libs/acml/acml-3.6.1-r1.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.1-r1.ebuild,v 1.1 2007/10/08 20:47:04 bicatali Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="AMD Core Math Library (ACML) for x86 and amd64 CPUs"
+HOMEPAGE="http://developer.amd.com/acml.jsp"
+
+MY_PV=${PV//\./\-}
+S=${WORKDIR}
+SRC_URI="x86? ( acml-${MY_PV}-gfortran-32bit.tgz )
+ amd64? ( ( acml-${MY_PV}-gfortran-64bit.tgz )
+ int64? ( acml-${MY_PV}-gfortran-64bit-int64.tgz ) )"
+
+
+RESTRICT="strip fetch"
+IUSE="openmp int64 doc examples"
+LICENSE="ACML"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DEPEND="app-admin/eselect-blas
+ app-admin/eselect-lapack
+ dev-util/pkgconfig
+ openmp? ( >=sys-devel/gcc-4.2 )
+ !openmp? ( =sys-devel/gcc-4.1* )"
+
+RDEPEND="${DEPEND}
+ doc? ( app-doc/blas-docs app-doc/lapack-docs )"
+
+pkg_nofetch() {
+ einfo "Please download the ACML from:"
+ einfo "${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+ einfo "The previous versions could be found at"
+ einfo "http://developer.amd.com/acmlarchive.jsp"
+}
+
+pkg_setup() {
+ elog "From version 3.5.0 on, ACML no longer supports"
+ elog "hardware without SSE/SSE2 instructions. "
+ elog "For older 32-bit hardware that does not support SSE/SSE2,"
+ elog "you must continue to use an older version (ACML 3.1.0 and ealier)."
+ FORTRAN="gfortran"
+ fortran_pkg_setup
+ if [[ ${FORTRANC} == gfortran ]]; then
+ local gcc_version=$(gcc-major-version)$(gcc-minor-version)
+ if ! use openmp && (( ${gcc_version} != 41 )); then
+ eerror "You need gcc-4.1.x to test acml."
+ eerror "Please use gcc-config to swicth gcc version 4.1.x"
+ die "setup gcc failed"
+ elif use openmp && (( ${gcc_version} != 42 )); then
+ eerror "You need gfortran >= 4.2 to use openmp features."
+ eerror "Please use gcc-config to switch gcc version >= 4.2"
+ die "setup gcc failed"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ (DISTDIR="${S}" unpack contents-acml-*.tgz)
+ case ${FORTRANC} in
+ gfortran) FORT=gfortran ;;
+ ifc|ifort) FORT=ifort ;;
+ *) eerror "Unsupported fortran compiler: ${FORTRANC}"
+ die ;;
+ esac
+ use openmp || rm -rf ${FORT}*_mp*
+ FORTDIRS="$(ls -d ${FORT}*)"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_test() {
+ local forts=${FORTDIRS}
+ # only testing with current compiler
+ use openmp && forts="$(ls -d ${FORT}*_mp*)"
+ for fort in ${forts}; do
+ einfo "Testing acml for ${fort}"
+ cd "${S}"/${fort}/examples
+ for d in . acml_mv; do
+ cd "${S}"/${fort}/examples/${d}
+ emake \
+ ACMLDIR="${S}"/${fort} \
+ F77=${FORTRANC} \
+ CC="$(tc-getCC)" \
+ CPLUSPLUS="$(tc-getCXX)" \
+ || die "emake test in ${fort}/examples/${d} failed"
+ emake clean
+ done
+ done
+}
+
+src_install() {
+ # respect acml default install dir (and FHS)
+ local instdir=/opt/${PN}${PV}
+ dodir ${instdir}
+
+ for fort in ${FORTDIRS}; do
+ # install acml
+ use examples || rm -rf "${S}"/${fort}/examples
+ cp -pPR "${S}/${fort}" "${D}"${instdir} || die "copy ${fort} failed"
+
+ # install profiles
+ ESELECT_PROF=acml-${FORTRANC}
+ local acmldir=${instdir}/${fort}
+ local libname=${acmldir}/lib/libacml
+ local extlibs
+ local extflags
+ if [[ ${fort} =~ int64 ]]; then
+ ESELECT_PROF=${ESELECT_PROF}-int64
+ extflags="${extflags} -fdefault-integer-8"
+ fi
+ if [[ ${fort} =~ _mp ]]; then
+ ESELECT_PROF=${ESELECT_PROF}-openmp
+ extlibs=-lpthread
+ libname=${libname}_mp
+ extflags="${extflags} -fopenmp"
+ fi
+ for l in blas lapack; do
+ # pkgconfig files
+ sed -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PV@:${PV}:" \
+ -e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@EXTLIBS@:${extlibs}:g" \
+ -e "s:@EXTFLAGS@:${extflags}:g" \
+ "${FILESDIR}"/${l}.pc.in > ${l}.pc \
+ || die "sed ${l}.pc failed"
+ insinto ${acmldir}/lib
+ doins ${l}.pc
+
+ # eselect files
+ cat > eselect.${l} << EOF
+${libname}.so /usr/@LIBDIR@/lib${l}.so.0
+${libname}.so /usr/@LIBDIR@/lib${l}.so
+${libname}.a /usr/@LIBDIR@/lib${l}.a
+${acmldir}/lib/${l}.pc /usr/@LIBDIR@/pkgconfig/${l}.pc
+EOF
+ eselect ${l} add $(get_libdir) eselect.${l} ${ESELECT_PROF}
+ done
+ echo "LDPATH=${acmldir}/lib" > "${S}"/35acml
+ echo "INCLUDE=${acmldir}/include" >> "${S}"/35acml
+ done
+
+ doenvd "${S}"/35acml || die "doenvd failed"
+ use doc || rm -rf "${S}"/Doc/acml.pdf "${S}"/Doc/html
+ cp -pPR "${S}"/Doc "${D}"${instdir} || die "copy doc failed"
+}
+
+pkg_postinst() {
+ for p in blas lapack; do
+ local current_p=$(eselect ${p} show | cut -d' ' -f2)
+ # uncomment when eselect bug #189942 is fixed, together with DEPEND
+ #if [[ -z ${current_p} || ${current_p} == ${ESELECT_PROF} ]]; then
+ if [[ -z ${current_p} ]]; then
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_p}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+ done
+ if use openmp; then
+ elog "Remember that if you want to use openmp"
+ elog "You need to switch to gcc >= 4.2 with gcc-config"
+ elog "When using ACML without openmp, stick with gcc-4.1.x"
+ fi
+}
diff --git a/sci-libs/acml/acml-4.0.0.ebuild b/sci-libs/acml/acml-4.0.0.ebuild
new file mode 100644
index 000000000000..2824d505580a
--- /dev/null
+++ b/sci-libs/acml/acml-4.0.0.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.0.ebuild,v 1.1 2007/10/08 20:47:04 bicatali Exp $
+
+inherit eutils toolchain-funcs fortran
+
+MY_PV=${PV//\./\-}
+
+DESCRIPTION="AMD Core Math Library (ACML) for x86_64 CPUs"
+HOMEPAGE="http://developer.amd.com/acml.jsp"
+SRC_URI="ifc? ( acml-${MY_PV}-ifort-64bit.tgz )
+ !ifc? ( int64? ( acml-${MY_PV}-gfortran-64bit-int64.tgz )
+ !int64? ( acml-${MY_PV}-gfortran-64bit.tgz ) )"
+
+IUSE="openmp ifc int64 doc examples"
+KEYWORDS="~amd64"
+
+RESTRICT="strip fetch"
+LICENSE="ACML"
+SLOT="0"
+
+DEPEND="app-admin/eselect-blas
+ app-admin/eselect-lapack
+ ifc? ( dev-lang/ifc )
+ openmp? ( !ifc? ( >=sys-devel/gcc-4.2 ) )
+ !openmp? ( !ifc? ( =sys-devel/gcc-4.1* ) )"
+
+RDEPEND="${DEPEND}
+ doc? ( app-doc/blas-docs app-doc/lapack-docs )"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download the ACML from:"
+ einfo "${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}."
+ einfo "The previous versions could be found at"
+ einfo "http://developer.amd.com/acmlarchive.jsp"
+ einfo "SRC=${A} $SRC_URI"
+}
+
+pkg_setup() {
+ FORTRAN="gfortran"
+ use ifc && FORTRAN="ifc"
+ fortran_pkg_setup
+ if [[ ${FORTRANC} == gfortran ]]; then
+ local gcc_version=$(gcc-major-version)$(gcc-minor-version)
+ if ! use openmp && (( ${gcc_version} != 41 )); then
+ eerror "You need gcc-4.1.x to test acml."
+ eerror "Please use gcc-config to swicth gcc version 4.1.x"
+ die "setup gcc failed"
+ elif use openmp && (( ${gcc_version} != 42 )); then
+ eerror "You need gfortran >= 4.2 to use openmp features."
+ eerror "Please use gcc-config to switch gcc version >= 4.2"
+ die "setup gcc failed"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ (DISTDIR="${S}" unpack contents-acml-*.tgz)
+ case ${FORTRANC} in
+ gfortran) FORT=gfortran ;;
+ ifc|ifort) FORT=ifort ;;
+ *) eerror "Unsupported fortran compiler: ${FORTRANC}"
+ die "failed configuring fortran";;
+ esac
+ use openmp || rm -rf ${FORT}*_mp*
+ FORTDIRS="$(ls -d ${FORT}*)"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_test() {
+ local forts=${FORTDIRS}
+ # only testing with current compiler
+ use openmp && forts="$(ls -d ${FORT}*_mp*)"
+ for fort in ${forts}; do
+ einfo "Testing acml for ${fort}"
+ cd "${S}"/${fort}/examples
+ for d in . acml_mv; do
+ cd "${S}"/${fort}/examples/${d}
+ emake \
+ ACMLDIR="${S}"/${fort} \
+ F77=${FORTRANC} \
+ CC="$(tc-getCC)" \
+ CPLUSPLUS="$(tc-getCXX)" \
+ || die "emake test in ${fort}/examples/${d} failed"
+ emake clean
+ done
+ done
+}
+
+src_install() {
+ # respect acml default install dir (and FHS)
+ local instdir=/opt/${PN}${PV}
+ dodir ${instdir}
+
+ for fort in ${FORTDIRS}; do
+ # install acml
+ use examples || rm -rf "${S}"/${fort}/examples
+ cp -pPR "${S}"/${fort} "${D}"${instdir} || die "copy ${fort} failed"
+
+ # install profiles
+ ESELECT_PROF=acml-${FORTRANC}
+ local acmldir=${instdir}/${fort}
+ local libname=${acmldir}/lib/libacml
+ local extlibs
+ local extflags
+ if [[ ${fort} =~ int64 ]]; then
+ ESELECT_PROF=${ESELECT_PROF}-int64
+ extflags="${extflags} -fdefault-integer-8"
+ fi
+ if [[ ${fort} =~ _mp ]]; then
+ ESELECT_PROF=${ESELECT_PROF}-openmp
+ extlibs=-lpthread
+ libname=${libname}_mp
+ extflags="${extflags} -fopenmp"
+ fi
+ for l in blas lapack; do
+ # pkgconfig files
+ sed -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PV@:${PV}:" \
+ -e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@EXTLIBS@:${extlibs}:g" \
+ -e "s:@EXTFLAGS@:${extflags}:g" \
+ "${FILESDIR}"/${l}.pc.in > ${l}.pc \
+ || die "sed ${l}.pc failed"
+ insinto ${acmldir}/lib
+ doins ${l}.pc || die "doins ${l}.pc failed"
+
+ # eselect files
+ cat > eselect.${l} << EOF
+${libname}.so /usr/@LIBDIR@/lib${l}.so.0
+${libname}.so /usr/@LIBDIR@/lib${l}.so
+${libname}.a /usr/@LIBDIR@/lib${l}.a
+${acmldir}/lib/${l}.pc /usr/@LIBDIR@/pkgconfig/${l}.pc
+EOF
+ eselect ${l} add $(get_libdir) eselect.${l} ${ESELECT_PROF}
+ done
+ echo "LDPATH=${instdir}/${fort}/lib" > 35acml
+ echo "INCLUDE=${instdir}/${fort}/include" >> 35acml
+ done
+
+ doenvd 35acml || die "doenvd failed"
+
+ use doc || rm -rf "${S}"/Doc/acml.pdf "${S}"/Doc/html
+ cp -pPR "${S}"/Doc "${D}"${instdir} || die "copy doc failed"
+}
+
+pkg_postinst() {
+ for p in blas lapack; do
+ local current_p=$(eselect ${p} show | cut -d' ' -f2)
+ # uncomment when eselect bug #189942 is fixed, together with DEPEND
+ #if [[ -z ${current_p} || ${current_p} == ${ESELECT_PROF} ]]; then
+ if [[ -z ${current_p} ]]; then
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_p}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+ done
+}
diff --git a/sci-libs/acml/files/blas.pc.in b/sci-libs/acml/files/blas.pc.in
new file mode 100644
index 000000000000..fd1d57ffd054
--- /dev/null
+++ b/sci-libs/acml/files/blas.pc.in
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=/usr/@LIBDIR@
+includedir=@ACMLDIR@/include
+
+Name: blas
+Description: ACML implementations of the Basic Linear Algebra Subroutines
+Version: @PV@
+URL: http://developer.amd.com/acml.jsp
+Libs: -L${libdir} -lblas @EXTLIBS@
+Cflags: @EXTFLAGS@
diff --git a/sci-libs/acml/files/digest-acml-3.6.0-r1 b/sci-libs/acml/files/digest-acml-3.6.0-r1
new file mode 100644
index 000000000000..78ad50e56f66
--- /dev/null
+++ b/sci-libs/acml/files/digest-acml-3.6.0-r1
@@ -0,0 +1,12 @@
+MD5 544b271fac69f3a5de4859c42962d257 acml-3-6-0-gnu-32bit.tgz 9879145
+RMD160 bafa6acd1d8a319fb385245559779450c7bdcd66 acml-3-6-0-gnu-32bit.tgz 9879145
+SHA256 81ee83babf134bc021e5e64983200abf815531ee20ecc5ecc97a30bbdb5cf6dd acml-3-6-0-gnu-32bit.tgz 9879145
+MD5 cd29b05621cc8af7094bc30e3d8288e3 acml-3-6-0-gnu-64bit.tgz 11101900
+RMD160 f6d674a4fbf99e79109bb379d1ba5dbaf88ce010 acml-3-6-0-gnu-64bit.tgz 11101900
+SHA256 240cd40c9f9c993c15ec113278faf8689713b45b7626da2d0c369024bec97c03 acml-3-6-0-gnu-64bit.tgz 11101900
+MD5 b142edc1cd30cee76262c7df3d6e491c acml-3-6-0-ifort-32bit.tgz 17399749
+RMD160 c41ebe1b62470858d176c5815e05893ba4caf4ad acml-3-6-0-ifort-32bit.tgz 17399749
+SHA256 1585df79ced4ecd6fdcbb59b36e2686b61d6faf7b755d5ac5a267eddeff36340 acml-3-6-0-ifort-32bit.tgz 17399749
+MD5 e887b75ceec837ba9778b3fe18913faa acml-3-6-0-ifort-64bit.tgz 21966276
+RMD160 a6031f5cdacdc70d11c06cf6d8e8ae3149eff55f acml-3-6-0-ifort-64bit.tgz 21966276
+SHA256 bdfb47a5f018d1bcca257b9223f176726663596ae0e8337dc295a312f8382950 acml-3-6-0-ifort-64bit.tgz 21966276
diff --git a/sci-libs/acml/files/digest-acml-3.6.1-r1 b/sci-libs/acml/files/digest-acml-3.6.1-r1
new file mode 100644
index 000000000000..31c6126b2492
--- /dev/null
+++ b/sci-libs/acml/files/digest-acml-3.6.1-r1
@@ -0,0 +1,9 @@
+MD5 3aa80dc1a5fed2ccedceacffcbf22501 acml-3-6-1-gfortran-32bit.tgz 17682562
+RMD160 abdb8ea2f66f08f478a951b37c5ce5945854a357 acml-3-6-1-gfortran-32bit.tgz 17682562
+SHA256 adec95c65d1042c65fa1490978b76042c3bf9670df7c226cd28431473985898c acml-3-6-1-gfortran-32bit.tgz 17682562
+MD5 1eb1958766688332a83e4b9807031495 acml-3-6-1-gfortran-64bit-int64.tgz 19802195
+RMD160 3cb2317d6a5ec62797c4a11ab1336aabb50e16fa acml-3-6-1-gfortran-64bit-int64.tgz 19802195
+SHA256 56cbbb6deac2a93d21f3954511ad95ccc2a8ce893fdbf9a8605a2d81deb1fc41 acml-3-6-1-gfortran-64bit-int64.tgz 19802195
+MD5 f1df8d99221337e5644e85ca790e19c2 acml-3-6-1-gfortran-64bit.tgz 20452058
+RMD160 8df00704e7ac037dcd55a9207f45d6f0b2214ff8 acml-3-6-1-gfortran-64bit.tgz 20452058
+SHA256 efec543a8185ffb6e6e68db94ef0cbd92c1b9ee1580affe6cd0a73c580ad8bdc acml-3-6-1-gfortran-64bit.tgz 20452058
diff --git a/sci-libs/acml/files/digest-acml-4.0.0 b/sci-libs/acml/files/digest-acml-4.0.0
new file mode 100644
index 000000000000..3d884d84518b
--- /dev/null
+++ b/sci-libs/acml/files/digest-acml-4.0.0
@@ -0,0 +1,9 @@
+MD5 50879e5fa9cafc7a9badde44037f55ab acml-4-0-0-gfortran-64bit-int64.tgz 21881646
+RMD160 65d3d4ca146ade1781efb43ca35c80cc85387c90 acml-4-0-0-gfortran-64bit-int64.tgz 21881646
+SHA256 eda0b3c1350716509b1d244641200edca30faaae42c7b7b3873f573b4036f1f6 acml-4-0-0-gfortran-64bit-int64.tgz 21881646
+MD5 47f15966a5ed81243350d31afdd4e7f6 acml-4-0-0-gfortran-64bit.tgz 22559682
+RMD160 cd9042e882fb4e8c1f5951e8eb2880d035ab14ea acml-4-0-0-gfortran-64bit.tgz 22559682
+SHA256 3a7300dd9f7a494177baddd8bc34375daf80e550f5b6edb9539ed966adb80f11 acml-4-0-0-gfortran-64bit.tgz 22559682
+MD5 175b1968c5a3279cb7ebfab7018c0b82 acml-4-0-0-ifort-64bit.tgz 26676345
+RMD160 2f4a1f14a55ac3334fd3fc045355a4fdebf2e87f acml-4-0-0-ifort-64bit.tgz 26676345
+SHA256 090f64a5fe309c6ed2ee9bcf7ae73687e0577a02da9f8ceabd4e5315fecb4769 acml-4-0-0-ifort-64bit.tgz 26676345
diff --git a/sci-libs/acml/files/lapack.pc.in b/sci-libs/acml/files/lapack.pc.in
new file mode 100644
index 000000000000..e312798d8485
--- /dev/null
+++ b/sci-libs/acml/files/lapack.pc.in
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=/usr/@LIBDIR@
+includedir=@ACMLDIR@/include
+
+Name: lapack
+Description: ACML implementation of the F77 Linear Algebra PACKage
+Version: @PV@
+URL: http://developer.amd.com/acml.jsp
+Libs: -L${libdir} -llapack @EXTLIBS@
+Cflags: @EXTFLAGS@