summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-29 19:53:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-29 19:53:52 +0000
commitbeb551e2511a792c04ec5b4e6ef4a169240c2ab4 (patch)
tree355101a14bc8ff021afcec20a98d1aa8edec5206
parentAdded myself to the metadata.xml (diff)
downloadgentoo-2-beb551e2511a792c04ec5b4e6ef4a169240c2ab4.tar.gz
gentoo-2-beb551e2511a792c04ec5b4e6ef4a169240c2ab4.tar.bz2
gentoo-2-beb551e2511a792c04ec5b4e6ef4a169240c2ab4.zip
Fix building with -Wl,--as-needed wrt #276928 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--net-p2p/dbhub/ChangeLog8
-rw-r--r--net-p2p/dbhub/dbhub-0.451.ebuild25
-rw-r--r--net-p2p/dbhub/files/dbhub-gentoo.patch22
3 files changed, 33 insertions, 22 deletions
diff --git a/net-p2p/dbhub/ChangeLog b/net-p2p/dbhub/ChangeLog
index 3281bad47e74..5b0d66848050 100644
--- a/net-p2p/dbhub/ChangeLog
+++ b/net-p2p/dbhub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/dbhub
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/ChangeLog,v 1.28 2008/06/30 12:52:45 corsair Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/ChangeLog,v 1.29 2010/06/29 19:53:52 ssuominen Exp $
+
+ 29 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> dbhub-0.451.ebuild,
+ files/dbhub-gentoo.patch:
+ Fix building with -Wl,--as-needed wrt #276928 by Diego E. Pettenò.
30 Jun 2008; Markus Rothe <corsair@gentoo.org> dbhub-0.451.ebuild:
Added ~ppc
diff --git a/net-p2p/dbhub/dbhub-0.451.ebuild b/net-p2p/dbhub/dbhub-0.451.ebuild
index 8fb50a759b3f..c750b62d26d8 100644
--- a/net-p2p/dbhub/dbhub-0.451.ebuild
+++ b/net-p2p/dbhub/dbhub-0.451.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/dbhub-0.451.ebuild,v 1.2 2008/06/30 12:52:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/dbhub-0.451.ebuild,v 1.3 2010/06/29 19:53:52 ssuominen Exp $
-inherit eutils
+EAPI=2
+inherit autotools eutils
DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
HOMEPAGE="http://www.dbhub.org"
@@ -14,25 +15,21 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="debug perl nls switch_user"
DEPEND="perl? ( dev-lang/perl )
- switch_user? ( sys-libs/libcap )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+ switch_user? ( sys-libs/libcap )"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-gentoo.patch
+ eautoreconf
}
-src_compile() {
- econf \
+src_configure() {
+ econf \
$(use_enable nls) \
$(use_enable perl) \
$(use_enable switch_user) \
- $(use_enable debug) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_enable debug)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
}
diff --git a/net-p2p/dbhub/files/dbhub-gentoo.patch b/net-p2p/dbhub/files/dbhub-gentoo.patch
index 3ac532ffef6b..6e992cdb0129 100644
--- a/net-p2p/dbhub/files/dbhub-gentoo.patch
+++ b/net-p2p/dbhub/files/dbhub-gentoo.patch
@@ -1,15 +1,25 @@
---- configure.orig 2008-02-25 15:28:29.000000000 +0100
-+++ configure 2008-02-25 15:28:52.000000000 +0100
-@@ -4926,12 +4926,6 @@
- fi
+--- configure.ac
++++ configure.ac
+@@ -115,7 +115,7 @@
+ AC_MSG_CHECKING([Perl LD Objs])
+ AC_MSG_RESULT([$perl_ldd])
+ CPPFLAGS="$CPPFLAGS $perl_ccflags"
+- LDFLAGS="$LDFLAGS $perl_ld"
++ LIBS="$LIBS $perl_ld"
+ MISSING_PERL_HEADERS=""
+ AC_CHECK_HEADERS([EXTERN.h perl.h],,HAVE_PERL="false"; MISSING_PERL_HEADERS="$ac_header $MISSING_PERL_HEADERS",[[#if HAVE_EXTERN_H
+ #include <EXTERN.h>
+@@ -141,13 +141,6 @@
+ AM_CONDITIONAL([BNLS],[test "$want_nls" = "yes"])
+-dnl Check if config directory exists.
-if test ! -d $HOME/.dbhub; then
- echo "creating config directory: $HOME/.dbhub"
- mkdir $HOME/.dbhub
- chmod 700 $HOME/.dbhub;
-fi
-
- ac_config_files="$ac_config_files Makefile src/Makefile"
+ AC_OUTPUT(Makefile src/Makefile)
- cat >confcache <<\_ACEOF
+ echo -e "\n\e@<:@1m-------------------------------------------------\e@<:@0m"