summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-12 07:02:02 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-12 07:02:02 +0000
commitb5be1ad1ca89b44c51ba58b991e31902743fdb3e (patch)
tree9d88cb6c7b8f113a053d35e1cf326e94008ea593
parentRemoved RDEPEND=${DEPEND} (diff)
downloadgentoo-2-b5be1ad1ca89b44c51ba58b991e31902743fdb3e.tar.gz
gentoo-2-b5be1ad1ca89b44c51ba58b991e31902743fdb3e.tar.bz2
gentoo-2-b5be1ad1ca89b44c51ba58b991e31902743fdb3e.zip
Removed RDEPEND=${DEPEND}
-rw-r--r--sys-libs/lwp/lwp-1.9.ebuild29
-rw-r--r--sys-libs/rvm/rvm-1.6.ebuild27
-rw-r--r--x11-libs/gtkglarea/gtkglarea-1.99.0.ebuild7
3 files changed, 18 insertions, 45 deletions
diff --git a/sys-libs/lwp/lwp-1.9.ebuild b/sys-libs/lwp/lwp-1.9.ebuild
index 87fce14b18ba..382f6bc369a2 100644
--- a/sys-libs/lwp/lwp-1.9.ebuild
+++ b/sys-libs/lwp/lwp-1.9.ebuild
@@ -1,36 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/lwp/lwp-1.9.ebuild,v 1.1 2002/07/23 21:48:04 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lwp/lwp-1.9.ebuild,v 1.2 2002/11/12 06:59:02 vapier Exp $
-DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl."
-
-# Appearantly maintained by the Coda people
-HOMEPAGE="http://www.coda.cs.cmu.edu"
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl."
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
-#actually "GNU Library General Public Licence Version 2"
LICENSE="LGPL-2.1"
-
-# Nothing listed in the docs for dependencies that I noticed
-DEPEND="virtual/glibc"
-RDEPEND=${DEPEND}
-
SLOT="1"
KEYWORDS="x86"
-SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
-
-S=${WORKDIR}/${P}
+DEPEND="virtual/glibc"
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
- emake || die
+ econf
+ emake || die "make failed"
}
-src_install () {
+src_install() {
# does not seems to consistently use DESTDIR where it needs to, but I could be wrong too
# make DESTDIR=${D} install || die
make \
diff --git a/sys-libs/rvm/rvm-1.6.ebuild b/sys-libs/rvm/rvm-1.6.ebuild
index 59e2a57e7ba1..7876bac269d4 100644
--- a/sys-libs/rvm/rvm-1.6.ebuild
+++ b/sys-libs/rvm/rvm-1.6.ebuild
@@ -1,36 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/rvm/rvm-1.6.ebuild,v 1.2 2002/07/23 22:20:41 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/rvm/rvm-1.6.ebuild,v 1.3 2002/11/12 07:01:05 vapier Exp $
DESCRIPTION="Recoverable Virtual Memory (used by Coda)"
-
-# Appearantly maintained by the Coda people
-HOMEPAGE="http://www.coda.cs.cmu.edu"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/rvm/src/${P}.tar.gz"
LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="x86"
-SLOT=1
-
-# partly based on the deps suggested by Mandrake's RPM
DEPEND="virtual/glibc
>=sys-libs/lwp-1.9"
-RDEPEND=${DEPEND}
-
-SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/rvm/src/${P}.tar.gz"
-
-S=${WORKDIR}/${P}
-KEYWORDS="x86"
-
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}
diff --git a/x11-libs/gtkglarea/gtkglarea-1.99.0.ebuild b/x11-libs/gtkglarea/gtkglarea-1.99.0.ebuild
index da5045e54512..eb300cb81cf6 100644
--- a/x11-libs/gtkglarea/gtkglarea-1.99.0.ebuild
+++ b/x11-libs/gtkglarea/gtkglarea-1.99.0.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglarea/gtkglarea-1.99.0.ebuild,v 1.5 2002/11/02 22:10:15 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglarea/gtkglarea-1.99.0.ebuild,v 1.6 2002/11/12 07:02:02 vapier Exp $
inherit gnome2
-S=${WORKDIR}/${P}
+
DESCRIPTION="GL extensions for gtk+"
SRC_URI="ftp://ftp.gnome.org/pub/gnome/pre-gnome2/sources/gtkglarea/${P}.tar.bz2"
HOMEPAGE="http://www.gnome.org/"
+
SLOT="2"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="x86 ppc sparc sparc64"
@@ -15,7 +16,5 @@ DEPEND="virtual/glibc
>=x11-libs/gtk+-2.0.3
virtual/glu
virtual/opengl"
-RDEPEND=${DEPEND}
DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README* docs/*.txt"
-