summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenneth Prugh <ken69267@gentoo.org>2008-07-27 15:35:13 +0000
committerKenneth Prugh <ken69267@gentoo.org>2008-07-27 15:35:13 +0000
commitaa68c9bb2540dec23941a2c60ea4cb1d60a3f5e7 (patch)
treea9303d2b982400679ff3884a1476ab23c31f2457
parentAdded gcc-4.3 compatibility patch. (diff)
downloadgentoo-2-aa68c9bb2540dec23941a2c60ea4cb1d60a3f5e7.tar.gz
gentoo-2-aa68c9bb2540dec23941a2c60ea4cb1d60a3f5e7.tar.bz2
gentoo-2-aa68c9bb2540dec23941a2c60ea4cb1d60a3f5e7.zip
version bump
(Portage version: 2.2_rc3/cvs/Linux 2.6.25-gentoo-r4 x86_64)
-rw-r--r--app-misc/slashtime/ChangeLog7
-rw-r--r--app-misc/slashtime/slashtime-0.5.5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-misc/slashtime/ChangeLog b/app-misc/slashtime/ChangeLog
index 913d7926f429..7519ea1dedf5 100644
--- a/app-misc/slashtime/ChangeLog
+++ b/app-misc/slashtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/slashtime
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.1 2008/06/29 17:18:15 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/ChangeLog,v 1.2 2008/07/27 15:35:13 ken69267 Exp $
+
+*slashtime-0.5.5 (27 Jul 2008)
+
+ 27 Jul 2008; Kenneth Prugh <ken69267@gentoo.org> +slashtime-0.5.5.ebuild:
+ version bump
*slashtime-0.5.4 (29 Jun 2008)
diff --git a/app-misc/slashtime/slashtime-0.5.5.ebuild b/app-misc/slashtime/slashtime-0.5.5.ebuild
new file mode 100644
index 000000000000..eb4abd802a27
--- /dev/null
+++ b/app-misc/slashtime/slashtime-0.5.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slashtime/slashtime-0.5.5.ebuild,v 1.1 2008/07/27 15:35:13 ken69267 Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2
+
+DESCRIPTION="View the time at locations around the world"
+HOMEPAGE="http://research.operationaldynamics.com/projects/slashtime/"
+SRC_URI="http://research.operationaldynamics.com/projects/${PN}/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP=">=dev-java/java-gnome-4.0.7:4.0"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+src_compile() {
+ # Handwritten in perl so not using econf
+ ./configure --prefix=/usr
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ #this is needed to generate the slashtime jar
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ #remove incorrect install path
+ rm -r "${D}"/usr/share/java/
+ rm "${D}"/usr/bin/slashtime
+
+ java-pkg_register-dependency java-gnome-4.0 gtk-4.0.jar
+ java-pkg_dojar tmp/${PN}.jar
+ java-pkg_dolauncher ${PN} --main slashtime.client.Master \
+ --pwd /usr
+
+ dodoc AUTHORS HACKING PLACES README TODO || die "dodoc failed."
+
+ use source && java-pkg_dosrc src/java/slashtime
+}