summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-03 23:04:56 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-03 23:04:56 +0000
commita21fbdf5f4a004afa8bdeed37175b88755358329 (patch)
treede08df6867ca1030eebdd9263c7e43c8cf47806b
parentbug #4411 (diff)
downloadgentoo-2-a21fbdf5f4a004afa8bdeed37175b88755358329.tar.gz
gentoo-2-a21fbdf5f4a004afa8bdeed37175b88755358329.tar.bz2
gentoo-2-a21fbdf5f4a004afa8bdeed37175b88755358329.zip
Fixes #4361.
-rw-r--r--dev-java/xalan/ChangeLog17
-rw-r--r--dev-java/xalan/files/digest-xalan-2.41
-rw-r--r--dev-java/xalan/xalan-2.4.ebuild32
-rw-r--r--profiles/package.mask8
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/xalan/ChangeLog b/dev-java/xalan/ChangeLog
new file mode 100644
index 000000000000..5e7f786afb21
--- /dev/null
+++ b/dev-java/xalan/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for dev-java/xalan
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/ChangeLog,v 1.1 2002/07/03 23:04:56 karltk Exp $
+
+*xalan-2.4 (04 Jul 2002)
+
+ 04 Jul 2002; Karl Trygve Kalleberg <karltk@gentoo.org> xalan-2.4.ebuild files/digest-xalan-2.4 :
+
+ From Xalan's home page:
+
+ "Xalan-Java is an XSLT processor for transforming XML documents into
+ HTML, text, or other XML document types. It implements the W3C
+ Recommendations for XSL Transformations (XSLT) and the XML Path
+ Language (XPath). It can be used from the command line, in an applet
+ or a servlet, or as a module in other program."
+
+ Initial import.
diff --git a/dev-java/xalan/files/digest-xalan-2.4 b/dev-java/xalan/files/digest-xalan-2.4
new file mode 100644
index 000000000000..0e981e4455d4
--- /dev/null
+++ b/dev-java/xalan/files/digest-xalan-2.4
@@ -0,0 +1 @@
+MD5 4736b3ba3db1630f9742ab10b08d0690 xalan-j_2_4_D1-src.tar.gz 4259589
diff --git a/dev-java/xalan/xalan-2.4.ebuild b/dev-java/xalan/xalan-2.4.ebuild
new file mode 100644
index 000000000000..fba89121dbf6
--- /dev/null
+++ b/dev-java/xalan/xalan-2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/xalan-2.4.ebuild,v 1.1 2002/07/03 23:04:56 karltk Exp $
+
+DESCRIPTION="XSLT processor"
+HOMEPAGE="http://xml.apache.org/xalan-j/index.html"
+LICENSE="Apache-1.1"
+DEPEND=">=virtual/jdk-1.2
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.15 )"
+RDEPEND="$DEPEND"
+SRC_URI="http://xml.apache.org/dist/xalan-j/${PN}-j_2_4_D1-src.tar.gz"
+S=${WORKDIR}/${PN}-j_2_4_D1
+
+src_compile() {
+ local myc
+
+ # FIXME: Compiling with Jikes does not work properly yet.
+
+ use jikes && \
+ myc="${myc} -Dbuild.compiler=jikes" ||
+ myc="${myc} -Dbuild.compiler=classic"
+
+ ant jar docs javadocs ${myc}
+}
+
+src_install () {
+ dojar build/xalan.jar
+
+ dohtml readme.html
+ dohtml -r build/docs/*
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 6726a0049298..6b3a3bd5e79d 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -22,6 +22,14 @@
## End example
##
+# <karltk@gentoo.org> (04 Jul 2002)
+# We're removing JAXP from our tree. It is just a repack of
+# the Apache project's Xalan and Xerces, with a nastier license
+# and a more erratic release schedule; only tomcat 3.2.2
+# depends on it, and 3.2.2 is old.
+dev-java/jaxp
+=net-www/tomcat-3.2.2
+
#azarah@gentoo.org (03 Jul 2002)
#this one moves a lot of stuff around, and have a search dir
#order fix that is very experimental