summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-06-26 10:05:58 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-06-26 10:05:58 +0000
commita1defc10616a4fefb52560fa0c7c35fbab4b7bd1 (patch)
tree82c546a90ef935541f872e4370358079c8608827
parentltsp_x_core bumped to version 3.0.4 (XFree 4.2.99) (diff)
downloadgentoo-2-a1defc10616a4fefb52560fa0c7c35fbab4b7bd1.tar.gz
gentoo-2-a1defc10616a4fefb52560fa0c7c35fbab4b7bd1.tar.bz2
gentoo-2-a1defc10616a4fefb52560fa0c7c35fbab4b7bd1.zip
alpha support for firebird
-rw-r--r--net-www/mozilla-firebird/ChangeLog6
-rw-r--r--net-www/mozilla-firebird/Manifest5
-rw-r--r--net-www/mozilla-firebird/files/mozilla-1.3-alpha-stubs.patch121
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.6-r5.ebuild12
4 files changed, 139 insertions, 5 deletions
diff --git a/net-www/mozilla-firebird/ChangeLog b/net-www/mozilla-firebird/ChangeLog
index f15de557aa7d..05a15ba6ccf1 100644
--- a/net-www/mozilla-firebird/ChangeLog
+++ b/net-www/mozilla-firebird/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mozilla-firebird
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.8 2003/06/21 01:28:42 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.9 2003/06/26 10:05:37 taviso Exp $
+
+ 26 Jun 2003; Tavis Ormandy <taviso@gentoo.org>
+ mozilla-firebird-0.6-r5.ebuild:
+ marking ~alpha, needs minor patch so added a minimal src_unpack()
20 Jun 2003; Jason Wever <weeve@gentoo.org> mozilla-firebird-0.6-r5.ebuild:
Changed ~sparc keyword to sparc.
diff --git a/net-www/mozilla-firebird/Manifest b/net-www/mozilla-firebird/Manifest
index a6008a8e1218..d75c210580f9 100644
--- a/net-www/mozilla-firebird/Manifest
+++ b/net-www/mozilla-firebird/Manifest
@@ -1,6 +1,7 @@
-MD5 670b7ac7def45160a32245cb309bc450 ChangeLog 1710
MD5 8ca497e8450db916c56c95ea96fcbfc9 mozilla-firebird-0.6-r4.ebuild 4713
-MD5 60002e5be8cfcfb2dad608cfc630c1da mozilla-firebird-0.6-r5.ebuild 4736
+MD5 febebab06fcb3cc7cf269e565795436d mozilla-firebird-0.6-r5.ebuild 4948
+MD5 f2b1375a60823d982137b3c9cb84975f ChangeLog 1863
+MD5 23d1fbd03cc6dd346a4e4ce8f2d88ebf files/mozilla-1.3-alpha-stubs.patch 4646
MD5 6e4352482ed149b3b9aca78d83de1124 files/MozillaFirebird 753
MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r4 81
MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r5 81
diff --git a/net-www/mozilla-firebird/files/mozilla-1.3-alpha-stubs.patch b/net-www/mozilla-firebird/files/mozilla-1.3-alpha-stubs.patch
new file mode 100644
index 000000000000..3aa192be9246
--- /dev/null
+++ b/net-www/mozilla-firebird/files/mozilla-1.3-alpha-stubs.patch
@@ -0,0 +1,121 @@
+diff -Naur mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp mozilla-alpha-stubs/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp
+--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp 2001-09-28 15:12:51.000000000 -0500
++++ mozilla-alpha-stubs/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_alpha.cpp 2003-03-18 09:50:06.000000000 -0600
+@@ -20,6 +20,7 @@
+ * the Initial Developer. All Rights Reserved.
+ *
+ * Contributor(s):
++ * Glen Nakamura <glen@imodulo.com>
+ *
+ * Alternatively, the contents of this file may be used under the terms of
+ * either the GNU General Public License Version 2 or later (the "GPL"), or
+@@ -37,8 +38,6 @@
+
+ /* Platform specific code to invoke XPCOM methods on native objects */
+
+-/* contributed by Glen Nakamura <glen.nakamura@usa.net> */
+-
+ #include "xptcprivate.h"
+
+ /* Prototype specifies unmangled function name and disables unused warning */
+@@ -163,7 +162,11 @@
+ "bis $16,$16,$1\n\t" /* load "this" */
+ "ldq $2,16($15)\n\t" /* load "methodIndex" */
+ "ldq $1,0($1)\n\t" /* load vtable */
++#if defined(__GXX_ABI_VERSION) && __GXX_ABI_VERSION >= 100 /* G++ V3 ABI */
++ "s8addq $2,$31,$2\n\t" /* vtable index = "methodIndex" * 8 */
++#else /* not G++ V3 ABI */
+ "s8addq $2,16,$2\n\t" /* vtable index = "methodIndex" * 8 + 16 */
++#endif /* G++ V3 ABI */
+ "addq $1,$2,$1\n\t"
+ "ldq $27,0($1)\n\t" /* load address of function */
+ "jsr $26,($27),0\n\t" /* call virtual function */
+@@ -176,4 +179,3 @@
+ "ret $31,($26),1\n\t"
+ ".end XPTC_InvokeByIndex"
+ );
+-
+diff -Naur mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp mozilla-alpha-stubs/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp
+--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp 2001-09-28 15:12:52.000000000 -0500
++++ mozilla-alpha-stubs/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_alpha.cpp 2003-03-18 09:50:06.000000000 -0600
+@@ -20,6 +20,7 @@
+ * the Initial Developer. All Rights Reserved.
+ *
+ * Contributor(s):
++ * Glen Nakamura <glen@imodulo.com>
+ *
+ * Alternatively, the contents of this file may be used under the terms of
+ * either the GNU General Public License Version 2 or later (the "GPL"), or
+@@ -37,8 +38,6 @@
+
+ /* Implement shared vtbl methods. */
+
+-/* contributed by Glen Nakamura <glen.nakamura@usa.net> */
+-
+ #include "xptcprivate.h"
+
+ /* Prototype specifies unmangled function name and disables unused warning */
+@@ -188,23 +187,45 @@
+ * nsresult nsXPTCStubBase::Stub##n()
+ * Sets register $1 to "methodIndex" and jumps to SharedStub.
+ */
++#define STUB_MANGLED_ENTRY(n, symbol) \
++ "#### Stub"#n" ####" "\n\t" \
++ ".text" "\n\t" \
++ ".align 5" "\n\t" \
++ ".globl " symbol "\n\t" \
++ ".ent " symbol "\n" \
++symbol ":" "\n\t" \
++ ".frame $30,0,$26,0" "\n\t" \
++ "ldgp $29,0($27)" "\n" \
++"$" symbol "..ng:" "\n\t" \
++ ".prologue 1" "\n\t" \
++ "lda $1,"#n "\n\t" \
++ "br $31,$SharedStub..ng" "\n\t" \
++ ".end " symbol
++
++#if defined(__GXX_ABI_VERSION) && __GXX_ABI_VERSION >= 100 /* G++ V3 ABI */
++
++#define STUB_ENTRY(n) \
++__asm__( \
++ ".if "#n" < 10" "\n\t" \
++ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase5Stub"#n"Ev") "\n\t" \
++ ".elseif "#n" < 100" "\n\t" \
++ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase6Stub"#n"Ev") "\n\t" \
++ ".elseif "#n" < 1000" "\n\t" \
++ STUB_MANGLED_ENTRY(n, "_ZN14nsXPTCStubBase7Stub"#n"Ev") "\n\t" \
++ ".else" "\n\t" \
++ ".err \"Stub"#n" >= 1000 not yet supported.\"" "\n\t" \
++ ".endif" \
++ );
++
++#else /* not G++ V3 ABI */
++
+ #define STUB_ENTRY(n) \
+ __asm__( \
+- "#### Stub"#n" ####\n" \
+-".text\n\t" \
+- ".align 5\n\t" \
+- ".globl Stub"#n"__14nsXPTCStubBase\n\t" \
+- ".ent Stub"#n"__14nsXPTCStubBase\n" \
+-"Stub"#n"__14nsXPTCStubBase:\n\t" \
+- ".frame $30,0,$26,0\n\t" \
+- "ldgp $29,0($27)\n" \
+-"$Stub"#n"__14nsXPTCStubBase..ng:\n\t" \
+- ".prologue 1\n\t" \
+- "lda $1,"#n"\n\t" \
+- "br $31,$SharedStub..ng\n\t" \
+- ".end Stub"#n"__14nsXPTCStubBase" \
++ STUB_MANGLED_ENTRY(n, "Stub"#n"__14nsXPTCStubBase") \
+ );
+
++#endif /* G++ V3 ABI */
++
+ #define SENTINEL_ENTRY(n) \
+ nsresult nsXPTCStubBase::Sentinel##n() \
+ { \
+@@ -213,4 +234,3 @@
+ }
+
+ #include "xptcstubsdef.inc"
+-
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.6-r5.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.6-r5.ebuild
index 08afb0890c5c..7564c84e2027 100644
--- a/net-www/mozilla-firebird/mozilla-firebird-0.6-r5.ebuild
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6-r5.ebuild,v 1.3 2003/06/21 01:28:42 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6-r5.ebuild,v 1.4 2003/06/26 10:05:37 taviso Exp $
inherit makeedit flag-o-matic gcc nsplugins
@@ -16,7 +16,7 @@ DESCRIPTION="The Mozilla Firebird Web Browser"
HOMEPAGE="http://www.mozilla.org/projects/firebird/"
SRC_URI="http://komodo.mozilla.org/pub/firebird/releases/${PV}/MozillaFirebird-${PV}-source.tar.bz2"
-KEYWORDS="x86 ~ppc sparc"
+KEYWORDS="x86 ~ppc sparc ~alpha"
SLOT="0"
LICENSE="MPL-1.1 | NPL-1.1"
IUSE="java gtk2 ipv6"
@@ -48,6 +48,14 @@ export MOZ_PHOENIX=1
export MOZ_CALENDAR=0
export MOZ_ENABLE_XFT=1
+src_unpack() {
+ unpack MozillaFirebird-${PV}-source.tar.bz2
+
+ # alpha stubs patch from lfs project.
+ # <taviso@gentoo.org> (26 Jun 2003)
+ use alpha && epatch ${FILESDIR}/mozilla-1.3-alpha-stubs.patch
+}
+
src_compile() {
local myconf="--disable-composer \
--with-x \