summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-04 13:42:19 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-04 13:42:19 +0000
commita0d526558a5fc727d217f3821caa0da913943931 (patch)
treec4e644e3c0efdbd0330a99778cabd4ee91f48cba
parentfix for >=qt-3.1 (diff)
downloadgentoo-2-a0d526558a5fc727d217f3821caa0da913943931.tar.gz
gentoo-2-a0d526558a5fc727d217f3821caa0da913943931.tar.bz2
gentoo-2-a0d526558a5fc727d217f3821caa0da913943931.zip
Version bump.
-rw-r--r--net-libs/libfwbuilder/ChangeLog7
-rw-r--r--net-libs/libfwbuilder/files/digest-libfwbuilder-0.10.111
-rw-r--r--net-libs/libfwbuilder/libfwbuilder-0.10.11.ebuild42
-rw-r--r--net-misc/fwbuilder/ChangeLog7
-rw-r--r--net-misc/fwbuilder/files/digest-fwbuilder-1.0.71
-rw-r--r--net-misc/fwbuilder/fwbuilder-1.0.6.ebuild2
-rw-r--r--net-misc/fwbuilder/fwbuilder-1.0.7.ebuild52
7 files changed, 109 insertions, 3 deletions
diff --git a/net-libs/libfwbuilder/ChangeLog b/net-libs/libfwbuilder/ChangeLog
index b52b6da02c3d..faf6f550de56 100644
--- a/net-libs/libfwbuilder/ChangeLog
+++ b/net-libs/libfwbuilder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libfwbuilder
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libfwbuilder/ChangeLog,v 1.7 2002/10/04 01:32:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libfwbuilder/ChangeLog,v 1.8 2002/11/04 13:37:42 aliz Exp $
+
+*libfwbuilder-0.10.11 (04 Nov 2002)
+
+ 04 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump. Found by AutoBot <autobot@midsouth.rr.com> in #10084.
*libfwbuilder-0.10.10 (03 Oct 2002)
diff --git a/net-libs/libfwbuilder/files/digest-libfwbuilder-0.10.11 b/net-libs/libfwbuilder/files/digest-libfwbuilder-0.10.11
new file mode 100644
index 000000000000..abb9c3895423
--- /dev/null
+++ b/net-libs/libfwbuilder/files/digest-libfwbuilder-0.10.11
@@ -0,0 +1 @@
+MD5 f64765cb5532d838b86654c2c8831649 libfwbuilder-0.10.11.tar.gz 345756
diff --git a/net-libs/libfwbuilder/libfwbuilder-0.10.11.ebuild b/net-libs/libfwbuilder/libfwbuilder-0.10.11.ebuild
new file mode 100644
index 000000000000..45bae75c6ed0
--- /dev/null
+++ b/net-libs/libfwbuilder/libfwbuilder-0.10.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /home/cvsroot/gentoo-x86/net-libs/libfwbuilder/libfwbuilder-0.10.8.ebuild,v 1.0
+
+IUSE="ssl static"
+
+DESCRIPTION="A firewall GUI (library functions)"
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
+HOMEPAGE="http://fwbuilder.sourceforge.net/"
+S=${WORKDIR}/${P}
+
+KEYWORDS="~x86 ~sparc ~sparc64"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="=dev-libs/libsigc++-1.0*
+ >=dev-libs/libxslt-1.0.7
+ >=net-analyzer/ucd-snmp-4.2.3
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ local myconf
+
+ use static && myconf="${myconf} --disable-shared --enable-static=yes"
+ use ssl || myconf="${myconf} --without-openssl"
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die "./configure failed"
+
+ if [ "`use static`" ] ; then
+ emake LDFLAGS="-static" || die "emake LDFLAGS failed"
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ prepalldocs
+}
diff --git a/net-misc/fwbuilder/ChangeLog b/net-misc/fwbuilder/ChangeLog
index c125a76ba732..ae471512f7d7 100644
--- a/net-misc/fwbuilder/ChangeLog
+++ b/net-misc/fwbuilder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/fwbuilder
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/fwbuilder/ChangeLog,v 1.8 2002/10/04 01:28:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fwbuilder/ChangeLog,v 1.9 2002/11/04 13:42:19 aliz Exp $
+
+*fwbuilder-1.0.7 (04 Nov 2002)
+
+ 04 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump. Found by AutoBot <autobot@midsouth.rr.com> in #10085.
*fwbuilder-1.0.6 (03 Oct 2002)
diff --git a/net-misc/fwbuilder/files/digest-fwbuilder-1.0.7 b/net-misc/fwbuilder/files/digest-fwbuilder-1.0.7
new file mode 100644
index 000000000000..89a0038c7622
--- /dev/null
+++ b/net-misc/fwbuilder/files/digest-fwbuilder-1.0.7
@@ -0,0 +1 @@
+MD5 8c0fe7783d8c30a1e76ed3bf673e9175 fwbuilder-1.0.7.tar.gz 1165939
diff --git a/net-misc/fwbuilder/fwbuilder-1.0.6.ebuild b/net-misc/fwbuilder/fwbuilder-1.0.6.ebuild
index a570bcdfdbb7..a2b812b034bc 100644
--- a/net-misc/fwbuilder/fwbuilder-1.0.6.ebuild
+++ b/net-misc/fwbuilder/fwbuilder-1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /home/cvsroot/gentoo-x86/net-misc/fwbuilder/fwbuilder-1.0.4.ebuild,v 1.0
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fwbuilder/fwbuilder-1.0.6.ebuild,v 1.3 2002/11/04 13:42:19 aliz Exp $
DESCRIPTION="A firewall GUI"
SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
diff --git a/net-misc/fwbuilder/fwbuilder-1.0.7.ebuild b/net-misc/fwbuilder/fwbuilder-1.0.7.ebuild
new file mode 100644
index 000000000000..220eea43cd0e
--- /dev/null
+++ b/net-misc/fwbuilder/fwbuilder-1.0.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fwbuilder/fwbuilder-1.0.7.ebuild,v 1.1 2002/11/04 13:42:19 aliz Exp $
+
+DESCRIPTION="A firewall GUI"
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
+HOMEPAGE="http://fwbuilder.sourceforge.net/"
+S=${WORKDIR}/${P}
+
+KEYWORDS="~x86 ~sparc ~sparc64"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtkmm-1.2.8
+ >=dev-libs/libxslt-1.0.7
+ >=net-libs/libfwbuilder-0.10.11
+ media-libs/gdk-pixbuf
+ dev-libs/libxml2
+ =dev-libs/libsigc++-1.0*"
+RDEPEND="sys-apps/iproute"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+ use static && myconf="${myconf} --enable-shared=no --enable-static=yes"
+ use nls || myconf="${myconf} --disable-nls"
+ use pic && myconf="${myconf} --with-pic"
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --host=${CHOST} || die "./configure failed"
+
+ cp config.h config.h.orig
+ sed -e "s:#define HAVE_XMLSAVEFORMATFILE 1://:" config.h.orig > config.h
+
+ if [ "`use static`" ]
+ then
+ emake LDFLAGS="-static" || die "emake LDFLAGS failed"
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+}
+
+pkg_postinst() {
+ einfo "You may have to install iproute on the machine that"
+ einfo "will run the firewall script."
+}
+