summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-07-22 00:16:43 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-07-22 00:16:43 +0000
commit981e83f299cf98fb601ba435aca6c0c823318867 (patch)
tree14e7f67027c9691536e190f8b258286213fbdc4d
parentmask libcerf useflag (bug 517726) (diff)
downloadgentoo-2-981e83f299cf98fb601ba435aca6c0c823318867.tar.gz
gentoo-2-981e83f299cf98fb601ba435aca6c0c823318867.tar.bz2
gentoo-2-981e83f299cf98fb601ba435aca6c0c823318867.zip
remove libcerf auto-magic (bug #517726#c3)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
-rw-r--r--sci-visualization/gnuplot/ChangeLog9
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.0_rc1-libcerf.patch47
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.0_rc1-r1.ebuild (renamed from sci-visualization/gnuplot/gnuplot-5.0_rc1.ebuild)13
-rw-r--r--sci-visualization/gnuplot/metadata.xml1
4 files changed, 66 insertions, 4 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index e0b86ec2a43a..be0a81ee178c 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.248 2014/07/19 06:19:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.249 2014/07/22 00:16:43 ottxor Exp $
+
+*gnuplot-5.0_rc1-r1 (22 Jul 2014)
+
+ 22 Jul 2014; Christoph Junghans <ottxor@gentoo.org>
+ +files/gnuplot-5.0_rc1-libcerf.patch, +gnuplot-5.0_rc1-r1.ebuild,
+ -gnuplot-5.0_rc1.ebuild, metadata.xml:
+ remove libcerf auto-magic (bug #517726#c3)
19 Jul 2014; Ulrich Müller <ulm@gentoo.org> gnuplot-4.6.4-r2.ebuild:
Stable on x86, bug 508218.
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.0_rc1-libcerf.patch b/sci-visualization/gnuplot/files/gnuplot-5.0_rc1-libcerf.patch
new file mode 100644
index 000000000000..e9e0139f8d72
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-5.0_rc1-libcerf.patch
@@ -0,0 +1,47 @@
+https://sourceforge.net/p/gnuplot/feature-requests/399/
+Index: configure.in
+===================================================================
+RCS file: /cvsroot/gnuplot/gnuplot/configure.in,v
+retrieving revision 1.370
+diff -u -r1.370 configure.in
+--- configure.in 20 Jun 2014 22:58:46 -0000 1.370
++++ configure.in 21 Jul 2014 23:33:43 -0000
+@@ -80,19 +80,25 @@
+ AC_FUNC_FSEEKO
+ AC_SYS_LARGEFILE
+
+-dnl The libcerf library contains a set of complex-valued special functions
+-dnl related to the error function (cerf, erfi, Dawson's integral, Voigt profile).
+-dnl If libcerf is installed then we can use them.
+-PKG_CHECK_MODULES_NOFAIL([LIBCERF], [libcerf],
+- [
+- CPPFLAGS="$CPPFLAGS $LIBCERF_CFLAGS"
+- LDFLAGS="$LDFLAGS $LIBCERF_LIBS"
+- ],
+-)
+-AC_SEARCH_LIBS([cdawson], [cerf],
+- [AC_DEFINE([HAVE_LIBCERF], 1, [define if you have libcerf])
+- have_libcerf=yes]
+-)
++AC_ARG_WITH(libcerf,dnl
++[ --without-libcerf build without special functions from libcerf (default enabled)],,
++ [test -z "${with_libcerf}" && with_libcerf=yes])
++
++if test "${with_libcerf}" = yes ; then
++ dnl The libcerf library contains a set of complex-valued special functions
++ dnl related to the error function (cerf, erfi, Dawson's integral, Voigt profile).
++ dnl If libcerf is installed then we can use them.
++ PKG_CHECK_MODULES_NOFAIL([LIBCERF], [libcerf],
++ [
++ CPPFLAGS="$CPPFLAGS $LIBCERF_CFLAGS"
++ LDFLAGS="$LDFLAGS $LIBCERF_LIBS"
++ ],
++ )
++ AC_SEARCH_LIBS([cdawson], [cerf],
++ [AC_DEFINE([HAVE_LIBCERF], 1, [define if you have libcerf])
++ have_libcerf=yes]
++ )
++fi
+
+ dnl Various programs
+ dnl X/Emacs for building .texi version of docs
diff --git a/sci-visualization/gnuplot/gnuplot-5.0_rc1.ebuild b/sci-visualization/gnuplot/gnuplot-5.0_rc1-r1.ebuild
index 53a6bcd22231..2ec7e089ad7f 100644
--- a/sci-visualization/gnuplot/gnuplot-5.0_rc1.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-5.0_rc1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-5.0_rc1.ebuild,v 1.2 2014/07/14 19:35:11 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-5.0_rc1-r1.ebuild,v 1.1 2014/07/22 00:16:43 ottxor Exp $
EAPI=5
@@ -18,15 +18,17 @@ if [[ -z ${PV%%*9999} ]]; then
ECVS_CVS_OPTIONS="-dP"
MY_P="${PN}"
SRC_URI=""
+ KEYWORDS=""
else
MY_P="${P/_/.}"
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ inherit autotools
fi
LICENSE="gnuplot bitmap? ( free-noncomm )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="aqua bitmap cairo doc examples +gd ggi latex libcaca lua qt4 readline svga wxwidgets X"
+IUSE="aqua bitmap cairo doc examples +gd ggi latex libcaca libcerf lua qt4 readline svga wxwidgets X"
RDEPEND="
cairo? (
@@ -45,6 +47,7 @@ RDEPEND="
>=dev-qt/qtgui-4.5:4
>=dev-qt/qtsvg-4.5:4 )
readline? ( sys-libs/readline )
+ libcerf? ( sci-libs/libcerf )
svga? ( media-libs/svgalib )
wxwidgets? (
x11-libs/wxGTK:2.8[X]
@@ -72,6 +75,9 @@ src_prepare() {
emake -C "$dir" -f Makefile.am.in Makefile.am
done
eautoreconf
+ else
+ epatch "${FILESDIR}/${P}-libcerf.patch"
+ eautoreconf
fi
# Add special version identification as required by provision 2
@@ -120,6 +126,7 @@ src_configure() {
"$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
"$(use_with ggi xmi "${EPREFIX}/usr/$(get_libdir)")" \
"$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
+ $(use_with libcerf) \
$(use_with lua) \
$(use_with svga linux-vga) \
$(use_with X x) \
diff --git a/sci-visualization/gnuplot/metadata.xml b/sci-visualization/gnuplot/metadata.xml
index 206d84db0152..1a66c9402320 100644
--- a/sci-visualization/gnuplot/metadata.xml
+++ b/sci-visualization/gnuplot/metadata.xml
@@ -19,6 +19,7 @@
<use>
<flag name="gd">Add support for <pkg>media-libs/gd</pkg>.
Needed for GIF, JPEG, and PNG image output.</flag>
+<flag name="libcerf">Enable special functions from <pkg>sci-libs/libcerf</pkg></flag>
<flag name="thin-splines">Enable thin plate splines</flag>
<flag name="bitmap">Enable dot-matrix printers and pbm terminal</flag>
</use>