summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-19 03:32:10 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-19 03:32:10 +0000
commit8cefb787b5deb790eb51354c83b0639c40939b61 (patch)
tree35092be5896f986ae24c82d68c19ef4726c9da74
parentfix test phase; rm un-needed dep nose, IUSE test, fixes Bug #503744 by an eroen (diff)
downloadgentoo-2-8cefb787b5deb790eb51354c83b0639c40939b61.tar.gz
gentoo-2-8cefb787b5deb790eb51354c83b0639c40939b61.tar.bz2
gentoo-2-8cefb787b5deb790eb51354c83b0639c40939b61.zip
Move the readline version to a global var so it stays in sync.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--app-shells/bash/ChangeLog5
-rw-r--r--app-shells/bash/bash-4.3-r1.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index c35cc1c9f248..af3fea04a336 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.354 2014/03/10 01:15:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.355 2014/03/19 03:32:10 vapier Exp $
+
+ 19 Mar 2014; Mike Frysinger <vapier@gentoo.org> bash-4.3-r1.ebuild:
+ Move the readline version to a global var so it stays in sync.
*bash-4.3-r1 (10 Mar 2014)
diff --git a/app-shells/bash/bash-4.3-r1.ebuild b/app-shells/bash/bash-4.3-r1.ebuild
index 0e715c2d8c6b..f52a5680fc37 100644
--- a/app-shells/bash/bash-4.3-r1.ebuild
+++ b/app-shells/bash/bash-4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3-r1.ebuild,v 1.1 2014/03/10 01:15:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3-r1.ebuild,v 1.2 2014/03/19 03:32:10 vapier Exp $
EAPI="4"
@@ -28,6 +28,9 @@ patches() {
fi
}
+# The version of readline this bash normally ships with.
+READLINE_VER="6.3"
+
DESCRIPTION="The standard GNU Bourne again shell"
HOMEPAGE="http://tiswww.case.edu/php/chet/bash/bashtop.html"
SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
@@ -39,7 +42,7 @@ SLOT="0"
IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline vanilla"
DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.3 )
+ readline? ( >=sys-libs/readline-${READLINE_VER} )
nls? ( virtual/libintl )"
RDEPEND="${DEPEND}
!<sys-apps/portage-2.1.6.7_p1
@@ -117,7 +120,7 @@ src_configure() {
# be safe.
# Exact cached version here doesn't really matter as long as it
# is at least what's in the DEPEND up above.
- export ac_cv_rl_version=6.2
+ export ac_cv_rl_version=${READLINE_VER}
# Force linking with system curses ... the bundled termcap lib
# sucks bad compared to ncurses. For the most part, ncurses