summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-28 22:49:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-28 22:49:59 +0000
commit89c9b6c4ce448b52099d7c9e12eca9d11b25cbf9 (patch)
treef3d0d174e59bc93be4826b7ef463395b517426a3
parentStable on amd64 (bug #286743) (diff)
downloadgentoo-2-89c9b6c4ce448b52099d7c9e12eca9d11b25cbf9.tar.gz
gentoo-2-89c9b6c4ce448b52099d7c9e12eca9d11b25cbf9.tar.bz2
gentoo-2-89c9b6c4ce448b52099d7c9e12eca9d11b25cbf9.zip
Add a pic useflag
(Portage version: 2.2_rc42/cvs/Linux x86_64)
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999-r1.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 11 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 90a135c5a451..a9a71e25dbc6 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.317 2009/09/26 21:52:02 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.318 2009/09/28 22:49:59 aballier Exp $
+
+ 28 Sep 2009; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999-r1.ebuild,
+ metadata.xml:
+ Add a pic useflag
25 Sep 2009; Mounir Lamouri <volkmar@gentoo.org> ffmpeg-0.5_p19928.ebuild:
Keywording for ppc. Bug 283953
diff --git a/media-video/ffmpeg/ffmpeg-9999-r1.ebuild b/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
index ce10274a1c75..4d40104de1a9 100644
--- a/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999-r1.ebuild,v 1.20 2009/09/23 21:34:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999-r1.ebuild,v 1.21 2009/09/28 22:49:59 aballier Exp $
EAPI=2
SCM=""
@@ -28,7 +28,7 @@ KEYWORDS=""
IUSE="+3dnow +3dnowext alsa altivec cpudetection custom-cflags debug dirac
doc ieee1394 +encode faac faad gsm ipv6 jack +mmx +mmxext vorbis test
theora threads x264 xvid network zlib sdl X mp3 opencore-amr
- oss schroedinger +hardcoded-tables bindist v4l v4l2
+ oss pic schroedinger +hardcoded-tables bindist v4l v4l2
speex +ssse3 jpeg2k vdpau"
VIDEO_CARDS="nvidia"
@@ -165,6 +165,9 @@ src_configure() {
myconf="${myconf} --disable-mmx --disable-mmx2"
fi
+ # Option to force building pic
+ use pic && myconf="${myconf} --enable-pic"
+
# Try to get cpu type based on CFLAGS.
# Bug #172723
# We need to do this so that features of that CPU will be better used
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index bac10cedf19e..95a667d128c5 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -20,6 +20,7 @@
<flag name="mmxext">Enables mmx2 support</flag>
<flag name="network">Enables network streaming support</flag>
<flag name="opencore-amr">Enables Adaptive Multi-Rate format support</flag>
+ <flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="ssse3">faster floating point optimization for SSSE3 capable chips (Intel Core 2 and later chips)</flag>
<flag name="vdpau">Enables VDPAU decoders (requires nVidia video cards to offload CPU processing to video card</flag>