summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 01:01:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 01:01:16 +0000
commit8956a2e1a188569566fb94d50bedb361bdf03dd1 (patch)
treea092abc853d78cef43f06efb3714a96aa52cb047
parentVersion bump. (diff)
downloadgentoo-2-8956a2e1a188569566fb94d50bedb361bdf03dd1.tar.gz
gentoo-2-8956a2e1a188569566fb94d50bedb361bdf03dd1.tar.bz2
gentoo-2-8956a2e1a188569566fb94d50bedb361bdf03dd1.zip
Version bump.
(Portage version: 2.2_rc88_p32/cvs/Linux x86_64)
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-0.21.3.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index f332a0e5cece..65d10cc2322e 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.73 2010/09/19 18:20:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.74 2010/09/29 01:01:16 arfrever Exp $
+
+*pylint-0.21.3 (29 Sep 2010)
+
+ 29 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pylint-0.21.3.ebuild:
+ Version bump.
*pylint-0.21.2 (19 Sep 2010)
diff --git a/dev-python/pylint/pylint-0.21.3.ebuild b/dev-python/pylint/pylint-0.21.3.ebuild
new file mode 100644
index 000000000000..0923017dc635
--- /dev/null
+++ b/dev-python/pylint/pylint-0.21.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.3.ebuild,v 1.1 2010/09/29 01:01:16 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+PYTHON_USE_WITH_OPT="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples tk"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.50.1
+ >=dev-python/astng-0.20.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DOCS="doc/*.txt"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if ! use tk; then
+ rm -f "${ED}usr/bin/pylint-gui"*
+ fi
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+}