summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-29 12:56:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-29 12:56:18 +0000
commit82613ab409a84b019e1a10c1d81fc2168692a9eb (patch)
tree9cc6ce1b5e13e23b39240a34f028a1b0ff9036c1
parentNew ebuild for dev-python/bluelet module for pure Python asynchronous I/O usi... (diff)
downloadgentoo-2-82613ab409a84b019e1a10c1d81fc2168692a9eb.tar.gz
gentoo-2-82613ab409a84b019e1a10c1d81fc2168692a9eb.tar.bz2
gentoo-2-82613ab409a84b019e1a10c1d81fc2168692a9eb.zip
Add avresample useflag
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild15
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 15 insertions, 7 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 323798ca06bd..bf28fa8b493f 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.557 2012/05/26 18:19:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.558 2012/05/29 12:56:18 aballier Exp $
+
+ 29 May 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ Add avresample useflag
*ffmpeg-0.11 (26 May 2012)
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 51b68b241bd8..38eafdbfba36 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.94 2012/05/17 20:45:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.95 2012/05/29 12:56:18 aballier Exp $
EAPI="4"
@@ -29,11 +29,11 @@ if [ "${PV#9999}" = "${PV}" ] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
fi
IUSE="
- aac aacplus alsa amr ass bindist bluray +bzip2 cdio celt cpudetection debug
- doc +encode faac fontconfig frei0r gnutls gsm +hardcoded-tables
- ieee1394 jack jpeg2k libv4l modplug mp3 network openal openssl oss pic
- pulseaudio rtmp schroedinger sdl speex static-libs test theora threads
- truetype v4l vaapi vdpau vorbis vpx X x264 xvid +zlib
+ aac aacplus alsa amr ass avresample bindist bluray +bzip2 cdio celt
+ cpudetection debug doc +encode faac fontconfig frei0r gnutls gsm
+ +hardcoded-tables ieee1394 jack jpeg2k libv4l modplug mp3 network openal
+ openssl oss pic pulseaudio rtmp schroedinger sdl speex static-libs test
+ theora threads truetype v4l vaapi vdpau vorbis vpx X x264 xvid +zlib
"
# String for CPU features in the useflag[:configure_option] form
@@ -237,6 +237,9 @@ src_configure() {
esac
fi
+ # avresample support for libav compatibility
+ use avresample && myconf="${myconf} --enable-avresample"
+
# Misc stuff
use hardcoded-tables && myconf="${myconf} --enable-hardcoded-tables"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 617e548641ea..83f4324dfcc8 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -14,6 +14,7 @@
<flag name="ass">Enables <pkg>media-libs/libass</pkg> based subtitle renderer.</flag>
<flag name="aacplus">AAC+ encoding via <pkg>media-libs/libaacplus</pkg>.</flag>
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
+ <flag name="avresample">Enables libavresample, <pkg>media-video/libav</pkg> version of libswresample (which installed and makes libavresample redundant): A conversion library between uncompressed audio formats.</flag>
<flag name="avx">Adds support for Advanced Vector Extensions instructions (Intel Sandy Bridge, AMD Bulldozer and later chips)</flag>
<flag name="bluray">Enable playback of Blu-ray filesystems</flag>
<flag name="cdio">Enables audio CD grabbing with <pkg>dev-libs/libcdio</pkg>.</flag>