summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-10-18 12:06:08 +0000
committerTorsten Veller <tove@gentoo.org>2009-10-18 12:06:08 +0000
commit7dd5040c45e1e83ecbd980392ac4c1275cdf8f29 (patch)
tree60ad08444699d4d34b3ec2623709f4244acf2112
parentFix compliation with perl 5.10. (diff)
downloadgentoo-2-7dd5040c45e1e83ecbd980392ac4c1275cdf8f29.tar.gz
gentoo-2-7dd5040c45e1e83ecbd980392ac4c1275cdf8f29.tar.bz2
gentoo-2-7dd5040c45e1e83ecbd980392ac4c1275cdf8f29.zip
Version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/getmail-4.13.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 32a978e40720..b3818deae2e4 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.172 2009/10/17 17:55:09 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.173 2009/10/18 12:06:08 tove Exp $
+
+*getmail-4.13.0 (18 Oct 2009)
+
+ 18 Oct 2009; Torsten Veller <tove@gentoo.org> +getmail-4.13.0.ebuild:
+ Version bump
17 Oct 2009; Torsten Veller <tove@gentoo.org> -getmail-4.7.6.ebuild,
-getmail-4.8.1.ebuild, -getmail-4.8.4.ebuild, -getmail-4.9.0.ebuild:
diff --git a/net-mail/getmail/getmail-4.13.0.ebuild b/net-mail/getmail/getmail-4.13.0.ebuild
new file mode 100644
index 000000000000..f3857a181a00
--- /dev/null
+++ b/net-mail/getmail/getmail-4.13.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.13.0.ebuild,v 1.1 2009/10/18 12:06:08 tove Exp $
+
+inherit distutils
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~ppc-macos ~x64-solaris"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3.3"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME=getmailcore
+
+src_install() {
+ [[ -z ${ED} ]] && local ED=${D}
+ distutils_src_install
+
+ # handle docs the gentoo way
+ rm "${ED}"/usr/share/doc/${P}/COPYING || die
+ if [[ ${P} != ${PF} ]] ; then
+ mv "${ED}"/usr/share/doc/${P} "${ED}"/usr/share/doc/${PF} || die
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv "${ED}"/usr/share/doc/${PF}/*.{html,css} "${ED}"/usr/share/doc/${PF}/html || die
+}