summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-13 10:39:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-13 10:39:55 +0000
commit70a4227be08153cd02429c3325b239832a0ccdbc (patch)
tree3d76819f6902018236091b4492e8147a26ccba9f
parentreduce number of libs to link against for poppler-glib, inspired by upstream ... (diff)
downloadgentoo-2-70a4227be08153cd02429c3325b239832a0ccdbc.tar.gz
gentoo-2-70a4227be08153cd02429c3325b239832a0ccdbc.tar.bz2
gentoo-2-70a4227be08153cd02429c3325b239832a0ccdbc.zip
Fix building with -Wl,--as-needed.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
-rw-r--r--x11-misc/xnee/ChangeLog6
-rw-r--r--x11-misc/xnee/files/xnee-3.05-asneeded.patch10
-rw-r--r--x11-misc/xnee/xnee-3.05.ebuild9
3 files changed, 22 insertions, 3 deletions
diff --git a/x11-misc/xnee/ChangeLog b/x11-misc/xnee/ChangeLog
index 5ab55d9e481b..f1525e628a87 100644
--- a/x11-misc/xnee/ChangeLog
+++ b/x11-misc/xnee/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xnee
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.6 2010/02/09 18:16:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.7 2010/02/13 10:39:54 ssuominen Exp $
+
+ 13 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> xnee-3.05.ebuild,
+ +files/xnee-3.05-asneeded.patch:
+ Fix building with -Wl,--as-needed.
*xnee-3.05 (09 Feb 2010)
diff --git a/x11-misc/xnee/files/xnee-3.05-asneeded.patch b/x11-misc/xnee/files/xnee-3.05-asneeded.patch
new file mode 100644
index 000000000000..cc378f16602d
--- /dev/null
+++ b/x11-misc/xnee/files/xnee-3.05-asneeded.patch
@@ -0,0 +1,10 @@
+--- libxnee/src/Makefile.am
++++ libxnee/src/Makefile.am
+@@ -75,6 +75,7 @@
+ lib_LTLIBRARIES = $(WANTED_LIBXNEE)
+ libxnee_la_LDFLAGS = -rpath '$(libdir)'
+ libxnee_la_SOURCES = $(LIB_XNEE_SOURCE_FILES)
++libxnee_la_LIBADD = @X_PRE_LIBS@ @X11_LIBS@
+ libxnee_a_CFLAGS = $(AM_CFLAGS)
+
+ dnl noinst_LIBRARIES = libxnee.a
diff --git a/x11-misc/xnee/xnee-3.05.ebuild b/x11-misc/xnee/xnee-3.05.ebuild
index 73acf0d49098..acd6f8fe3bd1 100644
--- a/x11-misc/xnee/xnee-3.05.ebuild
+++ b/x11-misc/xnee/xnee-3.05.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/xnee-3.05.ebuild,v 1.1 2010/02/09 18:16:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/xnee-3.05.ebuild,v 1.2 2010/02/13 10:39:54 ssuominen Exp $
EAPI=2
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Program suite to record, replay and distribute user actions."
HOMEPAGE="http://www.sandklef.com/xnee/"
@@ -26,6 +26,11 @@ DEPEND="${RDEPEND}
gnome? ( sys-devel/gettext
media-gfx/imagemagick )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_configure() {
local myconf=""