summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-08-30 11:42:30 +0000
committerMichael Imhof <tantive@gentoo.org>2002-08-30 11:42:30 +0000
commit6c6841daac03cfb15e82473e358a1c7da00c8c45 (patch)
treea6f5b48cf0781b6fb3e40be4cb761b0f2e1c2a98
parentmasked openmosix-user-0.2.4-r1 for further testing (diff)
downloadgentoo-2-6c6841daac03cfb15e82473e358a1c7da00c8c45.tar.gz
gentoo-2-6c6841daac03cfb15e82473e358a1c7da00c8c45.tar.bz2
gentoo-2-6c6841daac03cfb15e82473e358a1c7da00c8c45.zip
Created symlinks in /bin for some tools located in /usr/bin to make
scripts run properly.
-rw-r--r--sys-apps/openmosix-user/ChangeLog9
-rw-r--r--sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r11
-rw-r--r--sys-apps/openmosix-user/openmosix-user-0.2.4-r1.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/openmosix-user/ChangeLog b/sys-apps/openmosix-user/ChangeLog
index e32fdf08ba7f..4d655539b767 100644
--- a/sys-apps/openmosix-user/ChangeLog
+++ b/sys-apps/openmosix-user/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/openmosix-user
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/ChangeLog,v 1.4 2002/08/28 19:09:22 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/ChangeLog,v 1.5 2002/08/30 11:42:30 tantive Exp $
+
+
+* openmosix-user-0.2.4-r1 (30 Aug 2002)
+
+ 30 Aug 2002; Michael Imhof <tantive@gentoo.org>
+ Created symlinks in /bin for /usr/bin/[mmon/migrate/mosctl/mosrun] to make
+ scripts like nomig run.
* openmosix-user-0.2.4 (19 Aug 2002)
diff --git a/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r1 b/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r1
new file mode 100644
index 000000000000..85f88e730ce3
--- /dev/null
+++ b/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r1
@@ -0,0 +1 @@
+MD5 2e4e630a391900b331323bffea5c5547 openMosixUserland-0.2.4.tgz 65494
diff --git a/sys-apps/openmosix-user/openmosix-user-0.2.4-r1.ebuild b/sys-apps/openmosix-user/openmosix-user-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..82176a7d13c9
--- /dev/null
+++ b/sys-apps/openmosix-user/openmosix-user-0.2.4-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/openmosix-user-0.2.4-r1.ebuild,v 1.1 2002/08/30 11:42:30 tantive Exp $
+
+S=${WORKDIR}/openMosixUserland-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openMosixUserland-${PV}.tgz"
+HOMEPAGE="http://www.openmosix.com"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.18"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ sys-devel/perl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat > configuration << EOF
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\$(OPENMOSIX)/include ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+}
+
+src_compile() {
+ cd ${S}
+ make clean build
+}
+
+src_install () {
+ dodir /usr/lib
+ dodir /usr/sbin
+ dodir /usr/include
+ dodir /usr/bin
+ dodir /bin
+ ln -s /usr/bin/migrate ${D}/bin/migrate
+ ln -s /usr/bin/mmon ${D}/bin/mmon
+ ln -s /usr/bin/mosctl ${D}/bin/mosctl
+ ln -s /usr/bin/mosrun ${D}/bin/mosrun
+ dodir /usr/share/man/man1
+ make INSTALLBASEDIR=${D}usr \
+ INSTALLMANDIR=${D}usr/share/man \
+ INSTALLEXTRADIR=${D}usr/share \
+ DESTDIR=${D} \
+ INSTALLDIR=${D}usr \
+ install
+
+ dodoc COPYING README
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ insinto /etc
+ #stub mosix.map file
+ doins ${FILESDIR}/mosix.map
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/mosix.map and then type:
+ einfo "# rc-update add openmosix default
+ einfo " ...to add openMosix to the default runlevel. This particular version of"
+ einfo " openmosix-user has been designed to work with the linux-2.4.18-openmosix-r1"
+ einfo " or later kernel (>=sys-kernel/openmosix-sources-2.4.18)"
+ einfo
+}