summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-05-06 07:19:06 +0000
committerPeter Volkov <pva@gentoo.org>2008-05-06 07:19:06 +0000
commit5c59261b54df6ca78f57d21ae45f7105fbb90c02 (patch)
treee1bcfa249621e4a0932667f0bcfc9fbdc1347d7e
parentAdd SPTK-3.5.7.10 (diff)
downloadgentoo-2-5c59261b54df6ca78f57d21ae45f7105fbb90c02.tar.gz
gentoo-2-5c59261b54df6ca78f57d21ae45f7105fbb90c02.tar.bz2
gentoo-2-5c59261b54df6ca78f57d21ae45f7105fbb90c02.zip
Version bump, thank Vincent-Xavier JUMEL for bug #211288; thank Matteo Azzali for fixing crash, and Tiziano Müller for homepage change notice.
(Portage version: 2.1.4.4)
-rw-r--r--net-firewall/kmyfirewall/ChangeLog12
-rw-r--r--net-firewall/kmyfirewall/files/kmyfirewall-1.1.1-interfaces-crash.patch51
-rw-r--r--net-firewall/kmyfirewall/kmyfirewall-1.1.1.ebuild53
3 files changed, 114 insertions, 2 deletions
diff --git a/net-firewall/kmyfirewall/ChangeLog b/net-firewall/kmyfirewall/ChangeLog
index f7c27f24e9d8..4a89270b30a2 100644
--- a/net-firewall/kmyfirewall/ChangeLog
+++ b/net-firewall/kmyfirewall/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-firewall/kmyfirewall
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/kmyfirewall/ChangeLog,v 1.34 2007/07/26 19:06:53 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/kmyfirewall/ChangeLog,v 1.35 2008/05/06 07:19:06 pva Exp $
+
+*kmyfirewall-1.1.1 (06 May 2008)
+
+ 06 May 2008; Peter Volkov <pva@gentoo.org>
+ +files/kmyfirewall-1.1.1-interfaces-crash.patch,
+ +kmyfirewall-1.1.1.ebuild:
+ Version bump, thank Vincent-Xavier JUMEL for bug #211288; thank Matteo
+ Azzali for fixing crash, and Tiziano Müller for homepage change notice.
26 Jul 2007; Raúl Porcel <armin76@gentoo.org>
kmyfirewall-1.0.1-r1.ebuild:
diff --git a/net-firewall/kmyfirewall/files/kmyfirewall-1.1.1-interfaces-crash.patch b/net-firewall/kmyfirewall/files/kmyfirewall-1.1.1-interfaces-crash.patch
new file mode 100644
index 000000000000..85ab774cf7da
--- /dev/null
+++ b/net-firewall/kmyfirewall/files/kmyfirewall-1.1.1-interfaces-crash.patch
@@ -0,0 +1,51 @@
+--- kmyfirewall/kmfwidgets/kmfsystemsettingslinux.cpp.orig 2008-05-02 10:50:24.000000000 +0200
++++ kmyfirewall/kmfwidgets/kmfsystemsettingslinux.cpp 2008-05-02 12:08:26.000000000 +0200
+@@ -57,6 +57,12 @@
+ this, SLOT( slotSettingChanged() ) );
+ connect( m_cob_distribution, SIGNAL( activated( const QString& ) ),
+ this, SLOT( slotDistributionChanged() ) );
++
++ m_url_ipt_path->setEnabled( false );
++ m_url_mod_path->setEnabled( false );
++ m_url_init_path->setEnabled( false );
++ m_url_runlevel_path->setEnabled( false );
++ m_cob_distribution->setEnabled( false );
+ }
+
+ KMFSystemSettingsLinux::~KMFSystemSettingsLinux()
+@@ -77,6 +83,11 @@
+ kdDebug() << "KMFInterfaceWidget::updateView() - ERROR: m_target == 0 " << endl;
+ return;
+ }
++ m_url_ipt_path->setEnabled( true );
++ m_url_mod_path->setEnabled( true );
++ m_url_init_path->setEnabled( true );
++ m_url_runlevel_path->setEnabled( true );
++ m_cob_distribution->setEnabled( true );
+ KMFTargetConfig *conf = m_target->config();
+
+ kdDebug() << "KMFInterfaceWidget::updateView() - config: " << endl;
+--- kmyfirewall/kmfwidgets/kmfinterfacewidget.cpp.orig 2008-05-02 10:26:05.000000000 +0200
++++ kmyfirewall/kmfwidgets/kmfinterfacewidget.cpp 2008-05-02 12:08:51.000000000 +0200
+@@ -53,6 +53,10 @@
+ m_cb_int_name->insertItem( "tap" );
+ m_cb_int_name->insertItem( "gre" );
+ m_cb_int_name->insertItem( "lo" );
++ m_cb_int_name->setEnabled( false );
++ m_sb_int_num->setEnabled( false );
++ m_b_add_int->setEnabled( false );
++ m_b_del_int->setEnabled( false );
+ }
+
+ KMFInterfaceWidget::~KMFInterfaceWidget() {}
+@@ -68,6 +72,10 @@
+ if ( ! m_target ) {
+ return;
+ }
++ m_cb_int_name->setEnabled( true );
++ m_sb_int_num->setEnabled( true );
++ m_b_add_int->setEnabled( true );
++ m_b_del_int->setEnabled( true );
+ KMFTargetConfig *conf = m_target->config();
+ kdDebug() << "Load Config:" << endl;
+ kdDebug() << conf->toString() << endl;
diff --git a/net-firewall/kmyfirewall/kmyfirewall-1.1.1.ebuild b/net-firewall/kmyfirewall/kmyfirewall-1.1.1.ebuild
new file mode 100644
index 000000000000..bea0ff18c49c
--- /dev/null
+++ b/net-firewall/kmyfirewall/kmyfirewall-1.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/kmyfirewall/kmyfirewall-1.1.1.ebuild,v 1.1 2008/05/06 07:19:06 pva Exp $
+
+inherit kde eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="Graphical KDE iptables configuration tool"
+HOMEPAGE="http://www.kmyfirewall.org/"
+SRC_URI="mirror://sourceforge/kmyfirewall/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-firewall/iptables"
+
+S=${WORKDIR}/${MY_P}
+
+need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+ cat > "${S}"/kmyfirewall/kmyfirewallrc <<-EOF
+ [PATHS]
+ Distribution=gentoo
+ IPTPath=/sbin/iptables
+ ModprobePath=/sbin/modprobe
+ rcDefaultPath=/etc/runlevels/default/
+ EOF
+
+ epatch "${FILESDIR}"/${P}-interfaces-crash.patch
+}
+
+src_install() {
+ kde_src_install
+
+ # search path is broken in the app, help it temporarily
+ dosym {kpartplugins,/usr/share/apps/kmyfirewall}/kmfinstallerpluginui.rc
+ dosym {kpartplugins,/usr/share/apps/kmyfirewall}/kmfinstallerpluginui.rc
+}
+
+pkg_postinst() {
+ elog
+ elog "Only run-as-user menuentry provided. If you want to directly"
+ elog "run kmyfirewall as root (inside kdesu), just check:"
+ elog "run-as-other-user inside the menu edit,leving blank the field"
+ elog
+ ewarn "Use this version if you want to use the new generic interface"
+ ewarn "For iptables interface using 0.9 series is heavily recommended"
+ ewarn "See Bug #165429 for details"
+}