summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 22:26:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 22:26:57 +0000
commit5bb7d8437f13ec11a66d169864d9225945710ec8 (patch)
treeebf99aa2f2f05a1e574d8195d5ec2282d65ae521
parentAdd prefix keywords, fix D/ED usage (diff)
downloadgentoo-2-5bb7d8437f13ec11a66d169864d9225945710ec8.tar.gz
gentoo-2-5bb7d8437f13ec11a66d169864d9225945710ec8.tar.bz2
gentoo-2-5bb7d8437f13ec11a66d169864d9225945710ec8.zip
Use distutils_get_intermediate_installation_image().
(Portage version: 2.2.0_alpha29_p17/cvs/Linux x86_64)
-rw-r--r--net-zope/zope/zope-2.12.17.ebuild4
-rw-r--r--net-zope/zope/zope-2.13.6.ebuild5
2 files changed, 4 insertions, 5 deletions
diff --git a/net-zope/zope/zope-2.12.17.ebuild b/net-zope/zope/zope-2.12.17.ebuild
index e170714c2a26..612b65b63510 100644
--- a/net-zope/zope/zope-2.12.17.ebuild
+++ b/net-zope/zope/zope-2.12.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.12.17.ebuild,v 1.1 2011/04/03 19:24:08 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.12.17.ebuild,v 1.2 2011/04/12 22:26:57 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -100,7 +100,7 @@ src_compile() {
}
distutils_src_install_post_hook() {
- mv "${T}/images/${PYTHON_ABI}/${ZOPE_INSTALLATION_DIR}/lib/python"{,-${PYTHON_ABI}}
+ mv "$(distutils_get_intermediate_installation_image)/${ZOPE_INSTALLATION_DIR}/lib/python"{,-${PYTHON_ABI}}
}
src_install() {
diff --git a/net-zope/zope/zope-2.13.6.ebuild b/net-zope/zope/zope-2.13.6.ebuild
index a18c88c9e7e2..9c7871230c69 100644
--- a/net-zope/zope/zope-2.13.6.ebuild
+++ b/net-zope/zope/zope-2.13.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.13.6.ebuild,v 1.1 2011/04/03 19:47:47 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.13.6.ebuild,v 1.2 2011/04/12 22:26:57 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -110,8 +110,7 @@ src_compile() {
}
distutils_src_install_post_hook() {
- # mv "$(distutils_get_intermediate_installation_image)/${ZOPE_INSTALLATION_DIR}/lib/python"{,-${PYTHON_ABI}}
- mv "${T}/images/${PYTHON_ABI}/${ZOPE_INSTALLATION_DIR}/lib/python"{,-${PYTHON_ABI}}
+ mv "$(distutils_get_intermediate_installation_image)/${ZOPE_INSTALLATION_DIR}/lib/python"{,-${PYTHON_ABI}}
}
src_install() {