summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-07-11 20:06:26 +0000
committerUlrich Müller <ulm@gentoo.org>2015-07-11 20:06:26 +0000
commit585213321d198e83ba515af81a1fd1462766e839 (patch)
tree674fcc1aecb20ff8ee8130b5516b10522c0a8858
parentVersion bump; remove old (diff)
downloadgentoo-2-585213321d198e83ba515af81a1fd1462766e839.tar.gz
gentoo-2-585213321d198e83ba515af81a1fd1462766e839.tar.bz2
gentoo-2-585213321d198e83ba515af81a1fd1462766e839.zip
Make pkg_preinst() idempotent, bug 554518.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
-rw-r--r--app-emacs/emacs-common-gentoo/ChangeLog5
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.5.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/app-emacs/emacs-common-gentoo/ChangeLog b/app-emacs/emacs-common-gentoo/ChangeLog
index 0317879d4d56..ffc14073530c 100644
--- a/app-emacs/emacs-common-gentoo/ChangeLog
+++ b/app-emacs/emacs-common-gentoo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/emacs-common-gentoo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/ChangeLog,v 1.124 2015/06/05 12:07:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/ChangeLog,v 1.125 2015/07/11 20:06:26 ulm Exp $
+
+ 11 Jul 2015; Ulrich Müller <ulm@gentoo.org> emacs-common-gentoo-1.5.ebuild:
+ Make pkg_preinst() idempotent, bug 554518.
05 Jun 2015; Ulrich Müller <ulm@gentoo.org> emacs-common-gentoo-1.5.ebuild:
Remove backwards compatibility code for site-start.el.
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.5.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.5.ebuild
index 85267a16bcf7..41ca9a552112 100644
--- a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.5.ebuild
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.5.ebuild,v 1.11 2015/06/05 12:07:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.5.ebuild,v 1.12 2015/07/11 20:06:26 ulm Exp $
EAPI=5
@@ -71,11 +71,11 @@ src_install() {
pkg_preinst() {
# make sure that site-gentoo.el exists since site-start.el requires it
- if [[ ! -d ${EROOT}${SITELISP} ]]; then
+ if [[ ! -f ${ED}${SITELISP}/site-gentoo.el ]]; then #554518
mv "${ED}${SITELISP}"/site-gentoo.el{.orig,} || die
- else
+ fi
+ if [[ -d ${EROOT}${SITELISP} ]]; then
elisp-site-regen
- rm "${ED}${SITELISP}/site-gentoo.el.orig" || die
cp "${EROOT}${SITELISP}/site-gentoo.el" "${ED}${SITELISP}/" || die
fi