summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-01-11 14:59:52 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-01-11 14:59:52 +0000
commit5807d0e490dfd56b6ac198a8e20270bab3d02f62 (patch)
treef59cebc9f80bd11b1ddcbdfa9a94674868c72f2e
parentversion bump (diff)
downloadgentoo-2-5807d0e490dfd56b6ac198a8e20270bab3d02f62.tar.gz
gentoo-2-5807d0e490dfd56b6ac198a8e20270bab3d02f62.tar.bz2
gentoo-2-5807d0e490dfd56b6ac198a8e20270bab3d02f62.zip
Fix build failure against latest monadcatchio-mtl-0.3.1.0 (bug #497496 by Jason Mours).
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
-rw-r--r--dev-haskell/cgi/ChangeLog11
-rw-r--r--dev-haskell/cgi/cgi-3001.1.8.4-r1.ebuild37
-rw-r--r--dev-haskell/cgi/files/cgi-3001.1.8.4-mci.patch15
3 files changed, 61 insertions, 2 deletions
diff --git a/dev-haskell/cgi/ChangeLog b/dev-haskell/cgi/ChangeLog
index 24912d8a9941..c8432c029607 100644
--- a/dev-haskell/cgi/ChangeLog
+++ b/dev-haskell/cgi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/cgi
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/ChangeLog,v 1.33 2013/12/24 12:57:12 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/ChangeLog,v 1.34 2014/01/11 14:59:52 slyfox Exp $
+
+*cgi-3001.1.8.4-r1 (11 Jan 2014)
+
+ 11 Jan 2014; Sergei Trofimovich <slyfox@gentoo.org> +cgi-3001.1.8.4-r1.ebuild,
+ +files/cgi-3001.1.8.4-mci.patch:
+ Fix build failure against latest monadcatchio-mtl-0.3.1.0 (bug #497496 by
+ Jason Mours).
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> cgi-3001.1.8.4.ebuild:
Stable for x86, wrt bug #491984
diff --git a/dev-haskell/cgi/cgi-3001.1.8.4-r1.ebuild b/dev-haskell/cgi/cgi-3001.1.8.4-r1.ebuild
new file mode 100644
index 000000000000..6a844035c783
--- /dev/null
+++ b/dev-haskell/cgi/cgi-3001.1.8.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/cgi-3001.1.8.4-r1.ebuild,v 1.1 2014/01/11 14:59:52 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A library for writing CGI programs"
+HOMEPAGE="http://andersk.mit.edu/haskell/cgi/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="+extensible-exceptions-in-base"
+
+RDEPEND="dev-haskell/monadcatchio-mtl:=[profile?]
+ >=dev-haskell/mtl-1.0:=[profile?]
+ >=dev-haskell/network-2.0:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?]
+ >=dev-haskell/xhtml-3000.0.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ !extensible-exceptions-in-base? ( dev-haskell/extensible-exceptions:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}"/${P}-mci.patch)
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag extensible-exceptions-in-base extensible-exceptions-in-base)
+}
diff --git a/dev-haskell/cgi/files/cgi-3001.1.8.4-mci.patch b/dev-haskell/cgi/files/cgi-3001.1.8.4-mci.patch
new file mode 100644
index 000000000000..b672947ab1f9
--- /dev/null
+++ b/dev-haskell/cgi/files/cgi-3001.1.8.4-mci.patch
@@ -0,0 +1,15 @@
+Gentoo-bug: https://bugs.gentoo.org/show_bug.cgi?id=497496
+Gentoo-Haskell-bug: https://github.com/gentoo-haskell/gentoo-haskell/issues/297
+diff --git a/Network/CGI/Monad.hs b/Network/CGI/Monad.hs
+index 758ab03..9c41fc3 100644
+--- a/Network/CGI/Monad.hs
++++ b/Network/CGI/Monad.hs
+@@ -119,7 +119,7 @@ catchCGI = catch
+
+ -- | Catches any exception thrown by an CGI action, and returns either
+ -- the exception, or if no exception was raised, the result of the action.
+-tryCGI :: (MonadCGI m, MonadCatchIO m) => m a -> m (Either SomeException a)
++tryCGI :: (MonadCGI m, MonadCatchIO m, Functor m) => m a -> m (Either SomeException a)
+ tryCGI = try
+
+ {-# DEPRECATED handleExceptionCGI "Use catchCGI instead." #-}