summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-06-24 14:20:28 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-06-24 14:20:28 +0000
commit56e3bfdb0d87e665b837ef5f3c7b9108dcea0857 (patch)
tree94a1c39a2e51c564ecd64e615f2ed5a327c40f5b
parentnew release (diff)
downloadgentoo-2-56e3bfdb0d87e665b837ef5f3c7b9108dcea0857.tar.gz
gentoo-2-56e3bfdb0d87e665b837ef5f3c7b9108dcea0857.tar.bz2
gentoo-2-56e3bfdb0d87e665b837ef5f3c7b9108dcea0857.zip
new release
-rw-r--r--dev-haskell/hmake/ChangeLog9
-rw-r--r--dev-haskell/hmake/Manifest4
-rw-r--r--dev-haskell/hmake/files/digest-hmake-3.081
-rw-r--r--dev-haskell/hmake/files/patch-3.08-cpp30
-rw-r--r--dev-haskell/hmake/hmake-3.08.ebuild86
5 files changed, 127 insertions, 3 deletions
diff --git a/dev-haskell/hmake/ChangeLog b/dev-haskell/hmake/ChangeLog
index 4d8bb8d3ab79..adf88de0a534 100644
--- a/dev-haskell/hmake/ChangeLog
+++ b/dev-haskell/hmake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/hmake
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.1 2003/04/22 08:27:53 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.2 2003/06/24 14:20:03 kosmikus Exp $
+
+*hmake-3.08 (24 Jun 2003)
+
+ 24 Jun 2003; Andres Loeh <kosmikus@gentoo.org> hmake-3.08.ebuild,
+ files/patch-3.08-cpp:
+ Version bump. Cleaned up the ebuild. Readline usage now really is disabled if
+ corresponding USE flag is not set.
*hmake-3.07 (22 Apr 2003)
diff --git a/dev-haskell/hmake/Manifest b/dev-haskell/hmake/Manifest
index 233ed64c85fd..8e5b131f1c56 100644
--- a/dev-haskell/hmake/Manifest
+++ b/dev-haskell/hmake/Manifest
@@ -1,6 +1,6 @@
-MD5 bfdcdca18926434bd7a492760cb1e672 ChangeLog 502
+MD5 2be2024c90fa67101af3f6e92357854a ChangeLog 739
MD5 9d1b42bebcf0797a5dfe6d96ad046431 hmake-3.07.ebuild 1290
-MD5 69f1f603f73fde86d577339aa06a9bf4 hmake-3.08.ebuild 2003
+MD5 3e5d570f72f9544ac589266141cb7fbc hmake-3.08.ebuild 2003
MD5 c9976e0d30592cb6953aba0dbaebf223 files/digest-hmake-3.07 61
MD5 e724d6dc9e5854bd0286a73dd30edd28 files/digest-hmake-3.08 61
MD5 fba0ed68f7cdb071ce3b1e7c56225d76 files/patch-3.08-cpp 714
diff --git a/dev-haskell/hmake/files/digest-hmake-3.08 b/dev-haskell/hmake/files/digest-hmake-3.08
new file mode 100644
index 000000000000..d4e65b51853f
--- /dev/null
+++ b/dev-haskell/hmake/files/digest-hmake-3.08
@@ -0,0 +1 @@
+MD5 ac51b12cacc044699e51850dcdebb6ba hmake-3.08.tar.gz 74431
diff --git a/dev-haskell/hmake/files/patch-3.08-cpp b/dev-haskell/hmake/files/patch-3.08-cpp
new file mode 100644
index 000000000000..8b518f528562
--- /dev/null
+++ b/dev-haskell/hmake/files/patch-3.08-cpp
@@ -0,0 +1,30 @@
+Index: src/hmake/Imports.hs
+===================================================================
+RCS file: /home/cvs/root/nhc98/src/hmake/Imports.hs,v
+retrieving revision 1.7
+diff -u -r1.7 Imports.hs
+--- src/hmake/Imports.hs 27 Jun 2002 14:27:55 -0000 1.7
++++ src/hmake/Imports.hs 24 Jun 2003 13:01:09 -0000
+@@ -190,17 +190,17 @@
+ ((n,_):_) -> n :: Integer
+
+ parseOp st =
+- do skip (char '>')
+- return (>)
+- +++
+ do skip (string ">=")
+ return (>=)
+ +++
+- do skip (char '<')
+- return (<)
++ do skip (char '>')
++ return (>)
+ +++
+ do skip (string "<=")
+ return (<=)
++ +++
++ do skip (char '<')
++ return (<)
+ +++
+ do skip (string "==")
+ return (==)
diff --git a/dev-haskell/hmake/hmake-3.08.ebuild b/dev-haskell/hmake/hmake-3.08.ebuild
new file mode 100644
index 000000000000..405f35671c37
--- /dev/null
+++ b/dev-haskell/hmake/hmake-3.08.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.08.ebuild,v 1.1 2003/06/24 14:20:03 kosmikus Exp $
+
+DESCRIPTION="a make tool for Haskell programs"
+
+HOMEPAGE="http://www.haskell.org/hmake/"
+
+LICENSE="nhc98"
+
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="nhc98 readline"
+
+inherit base
+
+# hmake can be build with either ghc or nhc98; we prefer ghc
+# unless a use flag tells us otherwise
+DEPEND="nhc98? ( dev-lang/nhc98 ) : ( virtual/ghc )
+ readline? ( sys-libs/readline )"
+
+RDEPEND="readline? ( sys-libs/readline )
+ virtual/glibc
+ !nhc98? ( dev-libs/gmp
+ sys-libs/readline )"
+
+SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
+
+src_unpack() {
+ base_src_unpack
+
+ cd ${S}
+
+ # fix echo bug when using readline
+ pushd src/interpreter
+ mv SimpleLineEditor.hs SimpleLineEditor.hs.orig
+ cat SimpleLineEditor.hs.orig \
+ | sed 's/^.*system.*stty.*$/#ifndef USE_READLINE\n&\n#endif/' \
+ > SimpleLineEditor.hs
+ popd
+
+ # patch cpp parser
+ patch -p0 < ${FILESDIR}/patch-3.08-cpp
+}
+
+src_compile() {
+ local buildwith
+ local arch
+
+ if [ "`use nhc98`" ]; then
+ buildwith="--buildwith=nhc98"
+ # Makefile is erroneous; we need to fix it
+ pushd hmake-3.07
+ mv Makefile Makefile.orig
+ sed -e "s/^TARGETS.*=/TARGETS = hmake-nhc hi-nhc/" \
+ Makefile.orig > Makefile
+ popd
+ else
+ buildwith="--buildwith=ghc"
+ fi
+
+ # package uses non-standard configure, therefore econf does
+ # not work ...
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man/man1 \
+ ${buildwith} || die "./configure failed"
+
+ if [ ! "`use readline`" ]; then
+ arch="`script/harch`"
+ # manually override readline configuration
+ einfo "Disabling readline ..."
+ echo "READLINE=\"\"" >> lib/${arch}/config
+ fi
+
+ # emake tested; does not work
+ make || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # install HTML documentation
+ cd docs/hmake
+ dohtml *
+}