summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-09-21 18:03:53 +0000
committerVlastimil Babka <caster@gentoo.org>2008-09-21 18:03:53 +0000
commit53633a43ad8792f08af09743b88f19343e5b2e1c (patch)
treeba47cd3f5166c285782e2573840530e8468df191
parentRevert, since the patch doesn't apply (diff)
downloadgentoo-2-53633a43ad8792f08af09743b88f19343e5b2e1c.tar.gz
gentoo-2-53633a43ad8792f08af09743b88f19343e5b2e1c.tar.bz2
gentoo-2-53633a43ad8792f08af09743b88f19343e5b2e1c.zip
dos2unix on the patch to make it apply.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1-perfctr x86_64)
-rw-r--r--app-portage/eix/ChangeLog6
-rw-r--r--app-portage/eix/files/eix-0.13.3-numeric-compare.patch168
2 files changed, 89 insertions, 85 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index b5a66fd5868c..8387195f6126 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.240 2008/09/21 17:59:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.241 2008/09/21 18:03:53 caster Exp $
+
+ 21 Sep 2008; Vlastimil Babka <caster@gentoo.org>
+ files/eix-0.13.3-numeric-compare.patch:
+ dos2unix on the patch to make it apply.
21 Sep 2008; Raúl Porcel <armin76@gentoo.org> eix-0.13.3-r1.ebuild:
Revert, since the patch doesn't apply
diff --git a/app-portage/eix/files/eix-0.13.3-numeric-compare.patch b/app-portage/eix/files/eix-0.13.3-numeric-compare.patch
index 3f06e9d016af..7a36b87ab1a3 100644
--- a/app-portage/eix/files/eix-0.13.3-numeric-compare.patch
+++ b/app-portage/eix/files/eix-0.13.3-numeric-compare.patch
@@ -1,84 +1,84 @@
-Index: trunk/src/eixTk/compare.h
-===================================================================
---- trunk/src/eixTk/compare.h (revision 590)
-+++ trunk/src/eixTk/compare.h (revision 730)
-@@ -1,3 +1,3 @@
--// vim:set et cinoptions=g0,t0,^-2,(0 sw=4 ts=4:
-+// vim:set noet cinoptions=g0,t0,(0 sw=4 ts=4:
- // This file is part of the eix project and distributed under the
- // terms of the GNU General Public License v2.
-@@ -5,4 +5,5 @@
- // Copyright (c)
- // Emil Beinroth <emilbeinroth@gmx.net>
-+// Martin VÀth <vaeth@mathematik.uni-wuerzburg.de>
-
- #ifndef __GUARD__COMPARE_H__
-@@ -14,34 +15,40 @@
- namespace eix
- {
-- /// compare two objects.
-- /// @return 0 if equal, 1 if left > right or -1 if left < right.
-- template<typename T>
-- int default_compare(const T& left, const T& right)
-- {
-- if (left == right)
-- return 0;
-- else if(left < right)
-- return -1;
-- else
-- return 1;
-- }
-+ /// compare two objects.
-+ /// @return 0 if equal, 1 if left > right or -1 if left < right.
-+ template<typename T>
-+ int default_compare(const T& left, const T& right)
-+ {
-+ if (left == right)
-+ return 0;
-+ if(left < right)
-+ return -1;
-+ return 1;
-+ }
-
-- /// numeric comparison.
-- /// @note empty strings count a "0"
-- static inline int
-- numeric_compare(const std::string& left, const std::string& right)
-- {
-- // strip leading 0's
-- const std::string::size_type lstart = left.find_first_not_of('0');
-- const std::string::size_type rstart = right.find_first_not_of('0');
-+ /// numeric comparison.
-+ /// @note empty strings count a "0"
-+ static inline int
-+ numeric_compare(const std::string& left, const std::string& right)
-+ {
-+ // strip leading 0's
-+ std::string::size_type lstart = left.find_first_not_of('0');
-+ std::string::size_type rstart = right.find_first_not_of('0');
-+ // Special cases: number is 0 or string is empty
-+ if (lstart == std::string::npos) {
-+ if(rstart == std::string::npos)
-+ return 0;
-+ return -1;
-+ }
-+ if (rstart == std::string::npos)
-+ return 1;
-
-- // check if one is longer, that one would be bigger
-- const int size_result = default_compare(left.size() - (lstart == std::string::npos ? 0 : lstart),
-- right.size() - (rstart == std::string::npos ? 0 : rstart));
-- if (size_result)
-- return size_result;
-- // both strings have the same length, do string comparison
-- return left.compare(lstart, std::string::npos, right, rstart, std::string::npos);
-- }
-+ // check if one is longer, that one would be bigger
-+ int size_result = default_compare(left.size() - lstart, right.size() - rstart);
-+ if (size_result)
-+ return size_result;
-+ // both strings have the same length, do string comparison
-+ return left.compare(lstart, std::string::npos, right, rstart, std::string::npos);
-+ }
- }
-
+Index: trunk/src/eixTk/compare.h
+===================================================================
+--- trunk/src/eixTk/compare.h (revision 590)
++++ trunk/src/eixTk/compare.h (revision 730)
+@@ -1,3 +1,3 @@
+-// vim:set et cinoptions=g0,t0,^-2,(0 sw=4 ts=4:
++// vim:set noet cinoptions=g0,t0,(0 sw=4 ts=4:
+ // This file is part of the eix project and distributed under the
+ // terms of the GNU General Public License v2.
+@@ -5,4 +5,5 @@
+ // Copyright (c)
+ // Emil Beinroth <emilbeinroth@gmx.net>
++// Martin VÀth <vaeth@mathematik.uni-wuerzburg.de>
+
+ #ifndef __GUARD__COMPARE_H__
+@@ -14,34 +15,40 @@
+ namespace eix
+ {
+- /// compare two objects.
+- /// @return 0 if equal, 1 if left > right or -1 if left < right.
+- template<typename T>
+- int default_compare(const T& left, const T& right)
+- {
+- if (left == right)
+- return 0;
+- else if(left < right)
+- return -1;
+- else
+- return 1;
+- }
++ /// compare two objects.
++ /// @return 0 if equal, 1 if left > right or -1 if left < right.
++ template<typename T>
++ int default_compare(const T& left, const T& right)
++ {
++ if (left == right)
++ return 0;
++ if(left < right)
++ return -1;
++ return 1;
++ }
+
+- /// numeric comparison.
+- /// @note empty strings count a "0"
+- static inline int
+- numeric_compare(const std::string& left, const std::string& right)
+- {
+- // strip leading 0's
+- const std::string::size_type lstart = left.find_first_not_of('0');
+- const std::string::size_type rstart = right.find_first_not_of('0');
++ /// numeric comparison.
++ /// @note empty strings count a "0"
++ static inline int
++ numeric_compare(const std::string& left, const std::string& right)
++ {
++ // strip leading 0's
++ std::string::size_type lstart = left.find_first_not_of('0');
++ std::string::size_type rstart = right.find_first_not_of('0');
++ // Special cases: number is 0 or string is empty
++ if (lstart == std::string::npos) {
++ if(rstart == std::string::npos)
++ return 0;
++ return -1;
++ }
++ if (rstart == std::string::npos)
++ return 1;
+
+- // check if one is longer, that one would be bigger
+- const int size_result = default_compare(left.size() - (lstart == std::string::npos ? 0 : lstart),
+- right.size() - (rstart == std::string::npos ? 0 : rstart));
+- if (size_result)
+- return size_result;
+- // both strings have the same length, do string comparison
+- return left.compare(lstart, std::string::npos, right, rstart, std::string::npos);
+- }
++ // check if one is longer, that one would be bigger
++ int size_result = default_compare(left.size() - lstart, right.size() - rstart);
++ if (size_result)
++ return size_result;
++ // both strings have the same length, do string comparison
++ return left.compare(lstart, std::string::npos, right, rstart, std::string::npos);
++ }
+ }
+