summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-15 18:09:12 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-15 18:09:12 +0000
commit4b3884899497bdb378c2c64c32e5ee7137736916 (patch)
tree550aac4a33ade342eb6b089171dac599c8178f47
parentupdates (diff)
downloadgentoo-2-4b3884899497bdb378c2c64c32e5ee7137736916.tar.gz
gentoo-2-4b3884899497bdb378c2c64c32e5ee7137736916.tar.bz2
gentoo-2-4b3884899497bdb378c2c64c32e5ee7137736916.zip
This version fixes a ldconfig bug
-rw-r--r--sys-libs/glibc/files/glibc-2.2-ldconfig.patch20
-rw-r--r--sys-libs/glibc/glibc-2.2-r2.ebuild100
2 files changed, 120 insertions, 0 deletions
diff --git a/sys-libs/glibc/files/glibc-2.2-ldconfig.patch b/sys-libs/glibc/files/glibc-2.2-ldconfig.patch
new file mode 100644
index 000000000000..acc5174705b8
--- /dev/null
+++ b/sys-libs/glibc/files/glibc-2.2-ldconfig.patch
@@ -0,0 +1,20 @@
+--- glibc-2.2/elf/ldconfig.c Tue Nov 14 20:05:26 2000
++++ glibc-2.2/elf/ldconfig.c Tue Nov 14 20:05:02 2000
+@@ -370,13 +370,13 @@
+
+ /* Get complete path. */
+ full_libname = alloca (strlen (path) + strlen (libname) + 2);
+- full_soname = alloca (strlen (path) + strlen (libname) + 2);
++ full_soname = alloca (strlen (path) + strlen (soname) + 2);
+ sprintf (full_libname, "%s/%s", path, libname);
+ sprintf (full_soname, "%s/%s", path, soname);
+ if (opt_chroot)
+ {
+ real_full_libname = alloca (strlen (real_path) + strlen (libname) + 2);
+- real_full_soname = alloca (strlen (real_path) + strlen (libname) + 2);
++ real_full_soname = alloca (strlen (real_path) + strlen (soname) + 2);
+ sprintf (real_full_libname, "%s/%s", real_path, libname);
+ sprintf (real_full_soname, "%s/%s", real_path, soname);
+ }
+
+
diff --git a/sys-libs/glibc/glibc-2.2-r2.ebuild b/sys-libs/glibc/glibc-2.2-r2.ebuild
new file mode 100644
index 000000000000..ea4bf5ca2ad5
--- /dev/null
+++ b/sys-libs/glibc/glibc-2.2-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2-r2.ebuild,v 1.1 2000/11/15 18:09:12 achim Exp $
+
+A="$P.tar.gz glibc-linuxthreads-${PV}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU libc6 (also called glibc2) C library"
+SRC_URI="ftp://sourceware.cygnus.com/pub/glibc/releases/glibc-${PV}.tar.gz
+ ftp://sourceware.cygnus.com/pub/glibc/releases/glibc-linuxthreads-${PV}.tar.gz
+ ftp://ftp.unina.it/pub/Unix/cygnus/glibc/releases/glibc-${PV}.tar.gz
+ ftp://ftp.unina.it/pub/Unix/cygnus/glibc/releases/glibc-linuxthreads-${PV}.tar.gz
+ ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.gz
+ ftp://ftp.gnu.org/pub/gnu/glibc/glibc-linuxthreads-${PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
+
+src_compile() {
+
+ rm -rf buildhere
+ mkdir buildhere
+ cd buildhere
+ try ../configure --host=${CHOST} --without-cvs \
+ --enable-add-ons=linuxthreads,crypt,localedata \
+ --disable-profile --prefix=/usr \
+ --enable-kernel=2.2.17
+ try make
+ make check
+}
+
+src_unpack() {
+ unpack glibc-${PV}.tar.gz
+ cd ${S}
+ unpack glibc-linuxthreads-${PV}.tar.gz
+ patch -p0 < ${FILESDIR}/glibc-2.2-ldconfig.patch
+}
+
+src_install() {
+ cd ${S}
+ rm -rf ${D}
+ mkdir ${D}
+ dodir /etc/rc.d/init.d
+ export LC_ALL=C
+ try make install_root=${D} install -C buildhere
+ try make install_root=${D} info -C buildhere
+ try make install_root=${D} localedata/install-locales -C buildhere
+ try make -C linuxthreads/man
+ mkdir -p ${D}/usr/man/man3
+ install -m 0644 linuxthreads/man/*.3thr ${D}/usr/man/man3
+ chmod 755 ${D}/usr/libexec/pt_chown
+ install -m 644 nscd/nscd.conf ${D}/etc
+ install -m 755 ${O}/files/nscd ${D}/etc/rc.d/init.d/nscd
+ dodir /var/db
+ install -m 644 nss/db-Makefile ${D}/var/db/Makefile
+ rm ${D}/lib/ld-linux.so.2
+ rm ${D}/lib/libc.so.6
+ rm -rf documentation
+ mkdir documentation
+ mkdir documentation/html
+ cp linuxthreads/ChangeLog documentation/ChangeLog.threads
+ cp linuxthreads/Changes documentation/Changes.threads
+ cp linuxthreads/README documentation/README.threads
+ cp linuxthreads/FAQ.html documentation/html/FAQ-threads.html
+ cp crypt/README documentation/README.crypt
+ cp db2/README documentation/README.db2
+ cp db2/mutex/README documentation/README.db2.mutex
+ cp timezone/README documentation/README.timezone
+ cp ChangeLog* documentation
+ dodoc documentation/*
+ docinto html
+ dodoc documentation/html/*.html
+ dodir /usr/doc/${PF}/examples.threads
+ install -m0644 linuxthreads/Examples/*.c ${D}/usr/doc/${PF}/examples.threads
+ install -m0644 linuxthreads/Examples/Makefile ${D}/usr/doc/${PF}/examples.threads
+ # Patch ucontext.h (needed for lynx, xfree)
+ #cd ${D}/usr/include/sys
+ #cp ucontext.h ucontext.h.orig
+ #sed -e "s/ERR/GLIBCBUG/g" ucontext.h.orig > ucontext.h
+}
+
+pkg_preinst()
+{
+ echo "Saving ld-linux and libc6"
+
+ cp ${ROOT}lib/ld-linux.so.2 ${ROOT}tmp
+ sln ${ROOT}tmp/ld-linux.so.2 ${ROOT}lib/ld-linux.so.2
+ cp ${ROOT}lib/libc.so.6 ${ROOT}tmp
+ sln ${ROOT}tmp/libc.so.6 ${ROOT}lib/libc.so.6
+}
+
+pkg_postinst()
+{
+ echo "Setting ld-linux and libc6"
+
+ sln ${ROOT}lib/ld-2.2.so ${ROOT}lib/ld-linux.so.2
+ sln ${ROOT}lib/libc-2.2.so ${ROOT}lib/libc.so.6
+ rm ${ROOT}tmp/ld-linux.so.2
+ rm ${ROOT}tmp/libc.so.6
+}
+
+