summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-03-27 15:13:05 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-03-27 15:13:05 +0000
commit4b27fde4d41d79d98ae0280c4a3333fa03bba947 (patch)
tree7abed60f0cfcddb30112546bfbc507af5311e12b
parentremove unused use flags (diff)
downloadgentoo-2-4b27fde4d41d79d98ae0280c4a3333fa03bba947.tar.gz
gentoo-2-4b27fde4d41d79d98ae0280c4a3333fa03bba947.tar.bz2
gentoo-2-4b27fde4d41d79d98ae0280c4a3333fa03bba947.zip
Versioned and updated patch that broke when bumping from 2.0.0 -> 2.0.1.
(Portage version: 2.1.2.2)
-rw-r--r--dev-java/itext/ChangeLog7
-rw-r--r--dev-java/itext/files/2.0.1-compile_xml.patch (renamed from dev-java/itext/files/compile_xml.patch)8
-rw-r--r--dev-java/itext/itext-2.0.1.ebuild4
3 files changed, 12 insertions, 7 deletions
diff --git a/dev-java/itext/ChangeLog b/dev-java/itext/ChangeLog
index 39331bcd2c0a..097a0371a5d8 100644
--- a/dev-java/itext/ChangeLog
+++ b/dev-java/itext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/itext
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/ChangeLog,v 1.38 2007/03/25 19:27:02 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/ChangeLog,v 1.39 2007/03/27 15:13:05 wltjr Exp $
+
+ 27 Mar 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ +files/2.0.1-compile_xml.patch, -files/compile_xml.patch,
+ itext-2.0.1.ebuild:
+ Versioned and updated patch that broke when bumping from 2.0.0 -> 2.0.1.
*itext-2.0.1 (25 Mar 2007)
diff --git a/dev-java/itext/files/compile_xml.patch b/dev-java/itext/files/2.0.1-compile_xml.patch
index c4c008bde0de..1ac8233ba34b 100644
--- a/dev-java/itext/files/compile_xml.patch
+++ b/dev-java/itext/files/2.0.1-compile_xml.patch
@@ -1,6 +1,6 @@
---- compile.xml 2007-03-25 14:25:16.000000000 -0400
-+++ datavision-1.0.0/src/ant/compile.xml 2007-03-25 14:27:28.000000000 -0400
-@@ -34,8 +34,10 @@
+--- compile.xml 2007-03-27 09:11:06.000000000 -0400
++++ src/ant/compile.xml 2007-03-27 09:11:46.000000000 -0400
+@@ -34,8 +34,10 @@
<target name="compile" description="--> compiles the iText code">
<mkdir dir="${itext.bin}" />
@@ -11,7 +11,7 @@
<mkdir dir="${itext.classes}" />
<javac source="1.4" target="1.4" srcdir="${itext.src}" destdir="${itext.classes}">
<classpath refid="itext.classpath"/>
-@@ -48,8 +50,10 @@
+@@ -48,8 +50,10 @@
<target name="compile.debug" description="--> compiles the iText code for debugging">
<mkdir dir="${itext.bin}" />
diff --git a/dev-java/itext/itext-2.0.1.ebuild b/dev-java/itext/itext-2.0.1.ebuild
index e1d67caaa037..be0d4688b7c5 100644
--- a/dev-java/itext/itext-2.0.1.ebuild
+++ b/dev-java/itext/itext-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/itext-2.0.1.ebuild,v 1.1 2007/03/25 19:27:02 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/itext/itext-2.0.1.ebuild,v 1.2 2007/03/27 15:13:05 wltjr Exp $
JAVA_PKG_IUSE="doc source"
@@ -26,7 +26,7 @@ src_unpack() {
mkdir "${WORKDIR}/src" && cd "${WORKDIR}/src"
unpack ${A}
- epatch ${FILESDIR}/compile_xml.patch
+ epatch ${FILESDIR}/${PV}-compile_xml.patch
mkdir -p "${WORKDIR}/build/bin" || die
cd "${WORKDIR}/build/bin" || die