summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-05-21 18:10:19 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-05-21 18:10:19 +0000
commit4a5ade97cfa3ad9c09d1c2baae3a7929eec29459 (patch)
treeb2d6daf70c6598bc03e4b9e4f022d83fb1f1d80d
parentUSE=postgres should set --with-pgsql, reported by Krzysztof Tomczyk (#222317) (diff)
downloadgentoo-2-4a5ade97cfa3ad9c09d1c2baae3a7929eec29459.tar.gz
gentoo-2-4a5ade97cfa3ad9c09d1c2baae3a7929eec29459.tar.bz2
gentoo-2-4a5ade97cfa3ad9c09d1c2baae3a7929eec29459.zip
version bump
(Portage version: 2.1.5_rc10)
-rw-r--r--dev-cpp/Ice/ChangeLog9
-rw-r--r--dev-cpp/Ice/Ice-3.3.0.ebuild (renamed from dev-cpp/Ice/Ice-3.3.0_beta1.ebuild)8
-rw-r--r--dev-cpp/Ice/files/Ice-3.3.0-Makefile.patch68
-rw-r--r--dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch91
4 files changed, 79 insertions, 97 deletions
diff --git a/dev-cpp/Ice/ChangeLog b/dev-cpp/Ice/ChangeLog
index 490241438c44..b31af723df37 100644
--- a/dev-cpp/Ice/ChangeLog
+++ b/dev-cpp/Ice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/Ice
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.14 2008/04/23 13:25:21 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.15 2008/05/21 18:10:19 caleb Exp $
+
+*Ice-3.3.0 (21 May 2008)
+
+ 21 May 2008; Caleb Tennis <caleb@gentoo.org>
+ +files/Ice-3.3.0-Makefile.patch, -files/Ice-3.3.0_beta1-Makefile.patch,
+ -Ice-3.3.0_beta1.ebuild, +Ice-3.3.0.ebuild:
+ version bump
*Ice-3.3.0_beta1 (23 Apr 2008)
diff --git a/dev-cpp/Ice/Ice-3.3.0_beta1.ebuild b/dev-cpp/Ice/Ice-3.3.0.ebuild
index 9a148df0f8c7..f208800376fa 100644
--- a/dev-cpp/Ice/Ice-3.3.0_beta1.ebuild
+++ b/dev-cpp/Ice/Ice-3.3.0.ebuild
@@ -1,14 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.3.0_beta1.ebuild,v 1.1 2008/04/23 13:25:21 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.3.0.ebuild,v 1.1 2008/05/21 18:10:19 caleb Exp $
inherit eutils
-MY_P=Ice-3.3b
-
DESCRIPTION="ICE middleware C++ bindings"
HOMEPAGE="http://www.zeroc.com/index.html"
-SRC_URI="http://www.zeroc.com/download/Ice/3.3/${MY_P}.tar.gz"
+SRC_URI="http://www.zeroc.com/download/Ice/3.3/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -25,7 +23,7 @@ DEPEND="${RDEPEND}
ncurses? ( sys-libs/ncurses sys-libs/readline )
test? ( >=dev-lang/python-2.4 )"
-S=${WORKDIR}/${MY_P}/cpp
+S=${WORKDIR}/${P}/cpp
pkg_setup() {
if built_with_use sys-libs/db nocxx; then
diff --git a/dev-cpp/Ice/files/Ice-3.3.0-Makefile.patch b/dev-cpp/Ice/files/Ice-3.3.0-Makefile.patch
new file mode 100644
index 000000000000..ceeaab4fd48e
--- /dev/null
+++ b/dev-cpp/Ice/files/Ice-3.3.0-Makefile.patch
@@ -0,0 +1,68 @@
+--- config/Make.rules.orig 2008-05-21 13:39:46.000000000 -0400
++++ config/Make.rules 2008-05-21 13:43:35.000000000 -0400
+@@ -11,13 +11,13 @@
+ # Select an installation base directory. The directory will be created
+ # if it does not exist.
+ #
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= /$(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
+@@ -144,10 +144,10 @@
+ include $(top_srcdir)/config/Make.rules.$(UNAME)
+
+ install_includedir := $(prefix)/include
+-install_docdir := $(prefix)/doc
++install_docdir := $(prefix)/share/doc/Ice-$(VERSION)
+ install_bindir := $(prefix)/$(binsubdir)
+ install_libdir := $(prefix)/$(libsubdir)
+-install_configdir := $(prefix)/config
++install_configdir := $(prefix)/share/Ice/config
+
+ ifneq ($(embedded_runpath_prefix),)
+ runpath_libdir := $(embedded_runpath_prefix)/$(libsubdir)
+@@ -162,18 +162,8 @@
+ BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
+ BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
+
+-ifneq ($(DB_HOME),)
+- DB_FLAGS = -I$(DB_HOME)/include
+- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
+- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
+-else
+- ifeq ($(shell if [ -d /usr/include/db46 -a -d /usr/$(libsubdir)/db46 ] ; then echo yes; fi), yes)
+- DB_FLAGS = -I/usr/include/db46
+- DB_LIBS = -L/usr/$(libsubdir)/db46 -ldb_cxx
+- else
+- DB_LIBS = -ldb_cxx
+- endif
+-endif
++DB_FLAGS = -I/usr/include/db4.6
++DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.6
+
+ EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
+ EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
+--- Makefile.orig 2008-05-21 13:42:32.000000000 -0400
++++ Makefile 2008-05-21 13:42:50.000000000 -0400
+@@ -11,11 +11,11 @@
+
+ include $(top_srcdir)/config/Make.rules
+
+-SUBDIRS = config src include test demo
++SUBDIRS = config src include
+
+ INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_configdir)
+
+-install:: install-common
++install::
+ @for subdir in $(INSTALL_SUBDIRS); \
+ do \
+ if test ! -d $$subdir ; \
diff --git a/dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch b/dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch
deleted file mode 100644
index c76f4ee12c71..000000000000
--- a/dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch
+++ /dev/null
@@ -1,91 +0,0 @@
---- config/Make.rules.orig 2008-04-02 07:40:44.000000000 -0400
-+++ config/Make.rules 2008-04-02 07:45:56.000000000 -0400
-@@ -11,13 +11,13 @@
- # Select an installation base directory. The directory will be created
- # if it does not exist.
- #
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /$(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with
-@@ -125,7 +125,7 @@
- endif
-
- install_includedir = $(prefix)/include
--install_docdir = $(prefix)/doc
-+install_docdir = $(prefix)/share/doc/Ice-$(VERSION)
-
- bindir = $(top_srcdir)/bin
- libdir = $(top_srcdir)/lib
-@@ -161,18 +161,8 @@
- BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
- BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
-
--ifneq ($(DB_HOME),)
-- DB_FLAGS = -I$(DB_HOME)/include
-- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
-- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
--else
-- ifeq ($(shell if [ -d /usr/include/db46 -a -d /usr/$(libsubdir)/db46 ] ; then echo yes; fi), yes)
-- DB_FLAGS = -I/usr/include/db46
-- DB_LIBS = -L/usr/$(libsubdir)/db46 -ldb_cxx
-- else
-- DB_LIBS = -ldb_cxx
-- endif
--endif
-+DB_FLAGS = -I/usr/include/db4.6
-+DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.6
-
- EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
- EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
---- Makefile.orig 2008-04-02 09:51:02.000000000 -0400
-+++ Makefile 2008-04-02 09:51:18.000000000 -0400
-@@ -11,11 +11,11 @@
-
- include $(top_srcdir)/config/Make.rules
-
--SUBDIRS = config src include test demo
-+SUBDIRS = config src include
-
- INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir)
-
--install:: install-common
-+install::
- @for subdir in $(INSTALL_SUBDIRS); \
- do \
- if test ! -d $$subdir ; \
---- config/Makefile.orig 2008-04-02 10:33:40.000000000 -0400
-+++ config/Makefile 2008-04-02 10:34:26.000000000 -0400
-@@ -15,15 +15,15 @@
- echo ""
-
- install::
-- @if test ! -d $(prefix)/config ; \
-+ @if test ! -d $(prefix)/share/Ice/config ; \
- then \
-- echo "Creating $(prefix)/config..." ; \
-- $(call mkdir,$(prefix)/config) ; \
-+ echo "Creating $(prefix)/share/Ice/config..." ; \
-+ mkdir -p $(prefix)/share/Ice/config ; \
- fi
-- $(call installdata,templates.xml,$(prefix)/config)
-- $(call installdata,convertssl.py,$(prefix)/config)
-- $(call installdata,upgradeicegrid.py,$(prefix)/config)
-- $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/config)
-- $(call installdata,icegrid-slice.3.2.ice.gz,$(prefix)/config)
-- $(call installdata,icegrid-slice.3.3.ice.gz,$(prefix)/config)
-+ $(call installdata,templates.xml,$(prefix)/share/Ice/config)
-+ $(call installdata,convertssl.py,$(prefix)/share/Ice/config)
-+ $(call installdata,upgradeicegrid.py,$(prefix)/share/Ice/config)
-+ $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/share/Ice/config)
-+ $(call installdata,icegrid-slice.3.2.ice.gz,$(prefix)/share/Ice/config)
-+ $(call installdata,icegrid-slice.3.3.ice.gz,$(prefix)/share/Ice/config)
-