summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-19 18:06:53 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-02-19 18:06:53 +0000
commit47c0a4511786cfd4fa71f4aab5da484e448dfe16 (patch)
treee5a284a30c808198fd64cde79d47cf2371151e92
parentKeyword ~arm (diff)
downloadgentoo-2-47c0a4511786cfd4fa71f4aab5da484e448dfe16.tar.gz
gentoo-2-47c0a4511786cfd4fa71f4aab5da484e448dfe16.tar.bz2
gentoo-2-47c0a4511786cfd4fa71f4aab5da484e448dfe16.zip
Build against glibc-2.17, bug #458326
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.8.1-glibc-2.17.patch26
-rw-r--r--dev-util/valgrind/valgrind-3.8.1.ebuild7
3 files changed, 37 insertions, 4 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 03ff99990845..da0c8653c810 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/valgrind
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.160 2012/10/18 20:01:37 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.161 2013/02/19 18:06:53 blueness Exp $
+
+ 19 Feb 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/valgrind-3.8.1-glibc-2.17.patch, valgrind-3.8.1.ebuild:
+ Build against glibc-2.17, bug #458326
18 Oct 2012; Anthony G. Basile <blueness@gentoo.org> valgrind-3.7.0-r4.ebuild:
drop ~arm, bug #434884
diff --git a/dev-util/valgrind/files/valgrind-3.8.1-glibc-2.17.patch b/dev-util/valgrind/files/valgrind-3.8.1-glibc-2.17.patch
new file mode 100644
index 000000000000..605b80a038e6
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.8.1-glibc-2.17.patch
@@ -0,0 +1,26 @@
+diff -Nuar valgrind-3.8.1.orig/configure.in valgrind-3.8.1/configure.in
+--- valgrind-3.8.1.orig/configure.in 2012-09-18 15:17:32.000000000 -0400
++++ valgrind-3.8.1/configure.in 2013-02-19 13:00:26.000000000 -0500
+@@ -906,6 +906,13 @@
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
++ 2.17)
++ AC_MSG_RESULT(2.17 family)
++ AC_DEFINE([GLIBC_2_17], 1, [Define to 1 if you're using glibc 2.17.x])
++ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
++ ;;
+ darwin)
+ AC_MSG_RESULT(Darwin)
+ AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
+@@ -919,7 +926,7 @@
+
+ *)
+ AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
+- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.16])
++ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.17])
+ AC_MSG_ERROR([or Darwin libc])
+ ;;
+ esac
diff --git a/dev-util/valgrind/valgrind-3.8.1.ebuild b/dev-util/valgrind/valgrind-3.8.1.ebuild
index 02d62b0da1ab..a119706129fe 100644
--- a/dev-util/valgrind/valgrind-3.8.1.ebuild
+++ b/dev-util/valgrind/valgrind-3.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.8.1.ebuild,v 1.1 2012/09/20 20:49:50 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.8.1.ebuild,v 1.2 2013/02/19 18:06:53 blueness Exp $
EAPI="4"
inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
@@ -37,6 +37,9 @@ src_prepare() {
# warning about executable stacks.
epatch "${FILESDIR}"/${PN}-3.8.0-non-exec-stack.patch
+ # Fix for glibc 2.18, bug #458326
+ epatch "${FILESDIR}"/${PN}-3.8.1-glibc-2.17.patch
+
# Regenerate autotools files
eautoreconf
}