summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2003-12-23 22:40:20 +0000
committerTal Peer <coredumb@gentoo.org>2003-12-23 22:40:20 +0000
commit40f0c0df8a1e30514425787850841fa0b85acf1c (patch)
treebdafcb803f529b19c8ee8b7d2e2608fe55fdeeae
parentRevision bump to spread eclass changes. (diff)
downloadgentoo-2-40f0c0df8a1e30514425787850841fa0b85acf1c.tar.gz
gentoo-2-40f0c0df8a1e30514425787850841fa0b85acf1c.tar.bz2
gentoo-2-40f0c0df8a1e30514425787850841fa0b85acf1c.zip
Revision bump to spread eclass changes.
-rw-r--r--dev-php/php-core/ChangeLog7
-rw-r--r--dev-php/php-core/Manifest4
-rw-r--r--dev-php/php-core/files/digest-php-core-4.3.4-r12
-rw-r--r--dev-php/php-core/php-core-4.3.4-r1.ebuild65
4 files changed, 75 insertions, 3 deletions
diff --git a/dev-php/php-core/ChangeLog b/dev-php/php-core/ChangeLog
index c93228777fd2..6eb502563e2f 100644
--- a/dev-php/php-core/ChangeLog
+++ b/dev-php/php-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php-core
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-core/ChangeLog,v 1.2 2003/11/29 23:43:26 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-core/ChangeLog,v 1.3 2003/12/23 22:40:05 coredumb Exp $
+
+*php-core-4.3.4-r1 (24 Dec 2003)
+
+ 24 Dec 2003; Tal Peer <coredumb@gentoo.org> php-core-4.3.4-r1.ebuild:
+ Revision bump to spread eclass changes.
29 Nov 2003; Brad House <brad_mssw@gentoo.org> php-core-4.3.4.ebuild:
add ~amd64 flag
diff --git a/dev-php/php-core/Manifest b/dev-php/php-core/Manifest
index 4f964a8d7d21..04578f2cc277 100644
--- a/dev-php/php-core/Manifest
+++ b/dev-php/php-core/Manifest
@@ -1,6 +1,6 @@
-MD5 1e52a65a59d4362ea87c163882c91400 ChangeLog 469
+MD5 6447184ca27d6bf641d31448cb757993 ChangeLog 617
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 f8689fdb454429ad37f78817dce60c87 php-core-4.3.4.ebuild 1947
-MD5 f8689fdb454429ad37f78817dce60c87 php-core-4.3.4-r1.ebuild 1947
+MD5 9ce425d119108f0af199a40a421f558b php-core-4.3.4-r1.ebuild 1950
MD5 5547bf31e6a425747226d5984cff04e9 files/digest-php-core-4.3.4 137
MD5 5547bf31e6a425747226d5984cff04e9 files/digest-php-core-4.3.4-r1 137
diff --git a/dev-php/php-core/files/digest-php-core-4.3.4-r1 b/dev-php/php-core/files/digest-php-core-4.3.4-r1
new file mode 100644
index 000000000000..d65ce9576341
--- /dev/null
+++ b/dev-php/php-core/files/digest-php-core-4.3.4-r1
@@ -0,0 +1,2 @@
+MD5 b9dd601863e08e52e3c4d5e02c2627cf php-4.3.4.tar.bz2 3774324
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/php-core/php-core-4.3.4-r1.ebuild b/dev-php/php-core/php-core-4.3.4-r1.ebuild
new file mode 100644
index 000000000000..22c384c67cde
--- /dev/null
+++ b/dev-php/php-core/php-core-4.3.4-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-core/php-core-4.3.4-r1.ebuild,v 1.1 2003/12/23 22:40:05 coredumb Exp $
+
+PHPSAPI="cli"
+inherit php-2 eutils
+
+IUSE="${IUSE} readline"
+DESCRIPTION="PHP core package"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips ~amd64"
+
+DEPEND_EXTRA="readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ ncurses? ( >=sys-libs/ncurses-5.1 )
+ >=virtual/php-4.3.4
+ ~virtual/php-${PV}"
+DEPEND="${DEPEND} ${DEPEND_EXTRA}"
+RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
+
+src_compile() {
+ if has_version 'dev-php/php' && [ -x '/usr/bin/php' ]; then
+ # Ok, so we can cheat and not have to build all of it...
+ cp /usr/bin/php ${S}/sapi/cli/php
+ PHP_SKIP_MAKE=1
+ einfo "You have dev-php/php installed, so we're cheating and using it"
+ einfo "instead of rebuilding the CLI SAPI to make PEAR packages."
+ einfo "configure will still be run to build the required Makefiles."
+ else
+ ewarn "Since you don't have dev-php/php installed, we need to build"
+ ewarn "the PHP CLI interpreter to make the PEAR packages."
+ fi
+
+ # the rest of this should be identical to dev-php/php
+ myconf="${myconf} `use_with readline readline /usr`"
+ # Readline and Ncurses are CLI PHP only
+ # readline needs ncurses
+ use ncurses || use readline \
+ && myconf="${myconf} --with-ncurses=/usr" \
+ || myconf="${myconf} --without-ncurses"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ # make sure the possibly faked PHP is in place and new enough to avoid build storms
+ touch ${S}/sapi/cli/php
+ PHP_INSTALLTARGETS="install-programs install-pear install-build install-headers"
+ PHP_SKIP_BUILD=1
+ php_src_install
+ #rm -rf ${D}/etc/php4 ${D}/etc/php
+}
+
+pkg_postinst() {
+ einfo "This is a limited build to provide PEAR and build utilities"
+}
+
+pkg_preinst() {
+ #php_pkg_preinst
+ :
+}