summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-06-22 01:29:47 +0000
committerChris Reffett <creffett@gentoo.org>2012-06-22 01:29:47 +0000
commit401a8315b1f4160234c680e9485c106790834e29 (patch)
tree9b9827da40629100846b6ee7a15f2c7faed710e6
parentVersion bump. (diff)
downloadgentoo-2-401a8315b1f4160234c680e9485c106790834e29.tar.gz
gentoo-2-401a8315b1f4160234c680e9485c106790834e29.tar.bz2
gentoo-2-401a8315b1f4160234c680e9485c106790834e29.zip
Rev bump, added patch to fix Amarok crashing for bug 395575. Remove old.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-2.5.0-r3.ebuild (renamed from media-sound/amarok/amarok-2.5.0-r2.ebuild)7
-rw-r--r--media-sound/amarok/files/amarok-2.5.0-qtdebug.patch55
3 files changed, 66 insertions, 4 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 3f2ae38967b3..060990984d34 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.424 2012/05/26 15:22:19 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.425 2012/06/22 01:29:47 creffett Exp $
+
+*amarok-2.5.0-r3 (22 Jun 2012)
+
+ 22 Jun 2012; <creffett@gentoo.org> -amarok-2.5.0-r2.ebuild,
+ +amarok-2.5.0-r3.ebuild, +files/amarok-2.5.0-qtdebug.patch:
+ Rev bump, added patch to fix Amarok crashing for bug 395575. Remove old.
26 May 2012; Alexey Shvetsov <alexxy@gentoo.org> amarok-2.5.0-r2.ebuild,
metadata.xml:
diff --git a/media-sound/amarok/amarok-2.5.0-r2.ebuild b/media-sound/amarok/amarok-2.5.0-r3.ebuild
index 922098bdb624..94c24925b4fc 100644
--- a/media-sound/amarok/amarok-2.5.0-r2.ebuild
+++ b/media-sound/amarok/amarok-2.5.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.5.0-r2.ebuild,v 1.3 2012/05/26 15:22:19 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.5.0-r3.ebuild,v 1.1 2012/06/22 01:29:47 creffett Exp $
EAPI=4
@@ -15,8 +15,8 @@ inherit flag-o-matic kde4-base
DESCRIPTION="Advanced audio player based on KDE framework."
HOMEPAGE="http://amarok.kde.org/"
if [[ ${PV} != *9999* ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
- KEYWORDS="~amd64 ~ppc ~x86"
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
else
KEYWORDS=""
fi
@@ -74,6 +74,7 @@ RDEPEND="${COMMONDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-2.5.0-kde48.patch"
+ "${FILESDIR}/${PN}-2.5.0-qtdebug.patch"
)
src_prepare() {
diff --git a/media-sound/amarok/files/amarok-2.5.0-qtdebug.patch b/media-sound/amarok/files/amarok-2.5.0-qtdebug.patch
new file mode 100644
index 000000000000..8c6e0223b0dd
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.5.0-qtdebug.patch
@@ -0,0 +1,55 @@
+Patch originally from KDE commit d1a1c80370e4132c26fa636308822fdb3aa1b2e6, modified to work with current Amarok.
+diff -ruN /root/amarok-2.5.0/ChangeLog amarok-2.5.0/ChangeLog
+--- a/amarok-2.5.0/ChangeLog 2011-12-15 02:36:48.000000000 -0500
++++ b/amarok-2.5.0/ChangeLog 2012-06-21 21:05:29.871236927 -0400
+@@ -8,6 +8,7 @@
+ Playlist's layout items.
+
+ BUGFIXES:
++ * Fix crash on start when Qt is build with debugging assertions. (BR 285720)
+ * Do not crash when iPod doesn't have a master playlist. (BR 288936)
+ * Fix Last.fm not finding KDE Wallet. (BR 286741)
+ * Put a border around bottom toolbars, visually separating them from
+diff -ruN /root/amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.cpp amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.cpp
+--- a/amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.cpp 2011-12-15 02:36:48.000000000 -0500
++++ b/amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.cpp 2012-06-21 21:05:09.810237474 -0400
+@@ -223,23 +223,15 @@
+ {
+ int &rowValue = groupList[insertedProxyRow-1];
+ if( idx.row() <= rowValue )
+- {
+ //increment the rows that come after the new row since they moved one place up.
+ rowValue++;
+- }
+ else
+- {
+ break;
+- }
+ }
+
+ if( updatedGroups.contains( i.key() ) )
+- {
+- //the row needs to be added to this group
+- beginInsertRows( index( i.key() ), insertedProxyRow, insertedProxyRow );
+- groupList.insert( insertedProxyRow, idx.row() );
+- endInsertRows();
+- }
++ // we're inside beginInsertRows() or beginInsertRows(), don't re-enter it.
++ groupList.insert( insertedProxyRow, idx.row() );
+ }
+
+ return updatedGroups;
+diff -ruN /root/amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.h amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.h
+--- a/amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.h 2011-12-15 02:36:48.000000000 -0500
++++ b/amarok-2.5.0/src/browsers/playlistbrowser/QtGroupingProxy.h 2012-06-21 21:04:42.778238198 -0400
+@@ -38,8 +38,8 @@
+ void setGroupedColumn( int groupedColumn );
+
+ /* QAbstractProxyModel methods */
+- virtual QModelIndex index( int, int c = 0,
+- const QModelIndex& parent = QModelIndex() ) const;
++ virtual QModelIndex index( int row, int column = 0,
++ const QModelIndex& parent = QModelIndex() ) const;
+ virtual Qt::ItemFlags flags( const QModelIndex &idx ) const;
+ virtual QModelIndex parent( const QModelIndex &idx ) const;
+ virtual int rowCount( const QModelIndex &idx = QModelIndex() ) const;