summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-04-26 22:32:58 +0000
committerMike Gilbert <floppym@gentoo.org>2012-04-26 22:32:58 +0000
commit37235a4c7157e120af4e79f89112c0a1a8da4177 (patch)
tree0c264dae966cdb2f3c3b74105f531ae754cbdc8c
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-37235a4c7157e120af4e79f89112c0a1a8da4177.tar.gz
gentoo-2-37235a4c7157e120af4e79f89112c0a1a8da4177.tar.bz2
gentoo-2-37235a4c7157e120af4e79f89112c0a1a8da4177.zip
Don't pax-mark libpython.so. Bug 413671.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.6.8.ebuild4
-rw-r--r--dev-lang/python/python-2.7.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-3.1.5.ebuild4
-rw-r--r--dev-lang/python/python-3.2.3.ebuild4
5 files changed, 13 insertions, 9 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 1acb849ccf08..1fd6c4a8ee48 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.580 2012/04/26 22:25:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.581 2012/04/26 22:32:58 floppym Exp $
+
+ 26 Apr 2012; Mike Gilbert <floppym@gentoo.org> python-2.6.8.ebuild,
+ python-2.7.3-r1.ebuild, python-3.1.5.ebuild, python-3.2.3.ebuild:
+ Don't pax-mark libpython.so. Bug 413671.
26 Apr 2012; Mike Gilbert <floppym@gentoo.org> python-2.6.8.ebuild,
python-2.7.3-r1.ebuild, python-3.1.5.ebuild, python-3.2.3.ebuild:
diff --git a/dev-lang/python/python-2.6.8.ebuild b/dev-lang/python/python-2.6.8.ebuild
index 61991d826dde..5708a3038de8 100644
--- a/dev-lang/python/python-2.6.8.ebuild
+++ b/dev-lang/python/python-2.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8.ebuild,v 1.2 2012/04/26 22:25:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8.ebuild,v 1.3 2012/04/26 22:32:58 floppym Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -183,7 +183,7 @@ src_configure() {
src_compile() {
emake EPYTHON="python${PV%%.*}" || die "emake failed"
- pax-mark m libpython${SLOT}.so.1.0 python
+ pax-mark m python
}
src_test() {
diff --git a/dev-lang/python/python-2.7.3-r1.ebuild b/dev-lang/python/python-2.7.3-r1.ebuild
index fa8413426ef3..fb13a65ec433 100644
--- a/dev-lang/python/python-2.7.3-r1.ebuild
+++ b/dev-lang/python/python-2.7.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r1.ebuild,v 1.2 2012/04/26 22:25:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r1.ebuild,v 1.3 2012/04/26 22:32:58 floppym Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -197,7 +197,7 @@ src_configure() {
src_compile() {
emake EPYTHON="python${PV%%.*}" || die "emake failed"
- pax-mark m libpython${SLOT}.so.1.0 python
+ pax-mark m python
}
src_test() {
diff --git a/dev-lang/python/python-3.1.5.ebuild b/dev-lang/python/python-3.1.5.ebuild
index 3be851ddcf72..9df2437c640b 100644
--- a/dev-lang/python/python-3.1.5.ebuild
+++ b/dev-lang/python/python-3.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5.ebuild,v 1.2 2012/04/26 22:25:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5.ebuild,v 1.3 2012/04/26 22:32:58 floppym Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -165,7 +165,7 @@ src_configure() {
src_compile() {
emake || die "emake failed"
- pax-mark m libpython${SLOT}.so.1.0 python
+ pax-mark m python
}
src_test() {
diff --git a/dev-lang/python/python-3.2.3.ebuild b/dev-lang/python/python-3.2.3.ebuild
index 070cee6347bb..23a24332008c 100644
--- a/dev-lang/python/python-3.2.3.ebuild
+++ b/dev-lang/python/python-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3.ebuild,v 1.2 2012/04/26 22:25:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3.ebuild,v 1.3 2012/04/26 22:32:58 floppym Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -178,7 +178,7 @@ src_configure() {
src_compile() {
emake CPPFLAGS="" CFLAGS="" LDFLAGS="" || die "emake failed"
- pax-mark m libpython${SLOT}.so.1.0 python
+ pax-mark m python
}
src_test() {