summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-02 00:04:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-02 00:04:20 +0000
commit36e36515b4c5d89f66243cf22ee1c9d773a34cc5 (patch)
tree86bd4c9b35ae6c4d2b27e6db77b160d0927f18f7
parentinherit fixheadtails to fix bug #104475 (diff)
downloadgentoo-2-36e36515b4c5d89f66243cf22ee1c9d773a34cc5.tar.gz
gentoo-2-36e36515b4c5d89f66243cf22ee1c9d773a34cc5.tar.bz2
gentoo-2-36e36515b4c5d89f66243cf22ee1c9d773a34cc5.zip
clean up and remove hppa CHOST forcing #104461
(Portage version: 2.0.51.22-r2)
-rw-r--r--dev-libs/gmp/gmp-4.1.4-r1.ebuild26
1 files changed, 8 insertions, 18 deletions
diff --git a/dev-libs/gmp/gmp-4.1.4-r1.ebuild b/dev-libs/gmp/gmp-4.1.4-r1.ebuild
index a65e33232666..7a6f296e50a9 100644
--- a/dev-libs/gmp/gmp-4.1.4-r1.ebuild
+++ b/dev-libs/gmp/gmp-4.1.4-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.4-r1.ebuild,v 1.1 2005/08/14 10:13:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.4-r1.ebuild,v 1.2 2005/09/02 00:04:20 vapier Exp $
-inherit flag-o-matic libtool eutils multilib
+inherit flag-o-matic eutils
DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
SRC_URI="mirror://gnu/gmp/${P}.tar.gz"
@@ -13,31 +13,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE=""
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- sys-apps/gawk
- sys-devel/bison
- sys-devel/flex
- >=sys-devel/libtool-1.4.3-r4
- sys-devel/gcc"
+RDEPEND=""
+DEPEND=""
src_unpack () {
unpack ${A}
- cd ${S}
+ cd "${S}"
# This patch will actually be somewhat short lived as it's really
# somewhat of a hack. The toolchain folks (alanm) have a set of patches
# to remove the use of the '.' form in ppc64 assembler
if use ppc64 ; then
- epatch ${FILESDIR}/ppc64-gmp-acinclude.patch
+ epatch "${FILESDIR}"/ppc64-gmp-acinclude.patch
fi
# fix problems for -O3 or higher; bug #66780
if use amd64; then
- epatch ${FILESDIR}/amd64.patch
+ epatch "${FILESDIR}"/amd64.patch
fi
- epatch ${FILESDIR}/${PN}-4.1.4-multilib.patch
+ epatch "${FILESDIR}"/${PN}-4.1.4-multilib.patch
export WANT_AUTOCONF=2.5
export WANT_AUTOMAKE=1.5
@@ -50,7 +45,6 @@ src_compile() {
local myconf=""
use sparc || myconf="--enable-mpfr"
- use hppa && export CHOST="hppa-unknown-linux-gnu"
# FreeBSD libc already have bsdmp
econf \
@@ -70,7 +64,3 @@ src_install() {
dodoc doc/configuration doc/isa_abi_headache
dohtml -r doc
}
-
-src_test() {
- make check || die "make check failed"
-}