summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-09-09 19:33:57 +0000
committerTilman Klar <phoenix@gentoo.org>2002-09-09 19:33:57 +0000
commit3084a5a4860f280ce837b8664aeba5f48e53f194 (patch)
treec1d552984f71e1ed8d77c796bd617f571b9c21ea
parentenhanced wine mask to the new version (diff)
downloadgentoo-2-3084a5a4860f280ce837b8664aeba5f48e53f194.tar.gz
gentoo-2-3084a5a4860f280ce837b8664aeba5f48e53f194.tar.bz2
gentoo-2-3084a5a4860f280ce837b8664aeba5f48e53f194.zip
Bumped to new version
-rw-r--r--app-emulation/wine/ChangeLog8
-rw-r--r--app-emulation/wine/files/digest-wine-200209041
-rw-r--r--app-emulation/wine/files/wine-20020904-config299
-rw-r--r--app-emulation/wine/files/wine-20020904-regedit20
-rw-r--r--app-emulation/wine/files/wine-20020904-wine48
-rw-r--r--app-emulation/wine/wine-20020904.ebuild98
6 files changed, 473 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 81ce8b0dfe36..b9f50b47ee9d 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.17 2002/09/05 16:54:16 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.18 2002/09/09 19:33:57 phoenix Exp $
+
+*wine-20020809 (09 Sep 2002)
+
+ 09 Sep 2002; phoen][x <phoenix@gentoo.org> wine-20020809.ebuild :
+
+ Bumped to new version.
*wine-20020804 (05 Sep 2002)
diff --git a/app-emulation/wine/files/digest-wine-20020904 b/app-emulation/wine/files/digest-wine-20020904
new file mode 100644
index 000000000000..4d9267244b7f
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20020904
@@ -0,0 +1 @@
+MD5 686ebc4cb0a9ba3202e15453b07ab69a Wine-20020904.tar.gz 7603556
diff --git a/app-emulation/wine/files/wine-20020904-config b/app-emulation/wine/files/wine-20020904-config
new file mode 100644
index 000000000000..05616fe8d54f
--- /dev/null
+++ b/app-emulation/wine/files/wine-20020904-config
@@ -0,0 +1,299 @@
+WINE REGISTRY Version 2
+;; All keys relative to \\Machine\\Software\\Wine\\Wine\\Config
+
+;; If you think it is necessary to show others your complete config for a
+;; bug report, filter out empty lines and comments with
+;; grep -v "^;" ~/.wine/config | grep '.'
+;;
+;; MS-DOS drives configuration
+;;
+;; Each section has the following format:
+;; [Drive X]
+;; "Path"="xxx" (Unix path for drive root)
+;; "Type"="xxx" (supported types are 'floppy', 'hd', 'cdrom' and 'network')
+;; "Label"="xxx" (drive label, at most 11 characters)
+;; "Serial"="xxx" (serial number, 8 characters hexadecimal number)
+;; "Filesystem"="xxx" (supported types are 'msdos'/'dos'/'fat', 'win95'/'vfat', 'unix')
+;; This is the FS Wine is supposed to emulate on a certain
+;; directory structure.
+;; Recommended:
+;; - "win95" for ext2fs, VFAT and FAT32
+;; - "msdos" for FAT16 (ugly, upgrading to VFAT driver strongly recommended)
+;; DON'T use "unix" unless you intend to port programs using Winelib !
+;; "Device"="/dev/xx" (only if you want to allow raw device access)
+;;
+[Drive A]
+"Path" = "/mnt/fd0"
+"Type" = "floppy"
+"Label" = "Floppy"
+"Filesystem" = "win95"
+"Serial" = "87654321"
+"Device" = "/dev/fd0"
+
+[Drive C]
+"Path" = "/c"
+"Type" = "hd"
+"Label" = "MS-DOS"
+"Filesystem" = "win95"
+
+[Drive D]
+"Path" = "/cdrom"
+"Type" = "cdrom"
+"Label" = "CD-Rom"
+"Filesystem" = "win95"
+; make sure that device is correct and has proper permissions !
+"Device" = "/dev/cdrom"
+
+[Drive E]
+"Path" = "/tmp"
+"Type" = "hd"
+"Label" = "Tmp Drive"
+"Filesystem" = "win95"
+
+[Drive F]
+"Path" = "${HOME}"
+"Type" = "network"
+"Label" = "Home"
+"Filesystem" = "win95"
+
+[wine]
+"Windows" = "c:\\windows"
+"System" = "c:\\windows\\system"
+"Temp" = "e:\\"
+"Path" = "c:\\windows;c:\\windows\\system;e:\\;e:\\test;f:\\"
+"Profile" = "c:\\windows\\Profiles\\Administrator"
+"GraphicsDriver" = "x11drv"
+; Wine doesn't pass directory symlinks to Windows programs by default.
+; Enabling this may crash some programs that do recursive lookups of a whole
+; subdir tree in case of a symlink pointing back to itself.
+;"ShowDirSymlinks" = "1"
+"ShellLinker" = "wineshelllink"
+
+# <wineconf>
+
+[Version]
+; Windows version to imitate (win95,win98,winme,nt351,nt40,win2k,winxp,win20,win30,win31)" },
+;"Windows" = "win98"
+; DOS version to imitate
+;"DOS" = "6.22"
+
+; Be careful here, wrong DllOverrides settings have the potential
+; to pretty much kill your setup.
+[DllOverrides]
+"rpcrt4" = "builtin, native"
+"oleaut32" = "builtin, native"
+"ole32" = "builtin, native"
+"commdlg" = "builtin, native"
+"comdlg32" = "builtin, native"
+"ver" = "builtin, native"
+"version" = "builtin, native"
+"shell" = "builtin, native"
+"shell32" = "builtin, native"
+"shfolder" = "builtin, native"
+"shlwapi" = "builtin, native"
+"shdocvw" = "builtin, native"
+"lzexpand" = "builtin, native"
+"lz32" = "builtin, native"
+"comctl32" = "builtin, native"
+"commctrl" = "builtin, native"
+"advapi32" = "builtin, native"
+"crtdll" = "builtin, native"
+"mpr" = "builtin, native"
+"winspool.drv" = "builtin, native"
+"ddraw" = "builtin, native"
+"dinput" = "builtin, native"
+"dsound" = "builtin, native"
+"opengl32" = "builtin, native"
+"msvcrt" = "native, builtin"
+"msvideo" = "builtin, native"
+"msvfw32" = "builtin, native"
+"mcicda.drv" = "builtin, native"
+"mciseq.drv" = "builtin, native"
+"mciwave.drv" = "builtin, native"
+"mciavi.drv" = "native, builtin"
+"mcianim.drv" = "native, builtin"
+"msacm.drv" = "builtin, native"
+"msacm" = "builtin, native"
+"msacm32" = "builtin, native"
+"midimap.drv" = "builtin, native"
+; you can specify applications too
+"notepad.exe" = "native, builtin"
+; default for all other dlls
+"*" = "native, builtin"
+
+[x11drv]
+; Number of colors to allocate from the system palette
+"AllocSystemColors" = "100"
+; Use a private color map
+"PrivateColorMap" = "N"
+; Favor correctness over speed in some graphics operations
+"PerfectGraphics" = "N"
+; Color depth to use on multi-depth screens
+;;"ScreenDepth" = "16"
+; Name of X11 display to use
+;;"Display" = ":0.0"
+; Allow the window manager to manage created windows
+"Managed" = "Y"
+; Use a desktop window of 640x480 for Wine
+;"Desktop" = "640x480"
+; Use XFree86 DGA extension if present
+; (make sure /dev/mem is accessible by you !)
+"UseDGA" = "Y"
+; Use XShm extension if present
+"UseXShm" = "Y"
+; Use XVidMode extension if present
+"UseXVidMode" = "Y"
+; Enable DirectX mouse grab
+"DXGrab" = "N"
+; Create the desktop window with a double-buffered visual
+; (useful to play OpenGL games)
+"DesktopDoubleBuffered" = "N"
+; Code page used for captions in managed mode
+; 0 means default ANSI code page (CP_ACP == 0)
+"TextCP" = "0"
+; Use this if you have more than one port for video on your setup
+; (Wine uses for now the first 'input image' it finds).
+;; "XVideoPort" = "43"
+; Run in synchronous mode (useful for debugging X11 problems)
+;;"Synchronous" = "Y"
+
+[fonts]
+;Read the Fonts topic in the Wine User Guide before adding aliases
+;See a couple of examples for russian users below
+"Resolution" = "96"
+"Default" = "-adobe-helvetica-"
+"DefaultFixed" = "fixed"
+"DefaultSerif" = "-adobe-times-"
+"DefaultSansSerif" = "-adobe-helvetica-"
+
+;; default TrueType fonts with russian koi8-r encoding
+;"Default" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
+;"DefaultFixed" = "-monotype-courier new-*-*-*--*-*-*-*-*-*-koi8-r"
+;"DefaultSerif" = "-monotype-times new roman-*-*-*--*-*-*-*-*-*-koi8-r"
+;"DefaultSansSerif" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
+;; default cyrillic bitmap X fonts
+;"Default" = "-cronyx-helvetica-"
+;"DefaultFixed" = "fixed"
+;"DefaultSerif" = "-cronyx-times-"
+;"DefaultSansSerif" = "-cronyx-helvetica-"
+
+; the TrueType font dirs you want to make accessible to wine
+[FontDirs]
+;"dir1" = "/usr/X11R6/lib/X11/fonts/TrueType"
+;"dir2" = "/usr/share/fonts/truetype"
+;"dir3" = "/usr/X11R6/lib/X11/fonts/TT"
+;"dir4" = "/usr/share/fonts/TT"
+
+[serialports]
+"Com1" = "/dev/ttyS0"
+"Com2" = "/dev/ttyS1"
+"Com3" = "/dev/ttyS2"
+"Com4" = "/dev/modem"
+
+[parallelports]
+"Lpt1" = "/dev/lp0"
+
+[ppdev]
+;; key: io-base of the emulated port
+;; value : parport-device{,timeout}
+;; timeout for auto closing an open device ( not yet implemented)
+;"378" = "/dev/parport0"
+;"278" = "/dev/parport1"
+;"3bc" = "/dev/parport2"
+
+[spooler]
+"FILE:" = "tmp.ps"
+"LPT1:" = "|lpr"
+"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"
+"LPT3:" = "/dev/lp3"
+
+[ports]
+;"read" = "0x779,0x379,0x280-0x2a0"
+;"write" = "0x779,0x379,0x280-0x2a0"
+
+[Debug]
+;"RelayExclude" = "RtlEnterCriticalSection;RtlLeaveCriticalSection"
+;"RelayInclude" = "user32.CreateWindowA"
+;"SnoopExclude" = "RtlEnterCriticalSection;RtlLeaveCriticalSection"
+;"SpyExclude" = "WM_SIZE;WM_TIMER;"
+
+[registry]
+;These are all booleans. Y/y/T/t/1 are true, N/n/F/f/0 are false.
+;Defaults are read all, write to Home
+; Global registries (stored in /etc)
+"LoadGlobalRegistryFiles" = "Y"
+; Home registries (stored in ~user/.wine/)
+"LoadHomeRegistryFiles" = "Y"
+; Load Windows registries from the Windows directory
+"LoadWindowsRegistryFiles" = "Y"
+; TRY to write all changes to home registries
+"WritetoHomeRegistryFiles" = "Y"
+; Registry periodic save timeout in seconds
+; "PeriodicSave" = "600"
+; Save only modified keys
+"SaveOnlyUpdatedKeys" = "Y"
+
+[Tweak.Layout]
+;; supported styles are 'Win31'(default), 'Win95', 'Win98'
+;; this has *nothing* to do with the windows version Wine returns:
+;; set the "Windows" value in the [Version] section if you want that.
+"WineLook" = "Win95"
+
+[Console]
+;"Drivers" = "tty"
+;"XtermProg" = "nxterm"
+;"InitialRows" = "25"
+;"InitialColumns" = "80"
+;"TerminalType" = "nxterm"
+
+[Clipboard]
+"ClearAllSelections" = "0"
+"PersistentSelection" = "1"
+
+; List of all directories directly contain .AFM files
+[afmdirs]
+"1" = "/usr/share/ghostscript/fonts"
+"2" = "/usr/share/a2ps/afm"
+"3" = "/usr/share/enscript"
+"4" = "/usr/X11R6/lib/X11/fonts/Type1"
+
+[WinMM]
+"Drivers" = "wineoss.drv"
+#"Drivers" = "winearts.drv"
+"WaveMapper" = "msacm.drv"
+"MidiMapper" = "midimap.drv"
+
+[dsound]
+;; HEL only: Number of waveOut fragments ahead to mix in new buffers.
+;"HELmargin" = "5"
+;; HEL only: Number of waveOut fragments ahead to queue to driver.
+;"HELqueue" = "5"
+;; Max number of fragments to prebuffer
+;"SndQueueMax" = "28"
+;; Min number of fragments to prebuffer
+;"SndQueueMin" = "12"
+
+;; sample AppDefaults entries
+;[AppDefaults\\iexplore.exe\\DllOverrides]
+;"shlwapi" = "native"
+;"rpcrt4" = "native"
+;"ole32" = "native"
+;"shdocvw" = "native"
+;"wininet" = "native"
+;"shfolder" = "native"
+;"shell32" = "native"
+;"shell" = "native"
+;"comctl32" = "native"
+;
+;[AppDefaults\\setup.exe\\x11drv]
+;"Desktop" = "800x600"
+;
+;[AppDefaults\\sol.exe\\Version]
+;"Windows" = "nt40"
+;
+;; Some games (Quake 2, UT) refuse to accept emulated dsound devices.
+;; You can add an AppDefault entry like this for such cases.
+;[AppDefaults\\pickygame.exe\\dsound]
+;"EmulDriver" = "N"
+
+# </wineconf>
diff --git a/app-emulation/wine/files/wine-20020904-regedit b/app-emulation/wine/files/wine-20020904-regedit
new file mode 100644
index 000000000000..129bba0ab047
--- /dev/null
+++ b/app-emulation/wine/files/wine-20020904-regedit
@@ -0,0 +1,20 @@
+#!/bin/bash
+# The wine regapi wrapper
+
+export INSTALLDIR="/usr/lib/wine"
+
+export WINEPREFIX="$HOME/.wine"
+
+export LD_LIBRARY_PATH="$INSTALLDIR/lib/wine:$INSTALLDIR/lib:$LD_LIBRARY_PATH"
+export WINEDLLPATH="$LD_LIBRARY_PATH"
+
+export WINE_LOADER=wine
+
+export RUNWINE="$INSTALLDIR/bin/wine"
+export REGAPI="$INSTALLDIR/bin/regapi"
+
+if([ -z ${1} ]) then
+ echo "Usage: regedit foo.reg"
+else
+ "$REGAPI" setValue < ${1} &> /dev/null
+fi
diff --git a/app-emulation/wine/files/wine-20020904-wine b/app-emulation/wine/files/wine-20020904-wine
new file mode 100644
index 000000000000..19b32fac8c21
--- /dev/null
+++ b/app-emulation/wine/files/wine-20020904-wine
@@ -0,0 +1,48 @@
+#!/bin/bash
+# The wine wrapper
+
+# Kindly distributed by Martin Schlemmer
+# Modified by phoen][x
+
+export INSTALLDIR="/usr/lib/wine"
+
+export WINEPREFIX="$HOME/.wine"
+
+export LD_LIBRARY_PATH="$INSTALLDIR/lib/wine:$INSTALLDIR/lib:$LD_LIBRARY_PATH"
+export WINEDLLPATH="$LD_LIBRARY_PATH"
+
+export WINE_LOADER=wine
+
+export RUNWINE="$INSTALLDIR/bin/wine"
+export REGAPI="$INSTALLDIR/bin/regapi"
+
+if [ ! -f $WINEPREFIX/config ]
+then
+ echo "!! ~/.wine/config misses"
+ echo "!! Setting up a config file"
+
+ mkdir -p $WINEPREFIX/fake_windows
+
+ # First copy in the new config file.
+ cp "$INSTALLDIR/.data/config" "$WINEPREFIX/config"
+
+ echo "!! Setting up ~/.wine/fake_windows/"
+ cp -R $INSTALLDIR/.data/fake_windows/* $WINEPREFIX/fake_windows
+
+ echo "!! Setting up default registry."
+ "$REGAPI" setValue < "$INSTALLDIR/.data/winedefault.reg" &> /dev/null
+
+ echo "!! Installation complete."
+ echo "!! Set the correct path for drive D and E in ~/.wine/config and uncomment the sections, please"
+ exit
+fi
+
+# Force the use of the more memory-efficient MSVC 5 allocator with
+# any programs that use MSVCRT. This reduces memory consumption
+# significantly.
+export __MSVCRT_HEAP_SELECT=__GLOBAL_HEAP_SELECTED,2
+
+
+PATH="$INSTALLDIR/bin:$PATH"
+
+"$RUNWINE" --debugmsg -all "$@"
diff --git a/app-emulation/wine/wine-20020904.ebuild b/app-emulation/wine/wine-20020904.ebuild
new file mode 100644
index 000000000000..99863ac86a3f
--- /dev/null
+++ b/app-emulation/wine/wine-20020904.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020904.ebuild,v 1.1 2002/09/09 19:33:57 phoenix Exp $
+
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND="virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ dev-lang/tcl dev-lang/tk
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Creates /usr/lib/wine/.data with fake_windows in it
+ # This is needed for our wine wrapper script
+ mkdir ${D}/usr/lib/wine/.data
+ cp -R ${WORKDIR}/fake_windows ${D}/usr/lib/wine/.data
+ cp ${FILESDIR}/${P}-config ${D}/usr/lib/wine/.data/config
+ cp ${WORKDIR}/${P}/winedefault.reg ${D}/usr/lib/wine/.data/winedefault.reg
+
+ # Install the wrapper script
+ mkdir ${D}/usr/bin
+ cp ${FILESDIR}/${P}-wine ${D}/usr/bin/wine
+ cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-wine
+
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "**********************************************************************"
+ einfo "* NOTE: Use /usr/bin/wine to start wine. This is a wrapper-script *"
+ einfo "* which will take care of everything else. *"
+ einfo "* Use /usr/bin/regedit-wine to import registry files into the *"
+ einfo "* wine registry. *"
+ einfo "* If you have further questions, enhancements or patches *"
+ einfo "* send an email to phoenix@gentoo.org *"
+ einfo "**********************************************************************"
+}
+