summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-10 23:07:03 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-10 23:07:03 +0000
commit2b8213243461d278a33b4c881ef813f49af9163f (patch)
tree924b15594c3d0446730378fc606afcc7027caafa
parentadded ebuild from tchan (diff)
downloadgentoo-2-2b8213243461d278a33b4c881ef813f49af9163f.tar.gz
gentoo-2-2b8213243461d278a33b4c881ef813f49af9163f.tar.bz2
gentoo-2-2b8213243461d278a33b4c881ef813f49af9163f.zip
fixed so that it works with the sandbox, also don't install the config-file in /usr/etc, use die instead of try. tab instead of space and so on.. :)
-rw-r--r--app-text/enscript/enscript-1.6.1-r1.ebuild41
-rw-r--r--app-text/enscript/files/digest-enscript-1.6.1-r11
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/enscript/enscript-1.6.1-r1.ebuild b/app-text/enscript/enscript-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..6ee7d8b94be1
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/enscript-1.6.1-r1.ebuild,v 1.1 2002/01/10 23:07:03 hallski Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.gnu.org/gnu/enscript/${P}.tar.gz"
+
+HOMEPAGE="http:/www.gnu.org/software/enscript/enscript.html"
+DESCRIPTION="GNU's enscript is a powerful text-to-postsript converter"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison"
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc
+ assert
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog FAQ.html NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ echo "
+ Now, customize /etc/enscript.cfg.
+ "
+}
diff --git a/app-text/enscript/files/digest-enscript-1.6.1-r1 b/app-text/enscript/files/digest-enscript-1.6.1-r1
new file mode 100644
index 000000000000..f4e6b78d3d1d
--- /dev/null
+++ b/app-text/enscript/files/digest-enscript-1.6.1-r1
@@ -0,0 +1 @@
+MD5 5ebcd29011806fb038b088a6adbda8b2 enscript-1.6.1.tar.gz 647168