summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-12-14 22:55:14 +0000
committerTim Harder <radhermit@gentoo.org>2011-12-14 22:55:14 +0000
commit29e88b4f62f51da9724b9aec3a838d4aeef68361 (patch)
tree44b85fde55d69f58d6b61af9e0009d96b54541b4
parentMoving package from dev-php5 to dev-php category (bug #324665) (diff)
downloadgentoo-2-29e88b4f62f51da9724b9aec3a838d4aeef68361.tar.gz
gentoo-2-29e88b4f62f51da9724b9aec3a838d4aeef68361.tar.bz2
gentoo-2-29e88b4f62f51da9724b9aec3a838d4aeef68361.zip
Revbump to fix automagic dependencies. Add libedit and tools use flags.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
-rw-r--r--www-servers/varnish/ChangeLog8
-rw-r--r--www-servers/varnish/files/varnish-3.0.2-automagic.patch49
-rw-r--r--www-servers/varnish/metadata.xml31
-rw-r--r--www-servers/varnish/varnish-3.0.2-r1.ebuild66
4 files changed, 139 insertions, 15 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index e2f6b5b82515..e20256aeb40c 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.42 2011/12/14 22:48:29 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.43 2011/12/14 22:55:13 radhermit Exp $
+
+*varnish-3.0.2-r1 (14 Dec 2011)
+
+ 14 Dec 2011; Tim Harder <radhermit@gentoo.org> +varnish-3.0.2-r1.ebuild,
+ +files/varnish-3.0.2-automagic.patch, metadata.xml:
+ Revbump to fix automagic dependencies. Add libedit and tools use flags.
14 Dec 2011; Tim Harder <radhermit@gentoo.org> varnish-2.1.5.ebuild,
varnish-3.0.1.ebuild, varnish-3.0.2.ebuild:
diff --git a/www-servers/varnish/files/varnish-3.0.2-automagic.patch b/www-servers/varnish/files/varnish-3.0.2-automagic.patch
new file mode 100644
index 000000000000..204e558eb113
--- /dev/null
+++ b/www-servers/varnish/files/varnish-3.0.2-automagic.patch
@@ -0,0 +1,49 @@
+--- varnish-3.0.2/configure.ac.orig
++++ varnish-3.0.2/configure.ac
+@@ -87,15 +87,20 @@
+
+ save_LIBS="${LIBS}"
+ LIBS=""
+-AC_SEARCH_LIBS(initscr, [curses ncurses],
+- [have_curses=yes], [have_curses=no])
+-CURSES_LIBS="${LIBS}"
+-LIBS="${save_LIBS}"
+-AC_SUBST(CURSES_LIBS)
+-if test "$have_curses" = no; then
+- AC_MSG_WARN([curses not found; some tools will not be built])
+-fi
+-AC_CHECK_HEADERS([ncurses/curses.h curses.h])
++AC_ARG_WITH([tools], AS_HELP_STRING([--without-tools],
++ [Don't build additional tools: varnishhist, varnishstat, varnishtop, varnishsizes (default: test)]))
++
++AS_IF([test "x$with_tools" != "xno"], [
++ AC_SEARCH_LIBS(initscr, [curses ncurses],
++ [have_curses=yes], [have_curses=no])
++ CURSES_LIBS="${LIBS}"
++ LIBS="${save_LIBS}"
++ AC_SUBST(CURSES_LIBS)
++ if test "$have_curses" = no; then
++ AC_MSG_ERROR([curses not found, required to build additional tools])
++ fi
++ AC_CHECK_HEADERS([ncurses/curses.h curses.h])
++])
+ AM_CONDITIONAL([HAVE_CURSES], [test x$have_curses = xyes])
+
+ save_LIBS="${LIBS}"
+@@ -147,9 +152,13 @@
+ AC_SUBST(PCRE_CFLAGS)
+ AC_SUBST(PCRE_LIBS)
+
+-PKG_CHECK_MODULES([LIBEDIT], [libedit],
+- [AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])],
+- [AC_MSG_WARN([libedit not found, disabling libedit support])])
++AC_ARG_WITH([libedit], AS_HELP_STRING([--with-libedit],
++ [Enable support for libedit in varnishadm (default: disabled)]))
++AS_IF([test "x$with_libedit" = "xyes"], [
++ PKG_CHECK_MODULES([LIBEDIT], [libedit],
++ [AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])],
++ [AC_MSG_ERROR([libedit not found])])
++])
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/www-servers/varnish/metadata.xml b/www-servers/varnish/metadata.xml
index 6a9d9e083d8e..86e5e5315cb3 100644
--- a/www-servers/varnish/metadata.xml
+++ b/www-servers/varnish/metadata.xml
@@ -1,19 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>www-servers</herd>
-<longdescription lang="en">
-Varnish is an HTTP accelerator. An HTTP accelerator (often called Reverse Proxy)
-is an application that stores (caches) documents that have been requested over
-the HTTP protocol.
-Based on certain criteria the next client requesting the document is either
-given the cached document, or a "fresh" document requested from a backend
-server. The purpose of this is to minimize the requests going to the backend
-server(s) by serving the same document to potentially many users.
+ <herd>www-servers</herd>
+ <use>
+ <flag name="tools">Build additional tools: varnishhist, varnishstat, varnishtop, varnishsizes</flag>
+ </use>
+ <longdescription lang="en">
+ Varnish is an HTTP accelerator. An HTTP accelerator (often called Reverse Proxy)
+ is an application that stores (caches) documents that have been requested over
+ the HTTP protocol.
+ Based on certain criteria the next client requesting the document is either
+ given the cached document, or a "fresh" document requested from a backend
+ server. The purpose of this is to minimize the requests going to the backend
+ server(s) by serving the same document to potentially many users.
-The goal of Varnish is to be a very fast, stable and effective light-weight HTTP
-accelerator daemon, by using modern and effective technologies. Ease of
-managment and good documentation is also a main goal of the project since the
-lack of either one will render Varnish useless.
-</longdescription>
+ The goal of Varnish is to be a very fast, stable and effective light-weight HTTP
+ accelerator daemon, by using modern and effective technologies. Ease of
+ managment and good documentation is also a main goal of the project since the
+ lack of either one will render Varnish useless.
+ </longdescription>
</pkgmetadata>
diff --git a/www-servers/varnish/varnish-3.0.2-r1.ebuild b/www-servers/varnish/varnish-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..8c6e4c7a6def
--- /dev/null
+++ b/www-servers/varnish/varnish-3.0.2-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-3.0.2-r1.ebuild,v 1.1 2011/12/14 22:55:13 radhermit Exp $
+
+EAPI="4"
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://repo.varnish-cache.org/source/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc libedit static-libs +tools"
+
+CDEPEND="dev-libs/libpcre
+ libedit? ( dev-libs/libedit )
+ tools? ( sys-libs/ncurses )"
+#varnish compiles stuff at run time
+RDEPEND="${CDEPEND}
+ sys-devel/gcc"
+DEPEND="${CDEPEND}
+ dev-python/docutils
+ dev-util/pkgconfig"
+
+RESTRICT="test" #315725
+
+DOCS=( README doc/changes.rst )
+
+PATCHES=( "${FILESDIR}"/${P}-automagic.patch )
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with libedit)
+ $(use_with tools)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/varnishd.initd varnishd
+ newconfd "${FILESDIR}"/varnishd.confd varnishd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+
+ use doc && dohtml -r "doc/sphinx/=build/html/"
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "please read the man-page for more info."
+ elog "A sample (localhost:8080 -> localhost:80) for gentoo is given in"
+ elog " /etc/conf.d/varnishd"
+}