summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-02-15 14:14:09 +0000
committerIan Delaney <idella4@gentoo.org>2014-02-15 14:14:09 +0000
commit293619bf0782949318508f1c876d079a2f9da268 (patch)
tree831c0ffa25c126889ff0f3499668c8036cb3fec4
parentStable for HPPA (bug #498186). (diff)
downloadgentoo-2-293619bf0782949318508f1c876d079a2f9da268.tar.gz
gentoo-2-293619bf0782949318508f1c876d079a2f9da268.tar.bz2
gentoo-2-293619bf0782949318508f1c876d079a2f9da268.zip
bump; extra patchsets prepared by dlan, -qa.patch required a re-base
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--app-emulation/xen-pvgrub/ChangeLog8
-rw-r--r--app-emulation/xen-pvgrub/files/xen-pvgrub-4.2.3-qa.patch34
-rw-r--r--app-emulation/xen-pvgrub/xen-pvgrub-4.2.3.ebuild158
3 files changed, 199 insertions, 1 deletions
diff --git a/app-emulation/xen-pvgrub/ChangeLog b/app-emulation/xen-pvgrub/ChangeLog
index 1e0f6e2fe9ec..8750564de60d 100644
--- a/app-emulation/xen-pvgrub/ChangeLog
+++ b/app-emulation/xen-pvgrub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/xen-pvgrub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/ChangeLog,v 1.46 2014/01/24 15:42:08 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/ChangeLog,v 1.47 2014/02/15 14:14:09 idella4 Exp $
+
+*xen-pvgrub-4.2.3 (15 Feb 2014)
+
+ 15 Feb 2014; Ian Delaney <idella4@gentoo.org>
+ +files/xen-pvgrub-4.2.3-qa.patch, +xen-pvgrub-4.2.3.ebuild:
+ bump; extra patchsets prepared by dlan, -qa.patch required a re-base
24 Jan 2014; Yixun Lan <dlan@gentoo.org> -xen-pvgrub-4.3.0.ebuild:
ebuild clean, drop 4.3.0
diff --git a/app-emulation/xen-pvgrub/files/xen-pvgrub-4.2.3-qa.patch b/app-emulation/xen-pvgrub/files/xen-pvgrub-4.2.3-qa.patch
new file mode 100644
index 000000000000..ea693666f022
--- /dev/null
+++ b/app-emulation/xen-pvgrub/files/xen-pvgrub-4.2.3-qa.patch
@@ -0,0 +1,34 @@
+This includes a few headers to fix some missing function declarations.
+
+Signed-off-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
+
+diff --git a/stubdom/grub/config.h b/stubdom/grub/config.h
+index 1649d51..15a6583 100644
+--- a/stubdom/grub/config.h
++++ b/stubdom/grub/config.h
+@@ -2,6 +2,7 @@
+ #undef putchar
+ #include <ctype.h>
+ #include <string.h>
++#include <kernel.h>
+ #define debug _debug
+ #define grub_halt(a) do_exit()
+ #define printf grub_printf
+diff -ur xen-4.2.3.orig/xen/include/xen/libelf.h xen-4.2.3/xen/include/xen/libelf.h
+--- xen-4.2.3.orig/xen/include/xen/libelf.h 2013-09-09 20:27:41.000000000 +0800
++++ xen-4.2.3/xen/include/xen/libelf.h 2014-02-15 13:42:24.491435783 +0800
+@@ -37,12 +37,14 @@
+ #ifdef __XEN__
+ #include <public/elfnote.h>
+ #include <public/features.h>
++#include <xen/string.h>
+ #include <xen/stdbool.h>
+ #else
+ #include <xen/elfnote.h>
+ #include <xen/features.h>
+
+ #include <stdarg.h>
++#include <string.h>
+ #include <stdbool.h>
+
+ struct elf_binary;
diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-4.2.3.ebuild b/app-emulation/xen-pvgrub/xen-pvgrub-4.2.3.ebuild
new file mode 100644
index 000000000000..88464c940487
--- /dev/null
+++ b/app-emulation/xen-pvgrub/xen-pvgrub-4.2.3.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.2.3.ebuild,v 1.1 2014/02/15 14:14:09 idella4 Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+
+inherit flag-o-matic eutils multilib python toolchain-funcs
+
+XEN_EXTFILES_URL="http://xenbits.xensource.com/xen-extfiles"
+LIBPCI_URL=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+GRUB_URL=mirror://gnu-alpha/grub
+
+UPSTREAM_VER=0
+GENTOO_VER=
+
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P/-pvgrub/}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+[[ -n ${GENTOO_VER} ]] && \
+ GENTOO_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P/-pvgrub/}-gentoo-patches-${GENTOO_VER}.tar.xz"
+
+SRC_URI="
+ http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz
+ $GRUB_URL/grub-0.97.tar.gz
+ $XEN_EXTFILES_URL/zlib-1.2.3.tar.gz
+ $LIBPCI_URL/pciutils-2.2.9.tar.bz2
+ $XEN_EXTFILES_URL/lwip-1.3.0.tar.gz
+ $XEN_EXTFILES_URL/newlib/newlib-1.16.0.tar.gz
+ ${UPSTREAM_PATCHSET_URI}
+ ${GENTOO_PATCHSET_URI}
+ "
+
+S="${WORKDIR}/xen-${PV}"
+
+DESCRIPTION="allows to boot Xen domU kernels from a menu.lst laying inside guest filesystem"
+HOMEPAGE="http://xen.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="custom-cflags"
+
+DEPEND="sys-devel/gettext"
+
+RDEPEND=">=app-emulation/xen-4.2.1"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+retar-externals() {
+ # Purely to unclutter src_prepare
+ local set="grub-0.97.tar.gz lwip-1.3.0.tar.gz newlib-1.16.0.tar.gz zlib-1.2.3.tar.gz"
+
+ # epatch can't patch in $WORKDIR, requires a sed; Bug #455194. Patchable, but sed informative
+ sed -e s':AR=${AR-"ar rc"}:AR=${AR-"ar"}:' \
+ -i "${WORKDIR}"/zlib-1.2.3/configure
+ sed -e 's:^AR=ar rc:AR=ar:' \
+ -e s':$(AR) $@:$(AR) rc $@:' \
+ -i "${WORKDIR}"/zlib-1.2.3/{Makefile,Makefile.in}
+ einfo "zlib Makefile edited"
+
+ cd "${WORKDIR}"
+ tar czp zlib-1.2.3 -f zlib-1.2.3.tar.gz
+ tar czp grub-0.97 -f grub-0.97.tar.gz
+ tar czp lwip -f lwip-1.3.0.tar.gz
+ tar czp newlib-1.16.0 -f newlib-1.16.0.tar.gz
+ mv $set "${S}"/stubdom/
+ einfo "tarballs moved to source"
+}
+
+src_prepare() {
+ # Upstream's patchset
+ if [[ -n ${UPSTREAM_VER} ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patches-upstream
+ fi
+
+ # Gentoo's patchset
+ if [[ -n ${GENTOO_VER} ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patches-gentoo
+ fi
+
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+
+ # Patch the unmergeable newlib, fix most of the leftover gcc QA issues
+ cp "${FILESDIR}"/newlib-implicits.patch stubdom || die
+
+ # Patch stubdom/Makefile to patch insource newlib & prevent internal downloading
+ epatch "${FILESDIR}"/${PN/-pvgrub/}-4.2.1-externals.patch
+
+ # Drop .config and Fix gcc-4.6
+ epatch "${FILESDIR}"/${PN/-pvgrub/}-4-fix_dotconfig-gcc.patch
+
+ # fix jobserver in Makefile
+ epatch "${FILESDIR}"/${PN}-4.2-jserver.patch
+
+ # gcc warnings/QA fix
+ epatch "${FILESDIR}"/${P}-qa.patch
+
+ #Substitute for internal downloading. pciutils copied only due to the only .bz2
+ cp "${DISTDIR}"/pciutils-2.2.9.tar.bz2 ./stubdom/ || die "pciutils not copied to stubdom"
+ retar-externals || die "re-tar procedure failed"
+}
+
+src_compile() {
+ use custom-cflags || unset CFLAGS
+ if test-flag-CC -fno-strict-overflow; then
+ append-flags -fno-strict-overflow
+ fi
+
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" -C tools/include
+
+ if use x86; then
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
+ XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
+ elif use amd64; then
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
+ XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub
+ if use multilib; then
+ multilib_toolchain_setup x86
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
+ fi
+ fi
+}
+
+src_install() {
+ if use x86; then
+ emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C stubdom install-grub
+ fi
+ if use amd64; then
+ emake XEN_TARGET_ARCH="x86_64" DESTDIR="${D}" -C stubdom install-grub
+ if use multilib; then
+ emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C stubdom install-grub
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Official Xen Guide and the offical wiki page:"
+ elog "http://www.gentoo.org/doc/en/xen-guide.xml"
+ elog "http://wiki.xen.org/wiki/Main_Page"
+}