summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 11:10:29 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 11:10:29 +0000
commit25b8ae5124d4bd0fdeb44cf96e1a3e20833f7dad (patch)
tree4b4bfb2a1ddd95f98dd28daefc5944d513931704
parentInitial commit. (diff)
downloadgentoo-2-25b8ae5124d4bd0fdeb44cf96e1a3e20833f7dad.tar.gz
gentoo-2-25b8ae5124d4bd0fdeb44cf96e1a3e20833f7dad.tar.bz2
gentoo-2-25b8ae5124d4bd0fdeb44cf96e1a3e20833f7dad.zip
Respect CFLAGS (bug #241552), LDFLAGS, CC. Do not strip (bug #241488). Install man pages properly (bug #248591).
(Portage version: 2.2_rc62/cvs/Linux i686)
-rw-r--r--x11-misc/xrootconsole/ChangeLog9
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch30
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.6.ebuild11
3 files changed, 41 insertions, 9 deletions
diff --git a/x11-misc/xrootconsole/ChangeLog b/x11-misc/xrootconsole/ChangeLog
index 4c15f680cbc1..71d3cba204ad 100644
--- a/x11-misc/xrootconsole/ChangeLog
+++ b/x11-misc/xrootconsole/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xrootconsole
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/ChangeLog,v 1.22 2007/07/22 03:18:33 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/ChangeLog,v 1.23 2010/02/08 11:10:28 jer Exp $
+
+ 08 Feb 2010; Jeroen Roovers <jer@gentoo.org> xrootconsole-0.6.ebuild,
+ files/xrootconsole-0.6.makefile.patch:
+ Respect CFLAGS (bug #241552), LDFLAGS, CC. Do not strip (bug #241488).
+ Install man pages properly (bug #248591).
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
xrootconsole-0.4-r1.ebuild:
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
index ce74eb115e96..37fd4fb074a9 100644
--- a/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
@@ -1,6 +1,30 @@
---- Makefile.orig 2005-03-06 16:46:36.325616480 +0900
-+++ Makefile 2005-03-06 16:46:55.140756144 +0900
-@@ -76,5 +76,7 @@
+--- xrootconsole-0.6/Makefile.org 2004-02-20 22:53:28.000000000 +0100
++++ xrootconsole-0.6/Makefile 2010-02-08 12:01:11.000000000 +0100
+@@ -43,20 +43,16 @@
+ else echo Bleeding Edge Version; \
+ fi;)
+
+-CC = gcc
+-CPPFLAGS =
+-
+ # for production
+-CFLAGS = -O2 -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
+- -I /usr/X11R6/include
+-LDFLAGS = -s
++CFLAGS += -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
++ $(shell pkg-config --cflags x11)
+
+ # for testing
+ #CFLAGS = -g -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION) (debug build)\"" \
+ -I /usr/X11R6/include
+ #LDFLAGS =
+
+-LIBS = -L/usr/X11R6/lib -lX11 -lutil
++LIBS = $(shell pkg-config --libs x11) -lutil
+
+ OBJS = main.o util.o
+
+@@ -76,5 +72,7 @@
rm -f $(EXEC) *.o core *~
install: $(EXEC)
diff --git a/x11-misc/xrootconsole/xrootconsole-0.6.ebuild b/x11-misc/xrootconsole/xrootconsole-0.6.ebuild
index 0a07cb8be445..1834e9a4fcdc 100644
--- a/x11-misc/xrootconsole/xrootconsole-0.6.ebuild
+++ b/x11-misc/xrootconsole/xrootconsole-0.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/xrootconsole-0.6.ebuild,v 1.3 2006/10/21 21:25:52 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/xrootconsole-0.6.ebuild,v 1.4 2010/02/08 11:10:28 jer Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="A utility that displays its input in a text box on your root window"
HOMEPAGE="http://de-fac.to/book/view/17"
@@ -27,6 +27,7 @@ src_unpack() {
}
src_compile() {
+ tc-export CC
emake || die "emake failed"
}
@@ -34,7 +35,9 @@ src_install() {
dodir /usr/bin
make \
- MANDIR="${D}usr/man/man1" \
+ MANDIR="${D}usr/share/man/man1" \
BINDIR="${D}usr/bin/" \
install || die "make install failed"
+
+ dodoc TODO NEWS CREDITS
}