summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-01-17 15:22:20 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-01-17 15:22:20 +0000
commit24d4d71e0872fc836c1b39567747f04a35ee43b5 (patch)
tree4b7b258f8bcdabe7454c82ca1105b1934fc6de13
parentFixed PostgreSQL library error. Closed #37803. (Manifest recommit) (diff)
downloadgentoo-2-24d4d71e0872fc836c1b39567747f04a35ee43b5.tar.gz
gentoo-2-24d4d71e0872fc836c1b39567747f04a35ee43b5.tar.bz2
gentoo-2-24d4d71e0872fc836c1b39567747f04a35ee43b5.zip
libpq++ was renamed to libpqpp.
-rw-r--r--dev-libs/libpq++/ChangeLog19
-rw-r--r--dev-libs/libpq++/Manifest6
-rw-r--r--dev-libs/libpq++/files/digest-libpq++-4.01
-rw-r--r--dev-libs/libpq++/files/digest-libpq++-4.0-r11
-rw-r--r--dev-libs/libpq++/files/libpq++-gentoo.patch95
-rw-r--r--dev-libs/libpq++/libpq++-4.0-r1.ebuild37
-rw-r--r--dev-libs/libpq++/libpq++-4.0.ebuild31
-rw-r--r--dev-libs/libpq++/metadata.xml5
8 files changed, 0 insertions, 195 deletions
diff --git a/dev-libs/libpq++/ChangeLog b/dev-libs/libpq++/ChangeLog
deleted file mode 100644
index 30ae0519cef7..000000000000
--- a/dev-libs/libpq++/ChangeLog
+++ /dev/null
@@ -1,19 +0,0 @@
-# ChangeLog for dev-libs/libpq++
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpq++/ChangeLog,v 1.3 2003/07/19 06:10:32 jje Exp $
-
-*libpq++-4.0-r1 (19 Jul 2003)
-
- 19 Jul 2003; jje <jje@gentoo.org> libpq++-4.0-r1.ebuild,
- files/libpq++-gentoo.patch:
- Added patch to remove DLLIMPORT defines.
-
-*libpq++-4.0 (16 Jun 2003)
-
- 12 Jul 2003; Daniel Ahlberg <aliz@gentoo.org> :
- Added missing changelog entry.
-
- 16 Jun 2003; Masatomo Nakano <nakano@gentoo.org> :
- Initial import. Thanks to marco <marco@md2.ath.cx>
- #21737
-
diff --git a/dev-libs/libpq++/Manifest b/dev-libs/libpq++/Manifest
deleted file mode 100644
index 7dcff7fff8b2..000000000000
--- a/dev-libs/libpq++/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 3b5a462922822ae158d063897cc6979c ChangeLog 604
-MD5 d5c666025df4d9ef39e8701bd361927b libpq++-4.0-r1.ebuild 1073
-MD5 7fa4bb43a332bba3c4444e5ba82bee50 libpq++-4.0.ebuild 999
-MD5 312b07ad4bf840d75840b7410d48f268 files/digest-libpq++-4.0 62
-MD5 530daffcb76569636aa08cb163318b88 files/libpq++-gentoo.patch 3559
-MD5 312b07ad4bf840d75840b7410d48f268 files/digest-libpq++-4.0-r1 62
diff --git a/dev-libs/libpq++/files/digest-libpq++-4.0 b/dev-libs/libpq++/files/digest-libpq++-4.0
deleted file mode 100644
index b94211985780..000000000000
--- a/dev-libs/libpq++/files/digest-libpq++-4.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 da71cb79ef45cef55f4bc97a33a0857d libpq++-4.0.tar.gz 25809
diff --git a/dev-libs/libpq++/files/digest-libpq++-4.0-r1 b/dev-libs/libpq++/files/digest-libpq++-4.0-r1
deleted file mode 100644
index b94211985780..000000000000
--- a/dev-libs/libpq++/files/digest-libpq++-4.0-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 da71cb79ef45cef55f4bc97a33a0857d libpq++-4.0.tar.gz 25809
diff --git a/dev-libs/libpq++/files/libpq++-gentoo.patch b/dev-libs/libpq++/files/libpq++-gentoo.patch
deleted file mode 100644
index 9f54fb43edb9..000000000000
--- a/dev-libs/libpq++/files/libpq++-gentoo.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-*** pgconnection.h Sat Jul 19 14:45:30 2003
---- pgconnection.h.orig Sat Jul 19 14:44:18 2003
-***************
-*** 45,51 ****
- // This class contains all the information about the connection
- // to the backend process. All the database classes should be
- // derived from this class to obtain the connection interface.
-! class DLLIMPORT PgConnection
- {
- protected:
- PGconn* pgConn; // Connection Structure
---- 45,51 ----
- // This class contains all the information about the connection
- // to the backend process. All the database classes should be
- // derived from this class to obtain the connection interface.
-! class PgConnection
- {
- protected:
- PGconn* pgConn; // Connection Structure
-*** pgcursordb.h Sat Jul 19 14:45:38 2003
---- pgcursordb.h.orig Sat Jul 19 14:44:32 2003
-***************
-*** 41,47 ****
- // manipulates data through it. The interface will introduce some
- // ease of use through the methods that will allow cursor specific
- // operations, like fetch, forward, etc.
-! class DLLIMPORT PgCursor : public PgTransaction
- {
- public:
- PgCursor(const char* conninfo, const char* cursor); // use reasonable & environment defaults
---- 41,47 ----
- // manipulates data through it. The interface will introduce some
- // ease of use through the methods that will allow cursor specific
- // operations, like fetch, forward, etc.
-! class PgCursor : public PgTransaction
- {
- public:
- PgCursor(const char* conninfo, const char* cursor); // use reasonable & environment defaults
-*** pglobject.h Sat Jul 19 14:45:57 2003
---- pglobject.h.orig Sat Jul 19 14:44:57 2003
-***************
-*** 35,41 ****
- // PgLargeObject - a class for accessing Large Object in a database
- //
- // ****************************************************************
-! class DLLIMPORT PgLargeObject : public PgConnection
- {
- private:
- int pgFd;
---- 35,41 ----
- // PgLargeObject - a class for accessing Large Object in a database
- //
- // ****************************************************************
-! class PgLargeObject : public PgConnection
- {
- private:
- int pgFd;
-*** pgtransdb.h Sat Jul 19 14:46:07 2003
---- pgtransdb.h.orig Sat Jul 19 14:45:07 2003
-***************
-*** 35,41 ****
- // transaction block during its lifetime. The block is ABORTed when
- // the object is destroyed, unless you call EndTransaction() method
- // before destruction of the object.
-! class DLLIMPORT PgTransaction : public PgDatabase
- {
- public:
- explicit PgTransaction(const char* conninfo); // use reasonable & environment defaults
---- 35,41 ----
- // transaction block during its lifetime. The block is ABORTed when
- // the object is destroyed, unless you call EndTransaction() method
- // before destruction of the object.
-! class PgTransaction : public PgDatabase
- {
- public:
- explicit PgTransaction(const char* conninfo); // use reasonable & environment defaults
-*** pgdatabase.h Sat Jul 19 14:57:39 2003
---- pgdatabase.h.orig Sat Jul 19 14:57:18 2003
-***************
-*** 34,40 ****
- // This is the basic database access class. Its interface should
- // be used only after a query has been sent to the backend and
- // results are being received.
-! class DLLIMPORT PgDatabase : public PgConnection
- {
- public:
- // connect to the database with conninfo
---- 34,40 ----
- // This is the basic database access class. Its interface should
- // be used only after a query has been sent to the backend and
- // results are being received.
-! class PgDatabase : public PgConnection
- {
- public:
- // connect to the database with conninfo
diff --git a/dev-libs/libpq++/libpq++-4.0-r1.ebuild b/dev-libs/libpq++/libpq++-4.0-r1.ebuild
deleted file mode 100644
index ca7570c1c8ed..000000000000
--- a/dev-libs/libpq++/libpq++-4.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpq++/libpq++-4.0-r1.ebuild,v 1.1 2003/07/19 06:10:32 jje Exp $
-
-DESCRIPTION="C++ wrapper for the libpq Postgresql library"
-HOMEPAGE="http://gborg.postgresql.org/"
-SRC_URI="ftp://gborg.postgresql.org/pub/libpqpp/stable/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-
-DEPEND="virtual/glibc"
-RDEPEND=">=dev-db/postgresql-7.3"
-
-S=${WORKDIR}/${P}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-gentoo.patch
-}
-
-src_compile() {
- sed "s|^POSTGRES_HOME=/usr/local/pgsql$|POSTGRES_HOME=/usr|g" Makefile > Makefile.new &&
- mv Makefile.new Makefile
- emake
- sed "s|^POSTGRES_HOME=/usr$|POSTGRES_HOME=\${D}usr|g" Makefile > Makefile.new &&
- mv Makefile.new Makefile
- sed "s|^\tln -s .*$|\tln -s \$(soname) \$(POSTGRES_HOME)/lib/\$(TARGET).so|g" Makefile > Makefile.new &&
- mv Makefile.new Makefile
- emake
-}
-
-src_install() {
- dodir /usr/lib /usr/include
- einstall install || die "Install failed"
-}
diff --git a/dev-libs/libpq++/libpq++-4.0.ebuild b/dev-libs/libpq++/libpq++-4.0.ebuild
deleted file mode 100644
index 1b780a399e77..000000000000
--- a/dev-libs/libpq++/libpq++-4.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpq++/libpq++-4.0.ebuild,v 1.1 2003/06/16 21:09:46 nakano Exp $
-
-DESCRIPTION="C++ wrapper for the libpq Postgresql library"
-HOMEPAGE="http://gborg.postgresql.org/"
-SRC_URI="ftp://gborg.postgresql.org/pub/libpqpp/stable/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-
-DEPEND="virtual/glibc"
-RDEPEND=">=dev-db/postgresql-7.3"
-
-S=${WORKDIR}/${P}
-
-src_compile() {
- sed "s|^POSTGRES_HOME=/usr/local/pgsql$|POSTGRES_HOME=/usr|g" Makefile > Makefile.new &&
- mv Makefile.new Makefile
- emake
- sed "s|^POSTGRES_HOME=/usr$|POSTGRES_HOME=\${D}usr|g" Makefile > Makefile.new &&
- mv Makefile.new Makefile
- sed "s|^\tln -s .*$|\tln -s \$(soname) \$(POSTGRES_HOME)/lib/\$(TARGET).so|g" Makefile > Makefile.new &&
- mv Makefile.new Makefile
- emake
-}
-
-src_install() {
- dodir /usr/lib /usr/include
- einstall install || die "Install failed"
-}
diff --git a/dev-libs/libpq++/metadata.xml b/dev-libs/libpq++/metadata.xml
deleted file mode 100644
index 309b51e9a965..000000000000
--- a/dev-libs/libpq++/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>postgresql</herd>
-</pkgmetadata>