summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-10-10 20:56:45 +0000
committerAnant Narayanan <anant@gentoo.org>2007-10-10 20:56:45 +0000
commit21070edc833ff9510563e092ba12a4115a06731c (patch)
tree1ac27f2aa8cca131e7b0fd4051cab2bc7b7764a0
parentstable ppc, bug #195209 (diff)
downloadgentoo-2-21070edc833ff9510563e092ba12a4115a06731c.tar.gz
gentoo-2-21070edc833ff9510563e092ba12a4115a06731c.tar.bz2
gentoo-2-21070edc833ff9510563e092ba12a4115a06731c.zip
bump to 1.5.6 (from overlay)
(Portage version: 2.1.3.12)
-rw-r--r--dev-php5/pecl-http/ChangeLog7
-rw-r--r--dev-php5/pecl-http/files/digest-pecl-http-1.5.63
-rw-r--r--dev-php5/pecl-http/pecl-http-1.5.6.ebuild40
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-php5/pecl-http/ChangeLog b/dev-php5/pecl-http/ChangeLog
index 3e1a006ca3d6..50c39d919ad8 100644
--- a/dev-php5/pecl-http/ChangeLog
+++ b/dev-php5/pecl-http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-http
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.7 2007/09/06 16:05:06 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.8 2007/10/10 20:56:45 anant Exp $
+
+*pecl-http-1.5.6 (11 Oct 2007)
+
+ 11 Oct 2007; Anant Narayanan <anant@gentoo.org> +pecl-http-1.5.6.ebuild:
+ bump to 1.5.6 (from overlay)
06 Sep 2007; Markus Ullmann <jokey@gentoo.org> -pecl-http-1.5.2.ebuild:
Cleanup
diff --git a/dev-php5/pecl-http/files/digest-pecl-http-1.5.6 b/dev-php5/pecl-http/files/digest-pecl-http-1.5.6
new file mode 100644
index 000000000000..337e7e045a03
--- /dev/null
+++ b/dev-php5/pecl-http/files/digest-pecl-http-1.5.6
@@ -0,0 +1,3 @@
+MD5 26115e3b845e8ae66a8ba33c9c5c2626 pecl_http-1.5.6.tgz 168420
+RMD160 9398bb62b1b3defcaadda5215efd555ba1f4331e pecl_http-1.5.6.tgz 168420
+SHA256 f40a4cc77e42e8ff57d90875e90e1145c8389311c2ea759615c825a755c0e2f6 pecl_http-1.5.6.tgz 168420
diff --git a/dev-php5/pecl-http/pecl-http-1.5.6.ebuild b/dev-php5/pecl-http/pecl-http-1.5.6.ebuild
new file mode 100644
index 000000000000..f77f6dbf90bc
--- /dev/null
+++ b/dev-php5/pecl-http/pecl-http-1.5.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.5.6.ebuild,v 1.1 2007/10/10 20:56:45 anant Exp $
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-misc/curl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression"
+
+ php-ext-pecl-r1_src_compile
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use --missing true =${PHP_PKG} hash iconv session spl ; then
+ elog "${PN} can optionally use hash, iconv, session and spl features."
+ elog "If you want those, recompile ${PHP_PKG} with those flags in USE."
+ fi
+}