summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-08-04 06:11:10 +0000
committerHans de Graaff <graaff@gentoo.org>2013-08-04 06:11:10 +0000
commit20dd4a109412580795628a25026793dc2213e93e (patch)
tree3837ddfd156a9177c8c4bb4c706e9d3edf36fde7
parentVersion bump to 1.7 series, see http://www.winehq.org/announce/1.7.0 for the ... (diff)
downloadgentoo-2-20dd4a109412580795628a25026793dc2213e93e.tar.gz
gentoo-2-20dd4a109412580795628a25026793dc2213e93e.tar.bz2
gentoo-2-20dd4a109412580795628a25026793dc2213e93e.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/ruby-prof/ChangeLog6
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.10.7.ebuild73
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.8.2-r1.ebuild71
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild71
4 files changed, 5 insertions, 216 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 5893723afb29..de106658dd18 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.35 2013/04/17 06:14:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.36 2013/08/04 06:11:10 graaff Exp $
+
+ 04 Aug 2013; Hans de Graaff <graaff@gentoo.org> -ruby-prof-0.8.2-r1.ebuild,
+ -ruby-prof-0.9.2.ebuild, -ruby-prof-0.10.7.ebuild:
+ Cleanup.
*ruby-prof-0.12.2 (17 Apr 2013)
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.10.7.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.10.7.ebuild
deleted file mode 100644
index 0cbd75397168..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.10.7.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.10.7.ebuild,v 1.1 2011/05/10 06:09:45 graaff Exp $
-
-EAPI=4
-
-# jruby → not compatible, since it uses an extension, but there is a bug
-# open for it: https://github.com/rdp/ruby-prof/issues/36
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/rdp/ruby-prof"
-SRC_URI="https://github.com/rdp/${PN}/tarball/${PV} -> ${P}.tgz"
-RUBY_S="rdp-${PN}-*"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.8.1 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
-# rm "${S}"/test/thread_test.rb \
-# || die "unable to remove broken test unit"
-# sed -i -e '/thread_test/d' \
-# test/test_suite.rb || die "unable to remove broken test reference"
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # On ruby 1.9 this test fails badly, so we disable it
- # until upstream can fix the related bug:
- # http://redmine.ruby-lang.org/issues/show/2012
- sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
- test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
- ;;
- esac
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext/ruby_prof || die "build failed"
-
- mkdir lib/ruby_prof || die "unable to create directory for shared object"
- cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc -r "$dir"/* || die "dodoc $dir failed"
- done
-}
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.8.2-r1.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.8.2-r1.ebuild
deleted file mode 100644
index 664bd9cd3f1b..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.8.2-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.8.2-r1.ebuild,v 1.1 2010/08/08 18:03:58 graaff Exp $
-
-EAPI=2
-
-# jruby → not compatible, since it uses an extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.8.1 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
- rm "${S}"/test/thread_test.rb \
- || die "unable to remove broken test unit"
- sed -i -e '/thread_test/d' \
- test/test_suite.rb || die "unable to remove broken test reference"
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # On ruby 1.9 this test fails badly, so we disable it
- # until upstream can fix the related bug:
- # http://redmine.ruby-lang.org/issues/show/2012
- sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
- test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
- ;;
- esac
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- # gem ships with prebuild files
- emake -Cext/ruby_prof clean || die "clean failed"
- emake -Cext/ruby_prof || die "build failed"
-
- mkdir lib/ruby_prof || die "unable to create directory for shared object"
- cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild
deleted file mode 100644
index fd03ac65681d..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild,v 1.1 2010/09/19 12:55:10 graaff Exp $
-
-EAPI=2
-
-# jruby → not compatible, since it uses an extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.8.1 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
- rm "${S}"/test/thread_test.rb \
- || die "unable to remove broken test unit"
- sed -i -e '/thread_test/d' \
- test/test_suite.rb || die "unable to remove broken test reference"
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # On ruby 1.9 this test fails badly, so we disable it
- # until upstream can fix the related bug:
- # http://redmine.ruby-lang.org/issues/show/2012
- sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
- test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
- ;;
- esac
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- # gem ships with prebuild files
- emake -Cext/ruby_prof clean || die "clean failed"
- emake -Cext/ruby_prof || die "build failed"
-
- mkdir lib/ruby_prof || die "unable to create directory for shared object"
- cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}