summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-07-22 14:25:53 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-07-22 14:25:53 +0000
commit1aa32c7339c59d55349ee91e1e970b752c441f3a (patch)
tree928a7c22d3e0cff2968722d0c6ac3489277c2758
parentBump patchset to include correct zzip headers, by Fabian Groffen <grobian@gen... (diff)
downloadgentoo-2-1aa32c7339c59d55349ee91e1e970b752c441f3a.tar.gz
gentoo-2-1aa32c7339c59d55349ee91e1e970b752c441f3a.tar.bz2
gentoo-2-1aa32c7339c59d55349ee91e1e970b752c441f3a.zip
Add patch to fix compilation on alpha
(Portage version: 2.1.6.13/cvs/Linux ia64)
-rw-r--r--dev-python/numpy/ChangeLog6
-rw-r--r--dev-python/numpy/files/numpy-1.3.0-alpha.patch24
-rw-r--r--dev-python/numpy/numpy-1.3.0.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 466de0cab185..399c9db3f90e 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.86 2009/07/20 01:53:46 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.87 2009/07/22 14:25:53 armin76 Exp $
+
+ 22 Jul 2009; Raúl Porcel <armin76@gentoo.org> numpy-1.3.0.ebuild,
+ +files/numpy-1.3.0-alpha.patch:
+ Add patch to fix compilation on alpha
20 Jul 2009; Jeremy Olexa <darkside@gentoo.org> numpy-1.3.0.ebuild:
amd64 stable, bug 277354
diff --git a/dev-python/numpy/files/numpy-1.3.0-alpha.patch b/dev-python/numpy/files/numpy-1.3.0-alpha.patch
new file mode 100644
index 000000000000..3aa5fe43a6de
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.3.0-alpha.patch
@@ -0,0 +1,24 @@
+diff -ur numpy-1.3.0.orig/numpy/core/include/numpy/npy_cpu.h numpy-1.3.0/numpy/core/include/numpy/npy_cpu.h
+--- numpy-1.3.0.orig/numpy/core/include/numpy/npy_cpu.h 2009-07-22 16:22:51.000000000 +0200
++++ numpy-1.3.0/numpy/core/include/numpy/npy_cpu.h 2009-07-22 16:23:18.000000000 +0200
+@@ -44,6 +44,8 @@
+ #define NPY_CPU_IA64
+ #elif defined(__hppa__)
+ #define NPY_CPU_PARISC
++#elif defined(__alpha__)
++ #define NPY_CPU_ALPHA
+ #else
+ #error Unknown CPU, please report this to numpy maintainers with \
+ information about your platform (OS, CPU and compiler)
+diff -ur numpy-1.3.0.orig/numpy/core/include/numpy/npy_endian.h numpy-1.3.0/numpy/core/include/numpy/npy_endian.h
+--- numpy-1.3.0.orig/numpy/core/include/numpy/npy_endian.h 2009-07-22 16:22:51.000000000 +0200
++++ numpy-1.3.0/numpy/core/include/numpy/npy_endian.h 2009-07-22 16:23:04.000000000 +0200
+@@ -22,7 +22,7 @@
+ #include "npy_cpu.h"
+
+ #if defined(NPY_CPU_X86) || defined(NPY_CPU_AMD64)\
+- || defined(NPY_CPU_IA64)
++ || defined(NPY_CPU_IA64) || defined(NPY_CPU_ALPHA)
+ #define NPY_LITTLE_ENDIAN
+ #define NPY_BYTE_ORDER 1234
+ #elif defined(NPY_CPU_PPC) || defined(NPY_CPU_SPARC)\ \ No newline at end of file
diff --git a/dev-python/numpy/numpy-1.3.0.ebuild b/dev-python/numpy/numpy-1.3.0.ebuild
index 64fce36f75be..b3d29f376b50 100644
--- a/dev-python/numpy/numpy-1.3.0.ebuild
+++ b/dev-python/numpy/numpy-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0.ebuild,v 1.5 2009/07/20 01:53:46 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0.ebuild,v 1.6 2009/07/22 14:25:53 armin76 Exp $
NEED_PYTHON=2.4
EAPI=2
@@ -44,6 +44,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.0-f2py.patch
epatch "${FILESDIR}/${P}-parisc.patch" # bug 277438
+ epatch "${FILESDIR}/${P}-alpha.patch" # bug 277438
# Gentoo patch for ATLAS library names
sed -i \