summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-06-26 14:13:54 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-06-26 14:13:54 +0000
commit17cc5dbf53bc2ac905c4f74bedd8726f575d84d4 (patch)
tree751bfd407c87c6f248241502b28b5035d7dcfbca
parentppc stable #315275 (diff)
downloadgentoo-2-17cc5dbf53bc2ac905c4f74bedd8726f575d84d4.tar.gz
gentoo-2-17cc5dbf53bc2ac905c4f74bedd8726f575d84d4.tar.bz2
gentoo-2-17cc5dbf53bc2ac905c4f74bedd8726f575d84d4.zip
Install within coin include dir, add static-libs, debug support, .la files removal, take over maintenance
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-libs/SoQt/ChangeLog13
-rw-r--r--media-libs/SoQt/SoQt-1.5.0-r1.ebuild53
-rw-r--r--media-libs/SoQt/SoQt-1.5.0.ebuild30
-rw-r--r--media-libs/SoQt/metadata.xml4
4 files changed, 64 insertions, 36 deletions
diff --git a/media-libs/SoQt/ChangeLog b/media-libs/SoQt/ChangeLog
index a92a82e154a9..e51253f30ffa 100644
--- a/media-libs/SoQt/ChangeLog
+++ b/media-libs/SoQt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/SoQt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/ChangeLog,v 1.29 2010/04/04 11:45:56 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/ChangeLog,v 1.30 2010/06/26 14:13:54 reavertm Exp $
+
+*SoQt-1.5.0-r1 (26 Jun 2010)
+
+ 26 Jun 2010; Maciej Mrozowski <reavertm@gentoo.org> -SoQt-1.5.0.ebuild,
+ +SoQt-1.5.0-r1.ebuild, metadata.xml:
+ Install within coin include dir, add static-libs, debug support, .la files
+ removal, take over maintenance
*SoQt-1.5.0 (04 Apr 2010)
@@ -99,11 +106,11 @@
Version bump
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
+
*SoQt-20010601-r1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
+
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/media-libs/SoQt/SoQt-1.5.0-r1.ebuild b/media-libs/SoQt/SoQt-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..9b7f1782bd4d
--- /dev/null
+++ b/media-libs/SoQt/SoQt-1.5.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-1.5.0-r1.ebuild,v 1.1 2010/06/26 14:13:54 reavertm Exp $
+
+EAPI="2"
+
+inherit base
+
+DESCRIPTION="The glue between Coin3D and Qt"
+SRC_URI="http://ftp.coin3d.org/coin/src/all/${P}.tar.gz"
+HOMEPAGE="http://www.coin3d.org/"
+
+LICENSE="|| ( GPL-2 PEL )"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc static-libs"
+
+RDEPEND="
+ >=media-libs/coin-3.1.3
+ virtual/glu
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(AUTHORS ChangeLog FAQ HACKING NEWS README)
+
+src_configure() {
+ econf \
+ htmldir="/usr/share/doc/${PF}/html" \
+ --disable-compact \
+ --disable-html-help \
+ --disable-loadlibrary \
+ --disable-man \
+ --enable-pkgconfig \
+ --includedir="/usr/include/coin" \
+ --with-coin \
+ $(use_enable debug) \
+ $(use_enable debug symbols) \
+ $(use_enable doc html) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ base_src_install
+
+ # Remove libtool files when not needed.
+ use static-libs || rm -f "${D}"/usr/lib*/*.la
+}
diff --git a/media-libs/SoQt/SoQt-1.5.0.ebuild b/media-libs/SoQt/SoQt-1.5.0.ebuild
deleted file mode 100644
index f6ba3d762566..000000000000
--- a/media-libs/SoQt/SoQt-1.5.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-1.5.0.ebuild,v 1.1 2010/04/04 11:45:56 tommy Exp $
-
-EAPI="2"
-
-inherit base
-
-DESCRIPTION="The glue between Coin3D and Qt"
-SRC_URI="http://ftp.coin3d.org/coin/src/all/${P}.tar.gz"
-HOMEPAGE="http://www.coin3d.org/"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 PEL )"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=media-libs/coin-3.1.2
- x11-libs/qt-gui:4
- x11-libs/qt-opengl:4"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( app-doc/doxygen )"
-
-DOCS=( "AUTHORS" "NEWS" "README" "FAQ" "HACKING" "ChangeLog" )
-
-src_configure() {
- econf --with-coin --disable-html-help $(use_enable doc html) htmldir=/usr/share/doc/${PF}/html
-}
diff --git a/media-libs/SoQt/metadata.xml b/media-libs/SoQt/metadata.xml
index a77d43ebb758..05d8790d135a 100644
--- a/media-libs/SoQt/metadata.xml
+++ b/media-libs/SoQt/metadata.xml
@@ -3,8 +3,6 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>tommy@gentoo.org</email>
- <name>Thomas Sachau</name>
- <description>Previous proxy committer, maintaining user left, feel free to take over</description>
+ <email>reavertm@gentoo.org</email>
</maintainer>
</pkgmetadata>