summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 21:53:32 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 21:53:32 +0000
commit16816e9097a79109a65d7a769705366fe4b0dfd0 (patch)
treece802ba9f8e776dc7427590fae0c673c6de8b76b
parentBump to KDE 3.5.8. (diff)
downloadgentoo-2-16816e9097a79109a65d7a769705366fe4b0dfd0.tar.gz
gentoo-2-16816e9097a79109a65d7a769705366fe4b0dfd0.tar.bz2
gentoo-2-16816e9097a79109a65d7a769705366fe4b0dfd0.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
-rw-r--r--kde-base/kaddressbook/ChangeLog8
-rw-r--r--kde-base/kaddressbook/files/digest-kaddressbook-3.5.83
-rw-r--r--kde-base/kaddressbook/kaddressbook-3.5.8.ebuild55
3 files changed, 65 insertions, 1 deletions
diff --git a/kde-base/kaddressbook/ChangeLog b/kde-base/kaddressbook/ChangeLog
index db00df389cb5..ce85ed4aa233 100644
--- a/kde-base/kaddressbook/ChangeLog
+++ b/kde-base/kaddressbook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kaddressbook
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.79 2007/08/11 16:57:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.80 2007/10/19 21:53:32 philantrop Exp $
+
+*kaddressbook-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +kaddressbook-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org> kaddressbook-3.5.7.ebuild:
x86 stable wrt #185823
diff --git a/kde-base/kaddressbook/files/digest-kaddressbook-3.5.8 b/kde-base/kaddressbook/files/digest-kaddressbook-3.5.8
new file mode 100644
index 000000000000..829a0a174fc3
--- /dev/null
+++ b/kde-base/kaddressbook/files/digest-kaddressbook-3.5.8
@@ -0,0 +1,3 @@
+MD5 a1ffff553f1d6739c7791891028b176b kdepim-3.5.8.tar.bz2 14107449
+RMD160 bb34c7e88227a1ebdd8ff38ee41445f85969175e kdepim-3.5.8.tar.bz2 14107449
+SHA256 433f8541af0a05e0a7e15df5ecca8463a29b6574871b941a8312b04b2233fef1 kdepim-3.5.8.tar.bz2 14107449
diff --git a/kde-base/kaddressbook/kaddressbook-3.5.8.ebuild b/kde-base/kaddressbook/kaddressbook-3.5.8.ebuild
new file mode 100644
index 000000000000..d537d7c3e51b
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-3.5.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.5.8.ebuild,v 1.1 2007/10/19 21:53:32 philantrop Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnokii"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/certmanager)
+$(deprange $PV $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/kontact)
+gnokii? ( app-mobilephone/gnokii )"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkcal libkcal
+ libkleopatra certmanager/lib/
+ libqgpgme libkdenetwork/qgpgme/
+ libkpinterfaces kontact/interfaces/"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ libkcal/
+ certmanager/
+ kontact/interfaces/
+ akregator
+ kmail/kmailIface.h"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/
+ akregator/src/librss"
+ # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
+KMEXTRA="
+ kabc/
+ kfile-plugins/vcf
+ kontact/plugins/kaddressbook"
+
+src_compile() {
+ myconf="$myconf $(use_with gnokii)"
+ export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd "${S}/libkcal/libical/src/libical" && make ical.h
+ # generate "icalss.h"
+ cd "${S}/libkcal/libical/src/libicalss" && make icalss.h
+
+ kde-meta_src_compile "make"
+}