summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-07-13 02:47:55 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-07-13 02:47:55 +0000
commit0e0a0b702253150f0495bd2b920dfb39ea58cac1 (patch)
treea262e679b935af097d4ac023b6f40c6ed415a491
parentexclude the fedora chk patch since it seems to break printf behavior #87631 (diff)
downloadgentoo-2-0e0a0b702253150f0495bd2b920dfb39ea58cac1.tar.gz
gentoo-2-0e0a0b702253150f0495bd2b920dfb39ea58cac1.tar.bz2
gentoo-2-0e0a0b702253150f0495bd2b920dfb39ea58cac1.zip
New ebuild.
(Portage version: 2.0.51.22-r1)
-rw-r--r--net-misc/astmanproxy/ChangeLog11
-rw-r--r--net-misc/astmanproxy/Manifest6
-rw-r--r--net-misc/astmanproxy/astmanproxy-1.1.ebuild45
-rw-r--r--net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff31
-rwxr-xr-xnet-misc/astmanproxy/files/astmanproxy.rc620
-rw-r--r--net-misc/astmanproxy/files/digest-astmanproxy-1.11
-rw-r--r--net-misc/astmanproxy/metadata.xml9
7 files changed, 123 insertions, 0 deletions
diff --git a/net-misc/astmanproxy/ChangeLog b/net-misc/astmanproxy/ChangeLog
new file mode 100644
index 000000000000..d22b4b60ab73
--- /dev/null
+++ b/net-misc/astmanproxy/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/astmanproxy
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/astmanproxy/ChangeLog,v 1.1 2005/07/13 02:47:55 stkn Exp $
+
+*astmanproxy-1.1 (13 Jul 2005)
+
+ 13 Jul 2005; Stefan Knoblich <stkn@gentoo.org> +metadata.xml,
+ +files/astmanproxy-1.1-gentoo.diff, +files/astmanproxy.rc6,
+ +astmanproxy-1.1.ebuild:
+ First version.
+
diff --git a/net-misc/astmanproxy/Manifest b/net-misc/astmanproxy/Manifest
new file mode 100644
index 000000000000..42245f9b5d4c
--- /dev/null
+++ b/net-misc/astmanproxy/Manifest
@@ -0,0 +1,6 @@
+MD5 17b4952fd69968e1475aa558d252950a astmanproxy-1.1.ebuild 783
+MD5 fa85b0a43a5888b385f789182fd1dc9f ChangeLog 121
+MD5 44cf247f04cc83413fcb40ed59d0847a metadata.xml 248
+MD5 5bbca9db1db666ffad0f311a8e144f3a files/digest-astmanproxy-1.1 77
+MD5 4670d4323365e584a57d8bfb44139d9b files/astmanproxy-1.1-gentoo.diff 1051
+MD5 a7b39422c5a73cc33f4ba24a5c9ce130 files/astmanproxy.rc6 378
diff --git a/net-misc/astmanproxy/astmanproxy-1.1.ebuild b/net-misc/astmanproxy/astmanproxy-1.1.ebuild
new file mode 100644
index 000000000000..c0456fc43b60
--- /dev/null
+++ b/net-misc/astmanproxy/astmanproxy-1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/astmanproxy/astmanproxy-1.1.ebuild,v 1.1 2005/07/13 02:47:55 stkn Exp $
+
+inherit eutils
+
+DESCRIPTION="Proxy for the Asterisk manager interface"
+HOMEPAGE="http://www.popvox.com/astmanproxy/"
+SRC_URI="http://www.popvox.com/${PN}/${P}-20050705-0643.tgz"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # small patch for cflags and path changes
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc README README.* VERSIONS astmanproxy.conf
+
+ docinto samples
+ dodoc samples/*
+
+ # fix permissions on config file
+ chmod 0640 ${D}/etc/astmanproxy.conf
+
+ newinitd ${FILESDIR}/astmanproxy.rc6 astmanproxy
+}
diff --git a/net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff b/net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff
new file mode 100644
index 000000000000..b713cdc7d514
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy-1.1-gentoo.diff
@@ -0,0 +1,31 @@
+--- astmanproxy-1.1/Makefile.orig 2005-07-13 04:35:49.000000000 +0200
++++ astmanproxy-1.1/Makefile 2005-07-13 04:37:43.000000000 +0200
+@@ -1,8 +1,8 @@
+ VERSION := 1.1
+ DESTDIR :=
+-PREFIX:= /usr/local
+-CONFDIR:=/etc/asterisk
+-CONFDIR_REAL := $(DESTDIR)/etc/asterisk
++PREFIX := /usr
++CONFDIR := /etc
++CONFDIR_REAL := $(DESTDIR)$(CONFDIR)
+
+ BINDIR := $(DESTDIR)$(PREFIX)/sbin
+ LIBDIR := $(DESTDIR)/usr/lib/astmanproxy
+@@ -14,7 +14,7 @@
+ DEFINES:='-DPROXY_VERSION="$(VERSION)"' '-DCDIR="$(CONFDIR)"' '-DCFILE="$(CONFFILE)"' '-DMDIR="$(MODDIR)"'
+
+ # Add -g below for debug/GDB symbols
+-CFLAGS := $(DEFINES) -Wall -O2 -rdynamic -D_REENTRANT
++CFLAGS += -Wall -rdynamic -D_REENTRANT -fPIC $(DEFINES)
+
+ CC := gcc
+ LD := ld
+--- astmanproxy-1.1/astmanproxy.conf.orig 2005-07-13 04:38:53.000000000 +0200
++++ astmanproxy-1.1/astmanproxy.conf 2005-07-13 04:38:59.000000000 +0200
+@@ -57,4 +57,4 @@
+ autofilter = on
+
+ ; location of logfile -- will be owned by proc_user/proc_group
+-logfile = /var/log/asterisk/astmanproxy.log
++logfile = /var/log/astmanproxy.log
diff --git a/net-misc/astmanproxy/files/astmanproxy.rc6 b/net-misc/astmanproxy/files/astmanproxy.rc6
new file mode 100755
index 000000000000..4a50b815ce7f
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy.rc6
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/astmanproxy/files/astmanproxy.rc6,v 1.1 2005/07/13 02:47:55 stkn Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting astmanproxy"
+ start-stop-daemon --start --exec /usr/sbin/astmanproxy
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping astmanproxy"
+ start-stop-daemon --stop --exec /usr/sbin/astmanproxy
+ eend $?
+}
diff --git a/net-misc/astmanproxy/files/digest-astmanproxy-1.1 b/net-misc/astmanproxy/files/digest-astmanproxy-1.1
new file mode 100644
index 000000000000..914fb09065b3
--- /dev/null
+++ b/net-misc/astmanproxy/files/digest-astmanproxy-1.1
@@ -0,0 +1 @@
+MD5 29027813c6d31126989fcb55ce0d7bb5 astmanproxy-1.1-20050705-0643.tgz 24471
diff --git a/net-misc/astmanproxy/metadata.xml b/net-misc/astmanproxy/metadata.xml
new file mode 100644
index 000000000000..10f27dc5e06a
--- /dev/null
+++ b/net-misc/astmanproxy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+ <name>Stefan Knoblich</name>
+</maintainer>
+</pkgmetadata>